summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorOlivier Fisette <ribosome@gentoo.org>2004-12-28 22:57:03 +0000
committerOlivier Fisette <ribosome@gentoo.org>2004-12-28 22:57:03 +0000
commite08b776d02ee7f955edf41a14eba2bb07c8b879a (patch)
treefae10c750bd83c6b5520dc635b69d86e1c2f3bab /sci-libs/ogdi/ogdi-3.1.1.ebuild
parentMoved dev-libs/libgeotiff to sci-libs/libgeotiff (diff)
downloadhistorical-e08b776d02ee7f955edf41a14eba2bb07c8b879a.tar.gz
historical-e08b776d02ee7f955edf41a14eba2bb07c8b879a.tar.bz2
historical-e08b776d02ee7f955edf41a14eba2bb07c8b879a.zip
Moved from dev-libs/ogdi to sci-libs/ogdi.
Diffstat (limited to 'sci-libs/ogdi/ogdi-3.1.1.ebuild')
-rw-r--r--sci-libs/ogdi/ogdi-3.1.1.ebuild50
1 files changed, 50 insertions, 0 deletions
diff --git a/sci-libs/ogdi/ogdi-3.1.1.ebuild b/sci-libs/ogdi/ogdi-3.1.1.ebuild
new file mode 100644
index 000000000000..641fe13443fb
--- /dev/null
+++ b/sci-libs/ogdi/ogdi-3.1.1.ebuild
@@ -0,0 +1,50 @@
+# Copyright 1999-2004 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sci-libs/ogdi/ogdi-3.1.1.ebuild,v 1.1 2004/12/28 22:57:03 ribosome Exp $
+
+DESCRIPTION="open geographical datastore interface"
+HOMEPAGE="http://ogdi.sourceforge.net"
+SRC_URI="mirror://sourceforge/ogdi/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="x86 ~sparc ~hppa ~alpha ~amd64 ~ppc ~ppc64"
+IUSE=""
+
+DEPEND="dev-libs/proj
+ sys-libs/zlib
+ dev-libs/expat"
+
+src_compile() {
+ export TOPDIR="${S}"
+ export TARGET="linux"
+ export CFG="release"
+ export LD_LIBRARY_PATH="${TOPDIR}/bin/${TARGET}"
+
+ ./configure \
+ --host=${CHOST} \
+ --prefix=/usr \
+ --infodir=/usr/share/info \
+ --mandir=/usr/share/man \
+ --with-proj \
+ --with-projlib=/usr/lib \
+ --with-projinc=/usr/include \
+ --with-zlib \
+ --with-zliblib=/usr/lib \
+ --with-zlibinc=/usr/include \
+ --with-expat \
+ --with-expatlib=/usr/lib \
+ --with-expatinc=/usr/include || die "./configure failed"
+ make || die "make failed"
+}
+
+src_install() {
+ make \
+ prefix=${D}usr \
+ mandir=${D}usr/share/man \
+ infodir=${D}usr/share/info \
+ TOPDIR="${S}" TARGET="linux" LD_LIBRARY_PATH="${TOPDIR}/bin/${TARGET}" \
+ install || die "make install failed"
+
+ dodoc ChangeLog LICENSE NEWS README VERSION
+}