summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMarkus Dittrich <markusle@gentoo.org>2007-10-16 22:23:43 +0000
committerMarkus Dittrich <markusle@gentoo.org>2007-10-16 22:23:43 +0000
commit444a1808e3ba9a2bab4746375e555d74d15f4715 (patch)
treec0550d4a56bbe40d8158c24c2da99f1a8ccbd8e7 /sci-libs
parentNew revision and removed obsolete version. (diff)
downloadhistorical-444a1808e3ba9a2bab4746375e555d74d15f4715.tar.gz
historical-444a1808e3ba9a2bab4746375e555d74d15f4715.tar.bz2
historical-444a1808e3ba9a2bab4746375e555d74d15f4715.zip
Version bump and removed old version.
Package-Manager: portage-2.1.3.13
Diffstat (limited to 'sci-libs')
-rw-r--r--sci-libs/blas-atlas/ChangeLog8
-rw-r--r--sci-libs/blas-atlas/blas-atlas-3.7.34.ebuild182
-rw-r--r--sci-libs/blas-atlas/blas-atlas-3.8.0.ebuild222
-rw-r--r--sci-libs/blas-atlas/files/digest-blas-atlas-3.7.346
-rw-r--r--sci-libs/blas-atlas/files/digest-blas-atlas-3.8.06
-rw-r--r--sci-libs/lapack-atlas/ChangeLog8
-rw-r--r--sci-libs/lapack-atlas/files/digest-lapack-atlas-3.7.349
-rw-r--r--sci-libs/lapack-atlas/files/digest-lapack-atlas-3.8.09
-rw-r--r--sci-libs/lapack-atlas/lapack-atlas-3.7.34.ebuild176
-rw-r--r--sci-libs/lapack-atlas/lapack-atlas-3.8.0.ebuild181
10 files changed, 432 insertions, 375 deletions
diff --git a/sci-libs/blas-atlas/ChangeLog b/sci-libs/blas-atlas/ChangeLog
index 43ef71db5cc5..fba79aa96da6 100644
--- a/sci-libs/blas-atlas/ChangeLog
+++ b/sci-libs/blas-atlas/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for sci-libs/blas-atlas
# Copyright 2002-2007 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sci-libs/blas-atlas/ChangeLog,v 1.67 2007/10/11 17:03:20 bicatali Exp $
+# $Header: /var/cvsroot/gentoo-x86/sci-libs/blas-atlas/ChangeLog,v 1.68 2007/10/16 22:22:19 markusle Exp $
+
+*blas-atlas-3.8.0 (14 Oct 2007)
+
+ 14 Oct 2007; Markus Dittrich <markusle@gentoo.org>
+ -blas-atlas-3.7.34.ebuild, +blas-atlas-3.8.0.ebuild:
+ Version bump and removed old version.
11 Oct 2007; Sébastien Fabbro <bicatali@gentoo.org>
blas-atlas-3.6.0-r1.ebuild, blas-atlas-3.6.0-r2.ebuild,
diff --git a/sci-libs/blas-atlas/blas-atlas-3.7.34.ebuild b/sci-libs/blas-atlas/blas-atlas-3.7.34.ebuild
deleted file mode 100644
index 3afc69971ad1..000000000000
--- a/sci-libs/blas-atlas/blas-atlas-3.7.34.ebuild
+++ /dev/null
@@ -1,182 +0,0 @@
-# Copyright 1999-2007 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sci-libs/blas-atlas/blas-atlas-3.7.34.ebuild,v 1.3 2007/10/11 17:03:20 bicatali Exp $
-
-inherit eutils toolchain-funcs fortran
-
-DESCRIPTION="Automatically Tuned Linear Algebra Software BLAS implementation"
-HOMEPAGE="http://math-atlas.sourceforge.net/"
-MY_PN=${PN/blas-/}
-SRC_URI="mirror://sourceforge/math-atlas/${MY_PN}${PV}.tar.bz2
- mirror://gentoo/${MY_PN}-${PV}-shared-libs.patch.bz2"
-
-LICENSE="BSD"
-SLOT="0"
-KEYWORDS="~alpha ~amd64 ~ppc ~ppc64 ~sparc ~x86"
-IUSE="doc"
-
-RDEPEND="app-admin/eselect-blas
- app-admin/eselect-cblas"
-DEPEND="${RDEPEND}
- >=sys-devel/libtool-1.5"
-
-S="${WORKDIR}/ATLAS"
-BLD_DIR="${S}/gentoo-build"
-RPATH="${DESTTREE}/$(get_libdir)/blas"
-FORTRAN="g77 gfortran"
-
-pkg_setup() {
- ewarn "You probably want to go for testing ${PN}, this version"
- ewarn "is particurlaly buggy, does not provide virtuals, and will go away soon."
- ewarn "Try ${PN} >= 3.7.39 for a working blas/cblas"
- epause 5
-
- fortran_pkg_setup
- echo
- ewarn "Please make sure to disable CPU throttling completely"
- ewarn "during the compile of blas-atlas. Otherwise, all atlas"
- ewarn "generated timings will be completely random and the"
- ewarn "performance of the resulting libraries will be degraded"
- ewarn "considerably."
- echo
- ewarn "For users of <=gcc-4.1.1 only:"
- ewarn "If you experience failing SANITY tests during"
- ewarn "atlas' compile please try passing -mfpmath=387; this"
- ewarn "option might also result in much better performance"
- ewarn "than using then sse instruction set depending on your"
- ewarn "CPU."
- echo
- epause 10
-}
-
-src_unpack() {
- unpack "${A}"
- cd "${S}"
-
- epatch "${DISTDIR}"/${MY_PN}-${PV}-shared-libs.patch.bz2
- epatch "${FILESDIR}"/${MY_PN}-asm-gentoo.patch
-
- # make sure shared libs link against proper libraries
- if [[ ${FORTRANC} == "gfortran" ]]; then
- libs="${LDFLAGS} -lpthread -lgfortran"
- else
- libs="${LDFLAGS} -lpthread -lg2c"
- fi
-
- #increase amount of workspace to improve threaded performance
- sed -e "s:16777216:167772160:" -i include/atlas_lvl3.h ||
- die "Failed to fix ATL_MaxMalloc"
-
- sed -e "s:SHRD_LNK:${libs}:g" -i Make.top || \
- die "Failed to add addtional libs to shared object build"
-
- sed -e "s:= gcc:= $(tc-getCC) ${CFLAGS}:" \
- -i CONFIG/src/SpewMakeInc.c || die "Failed to fix Spewmake"
-
- mkdir ${BLD_DIR} || die "failed to generate build directory"
- cp "${FILESDIR}"/war ${BLD_DIR} && chmod a+x ${BLD_DIR}/war || \
- die "failed to install war"
-
- # force proper 32/64bit libs
- local archselect
- if [[ "${ARCH}" == "amd64" || "${ARCH}" == "ppc64" ]]; then
- archselect="-b 64"
- elif [ "${ARCH}" == "alpha" ]; then
- archselect=""
- else
- archselect="-b 32"
- fi
-
- # set up compiler/flags using atlas' native configure
- local compdefs
- compdefs="${compdefs} -C xc '$(tc-getCC)' -F xc '${CFLAGS}'"
- compdefs="${compdefs} -C ic '$(tc-getCC)' -F ic '${CFLAGS}'"
- compdefs="${compdefs} -C sk '$(tc-getCC)' -F sk '${CFLAGS}'"
- compdefs="${compdefs} -C dk '$(tc-getCC)' -F dk '${CFLAGS}'"
- compdefs="${compdefs} -C sm '$(tc-getCC)' -F sm '${CFLAGS}'"
- compdefs="${compdefs} -C dm '$(tc-getCC)' -F dm '${CFLAGS}'"
- compdefs="${compdefs} -C if '${FORTRANC}' -F if '${FFLAGS}'"
- compdefs="${compdefs} -Ss pmake '\$(MAKE) ${MAKEOPTS}'"
- compdefs="${compdefs} -Si cputhrchk 0 ${archselect}"
-
- cd ${BLD_DIR} && ../configure ${compdefs} \
- || die "configure failed"
-}
-
-src_compile() {
- cd ${BLD_DIR}
- emake -j1 || die "make failed"
-
- make shared-strip RPATH=${RPATH}/atlas || \
- die "failed to build shared libraries"
-
- # build shared libraries of threaded libraries if applicable
- if [ -d gentoo/libptf77blas.a ]; then
- make ptshared-strip RPATH=${RPATH}/threaded-atlas || \
- die "failed to build threaded shared libraries"
- fi
-}
-
-src_install () {
- dodir "${RPATH}"/atlas
- cd ${BLD_DIR}/gentoo/libs
- cp -P libatlas* "${D}/${DESTTREE}/$(get_libdir)" || \
- die "Failed to install libatlas"
- cp -P *blas* "${D}/${RPATH}"/atlas || \
- die "Failed to install blas/cblas"
-
- eselect blas add $(get_libdir) "${FILESDIR}"/eselect.blas atlas
- eselect cblas add $(get_libdir) "${FILESDIR}"/eselect.cblas atlas
-
- if [ -d ${BLD_DIR}/gentoo/threaded-libs ]
- then
- dodir "${RPATH}"/threaded-atlas
- cd ${BLD_DIR}/gentoo/threaded-libs
- cp -P * "${D}/${RPATH}"/threaded-atlas || \
- die "Failed to install threaded atlas"
-
- eselect blas add $(get_libdir) "${FILESDIR}"/eselect.blas-threaded threaded-atlas
- eselect cblas add $(get_libdir) "${FILESDIR}"/eselect.cblas-threaded threaded-atlas
- fi
-
- insinto "${DESTTREE}"/include/atlas
- doins "${S}"/include/cblas.h "${S}"/include/atlas_misc.h \
- "${S}"/include/atlas_enum.h || \
- die "failed to install headers"
-
- # These headers contain the architecture-specific
- # optimizations determined by ATLAS. The atlas-lapack build
- # is much shorter if they are available, so save them:
- doins ${BLD_DIR}/include/*.h || \
- die "failed to install timing headers"
-
- #some docs
- cd "${S}"
- dodoc README doc/{AtlasCredits.txt,ChangeLog}
- use doc && dodoc doc/*.ps
-}
-
-pkg_postinst() {
- local THREADED
-
- if [ -d "${RPATH}"/threaded-atlas ]
- then
- THREADED="threaded-"
- fi
- if [[ -z "$(eselect blas show)" ]]; then
- eselect blas set ${THREADED}atlas
- fi
- if [[ -z "$(eselect cblas show)" ]]; then
- eselect cblas set ${THREADED}atlas
- fi
-
- elog
- elog "Fortran users link using -lblas"
- elog
- elog "C users compile against the header "${ROOT}"usr/include/atlas/cblas.h and"
- elog "link using -lcblas"
- elog
- elog "If using threaded ATLAS, you may also need to link with -lpthread."
- elog
- elog "Configuration now uses eselect rather than blas-config."
-}
diff --git a/sci-libs/blas-atlas/blas-atlas-3.8.0.ebuild b/sci-libs/blas-atlas/blas-atlas-3.8.0.ebuild
new file mode 100644
index 000000000000..702669d23d71
--- /dev/null
+++ b/sci-libs/blas-atlas/blas-atlas-3.8.0.ebuild
@@ -0,0 +1,222 @@
+# Copyright 1999-2007 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sci-libs/blas-atlas/blas-atlas-3.8.0.ebuild,v 1.1 2007/10/16 22:22:19 markusle Exp $
+
+inherit eutils toolchain-funcs fortran multilib
+
+PATCH_V="3.7.39"
+
+DESCRIPTION="Automatically Tuned Linear Algebra Software BLAS implementation"
+HOMEPAGE="http://math-atlas.sourceforge.net/"
+MY_PN=${PN/blas-/}
+SRC_URI="mirror://sourceforge/math-atlas/${MY_PN}${PV}.tar.bz2
+ mirror://gentoo/${MY_PN}-${PATCH_V}-shared-libs.patch.bz2"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~ppc ~ppc64 ~sparc ~x86"
+IUSE="doc"
+
+RDEPEND="app-admin/eselect-blas
+ app-admin/eselect-cblas
+ dev-util/pkgconfig
+ doc? ( app-doc/blas-docs )"
+
+DEPEND="app-admin/eselect-blas
+ app-admin/eselect-cblas
+ >=sys-devel/libtool-1.5"
+
+S="${WORKDIR}/ATLAS"
+
+pkg_setup() {
+ # icc won't compile (as of icc-10.0.026)
+ # and will blow out $PORTAGE_TMPDIR
+ if [[ $(tc-getCC) = icc* ]]; then
+ eerror "icc compiler is not supported with sci-libs/blas-atlas"
+ die "blas-atlas won't compile with icc"
+ fi
+
+ FORTRAN="g77 gfortran ifc"
+ fortran_pkg_setup
+ echo
+ ewarn "Please make sure to disable CPU throttling completely"
+ ewarn "during the compile of blas-atlas. Otherwise, all atlas"
+ ewarn "generated timings will be completely random and the"
+ ewarn "performance of the resulting libraries will be degraded"
+ ewarn "considerably."
+ echo
+ ewarn "For users of <=gcc-4.1.1 only:"
+ ewarn "If you experience failing SANITY tests during"
+ ewarn "atlas' compile please try passing -mfpmath=387; this"
+ ewarn "option might also result in much better performance"
+ ewarn "than using then sse instruction set depending on your"
+ ewarn "CPU."
+ echo
+ epause 10
+}
+
+src_unpack() {
+ unpack ${A}
+
+ cd "${S}"
+ epatch "${DISTDIR}"/${MY_PN}-${PATCH_V}-shared-libs.patch.bz2
+ epatch "${FILESDIR}"/${MY_PN}-asm-gentoo.patch
+ epatch "${FILESDIR}"/${MY_PN}-${PATCH_V}-decl-fix.patch
+
+ BLD_DIR="${S}"/gentoo-build
+ mkdir "${BLD_DIR}" || die "failed to generate build directory"
+ cd "${BLD_DIR}"
+ cp "${FILESDIR}"/war . && chmod a+x war || die "failed to install war"
+
+ local archselect=
+ if use amd64 || use ppc64; then
+ archselect="-b 64"
+ elif use alpha; then
+ archselect=""
+ else
+ archselect="-b 32"
+ fi
+
+ ../configure \
+ --cc="$(tc-getCC)" \
+ --cflags="${CFLAGS}" \
+ --prefix="${D}/${DESTTREE}" \
+ --libdir="${D}/${DESTTREE}"/$(get_libdir)/atlas \
+ --incdir="${D}/${DESTTREE}"/include \
+ -C ac "$(tc-getCC)" -F ac "${CFLAGS}" \
+ -C if ${FORTRANC} -F if "${FFLAGS:--O2}" \
+ -Ss pmake "\$(MAKE) ${MAKEOPTS}" \
+ -Si cputhrchk 0 ${archselect} \
+ || die "configure failed"
+}
+
+src_compile() {
+ cd "${BLD_DIR}"
+
+ # atlas does its own parallel builds
+ emake -j1 || die "emake failed"
+
+ RPATH="${DESTTREE}"/$(get_libdir)/blas
+ make \
+ LIBDIR=$(get_libdir) \
+ RPATH="${RPATH}"/atlas \
+ shared || die "failed to build shared libraries"
+
+ # build shared libraries of threaded libraries if applicable
+ if [[ -d gentoo/libptcblas.a ]]; then
+ make \
+ LIBDIR=$(get_libdir) \
+ RPATH="${RPATH}"/threaded-atlas \
+ ptshared || die "failed to build threaded shared libraries"
+ fi
+}
+
+src_test() {
+ # make check does not work because
+ # we don't build lapack libs
+ for i in F77 C; do
+ einfo "Testing ${i} interface"
+ cd "${BLD_DIR}"/interfaces/blas/${i}/testing
+ make sanity_test || die "emake tests for ${i} failed"
+ if [[ -d "${BLD_DIR}"/gentoo/libptf77blas.a ]]; then
+ make ptsanity_test || die "emake tests threaded for ${i}failed"
+ fi
+ done
+ echo "Timing ATLAS"
+ cd "${BLD_DIR}"
+ emake time || die "emake time failed"
+}
+
+src_install () {
+ dodir "${RPATH}"/atlas
+ cd "${BLD_DIR}"/gentoo/libs
+ cp -P libatlas* "${D}/${DESTTREE}"/$(get_libdir) \
+ || die "Failed to install libatlas"
+
+ # pkgconfig files
+ local extlibs="-lm"
+ local threadlibs
+ [[ ${FORTRANC} == gfortran ]] && extlibs="${extlibs} -lgfortran"
+ [[ ${FORTRANC} == g77 ]] && extlibs="${extlibs} -lg2c"
+ cp "${FILESDIR}"/blas.pc.in blas.pc
+ cp "${FILESDIR}"/cblas.pc.in cblas.pc
+ sed -i \
+ -e "s:@LIBDIR@:$(get_libdir):" \
+ -e "s:@PV@:${PV}:" \
+ -e "s:@EXTLIBS@:${extlibs}:g" \
+ -e "s:@THREADLIBS@:${threadlibs}:g" \
+ *blas.pc || die "sed *blas.pc failed"
+
+ cp -P *blas* "${D}/${RPATH}"/atlas \
+ || die "Failed to install blas/cblas"
+
+ ESELECT_PROF=atlas
+ eselect blas add $(get_libdir) "${FILESDIR}"/eselect.blas.atlas ${ESELECT_PROF}
+ eselect cblas add $(get_libdir) "${FILESDIR}"/eselect.cblas.atlas ${ESELECT_PROF}
+
+ if [[ -d "${BLD_DIR}"/gentoo/threaded-libs ]]; then
+ dodir "${RPATH}"/threaded-atlas
+ cd "${BLD_DIR}"/gentoo/threaded-libs
+
+ # pkgconfig files
+ cp "${FILESDIR}"/blas.pc.in blas.pc
+ cp "${FILESDIR}"/cblas.pc.in cblas.pc
+ threadlibs="-lpthread"
+ sed -i \
+ -e "s:@LIBDIR@:$(get_libdir):" \
+ -e "s:@PV@:${PV}:" \
+ -e "s:@EXTLIBS@:${extlibs}:g" \
+ -e "s:@THREADLIBS@:${threadlibs}:g" \
+ *blas.pc || die "sed *blas.pc failed"
+
+ cp -P * "${D}/${RPATH}"/threaded-atlas \
+ || die "Failed to install threaded atlas"
+ ESELECT_PROF=atlas-threads
+
+ eselect blas add $(get_libdir) "${FILESDIR}"/eselect.blas.threaded-atlas ${ESELECT_PROF}
+ eselect cblas add $(get_libdir) "${FILESDIR}"/eselect.cblas.threaded-atlas ${ESELECT_PROF}
+ fi
+
+ insinto "${DESTTREE}"/include/atlas
+ doins \
+ "${S}"/include/cblas.h \
+ "${S}"/include/atlas_misc.h \
+ "${S}"/include/atlas_enum.h \
+ || die "failed to install headers"
+
+ # These headers contain the architecture-specific
+ # optimizations determined by ATLAS. The atlas-lapack build
+ # is much shorter if they are available, so save them:
+ doins "${BLD_DIR}"/include/*.h \
+ || die "failed to install timing headers"
+
+ # some docs
+ cd "${S}"/doc
+ dodoc INDEX.txt AtlasCredits.txt ChangeLog || die "dodoc failed"
+ # atlas specific doc (blas generic docs installed by blas-docs)
+ if use doc; then
+ insinto /usr/share/doc/${PF}
+ doins atlas*pdf cblasqref.pdf || die "doins docs failed"
+ fi
+}
+
+pkg_postinst() {
+ for p in blas cblas; do
+ local current_p=$(eselect ${p} show | cut -d' ' -f2)
+ # this snippet works around the eselect bug #189942 and makes
+ # sure that users upgrading from a previous blas-atlas
+ # version pick up the new pkg-config files
+ if [[ ${current_p} == ${ESELECT_PROF} \
+ || ${current_p} == "threaded-atlas" \
+ || -z ${current_p} ]]; then
+ local configfile="${ROOT}"/etc/env.d/${p}/$(get_libdir)/config
+ [[ -e ${configfile} ]] && rm -f ${configfile}
+ eselect ${p} set ${ESELECT_PROF}
+ elog "${p} has been eselected to ${ESELECT_PROF}"
+ else
+ elog "Current eselected ${p} is ${current_p}"
+ elog "To use the ${p} ${ESELECT_PROF} implementation, you have to issue (as root):"
+ elog "\t eselect ${p} set ${ESELECT_PROF}"
+ fi
+ done
+}
diff --git a/sci-libs/blas-atlas/files/digest-blas-atlas-3.7.34 b/sci-libs/blas-atlas/files/digest-blas-atlas-3.7.34
deleted file mode 100644
index ec93a12e4467..000000000000
--- a/sci-libs/blas-atlas/files/digest-blas-atlas-3.7.34
+++ /dev/null
@@ -1,6 +0,0 @@
-MD5 6a37551621d91bd3495bc1718df0b9cd atlas-3.7.34-shared-libs.patch.bz2 6157
-RMD160 c898883344c421fa8290f7bbd759578ee6c60bed atlas-3.7.34-shared-libs.patch.bz2 6157
-SHA256 8d2fe80d4c368412bce30b2d6d9ce4017e9ab2d1e97f2fa2f8bff12c49748983 atlas-3.7.34-shared-libs.patch.bz2 6157
-MD5 2cb87f02e0d131138eef8049d5a854d1 atlas3.7.34.tar.bz2 2252847
-RMD160 b3c0b5ba49bd04da935bf6597ff727dcfc94711f atlas3.7.34.tar.bz2 2252847
-SHA256 6f29cc34266ceb9b5ee27276677281deba8438b00d4ace7c018b2b5aa5a9d333 atlas3.7.34.tar.bz2 2252847
diff --git a/sci-libs/blas-atlas/files/digest-blas-atlas-3.8.0 b/sci-libs/blas-atlas/files/digest-blas-atlas-3.8.0
new file mode 100644
index 000000000000..0a101b598533
--- /dev/null
+++ b/sci-libs/blas-atlas/files/digest-blas-atlas-3.8.0
@@ -0,0 +1,6 @@
+MD5 2923b57b4d67a25c2b76f5f32dba75f2 atlas-3.7.39-shared-libs.patch.bz2 6612
+RMD160 83d1167768e67128beccb88e6e291e0b63fd7837 atlas-3.7.39-shared-libs.patch.bz2 6612
+SHA256 c4f1c572a4506931c937d71f5b72709b36066e3c33b856a8a19444f72d2f9528 atlas-3.7.39-shared-libs.patch.bz2 6612
+MD5 fd42a00f36243bf4815d035b226ec305 atlas3.8.0.tar.bz2 2463051
+RMD160 16d52414c72f6a738823e0e93fdcd7dae8477bee atlas3.8.0.tar.bz2 2463051
+SHA256 e9131d8ffd2dfdd12312676e38183ca45a52547fad5498e46f90c95954bf121c atlas3.8.0.tar.bz2 2463051
diff --git a/sci-libs/lapack-atlas/ChangeLog b/sci-libs/lapack-atlas/ChangeLog
index f892408a4b95..ac0a3cbb7900 100644
--- a/sci-libs/lapack-atlas/ChangeLog
+++ b/sci-libs/lapack-atlas/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for sci-libs/lapack-atlas
# Copyright 2004-2007 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sci-libs/lapack-atlas/ChangeLog,v 1.48 2007/10/11 17:04:17 bicatali Exp $
+# $Header: /var/cvsroot/gentoo-x86/sci-libs/lapack-atlas/ChangeLog,v 1.49 2007/10/16 22:23:42 markusle Exp $
+
+*lapack-atlas-3.8.0 (14 Oct 2007)
+
+ 14 Oct 2007; Markus Dittrich <markusle@gentoo.org>
+ -lapack-atlas-3.7.34.ebuild, +lapack-atlas-3.8.0.ebuild:
+ Version bump and removed old version.
11 Oct 2007; Sébastien Fabbro <bicatali@gentoo.org>
lapack-atlas-3.7.39.ebuild:
diff --git a/sci-libs/lapack-atlas/files/digest-lapack-atlas-3.7.34 b/sci-libs/lapack-atlas/files/digest-lapack-atlas-3.7.34
deleted file mode 100644
index c40a27a11f69..000000000000
--- a/sci-libs/lapack-atlas/files/digest-lapack-atlas-3.7.34
+++ /dev/null
@@ -1,9 +0,0 @@
-MD5 6a37551621d91bd3495bc1718df0b9cd atlas-3.7.34-shared-libs.patch.bz2 6157
-RMD160 c898883344c421fa8290f7bbd759578ee6c60bed atlas-3.7.34-shared-libs.patch.bz2 6157
-SHA256 8d2fe80d4c368412bce30b2d6d9ce4017e9ab2d1e97f2fa2f8bff12c49748983 atlas-3.7.34-shared-libs.patch.bz2 6157
-MD5 2cb87f02e0d131138eef8049d5a854d1 atlas3.7.34.tar.bz2 2252847
-RMD160 b3c0b5ba49bd04da935bf6597ff727dcfc94711f atlas3.7.34.tar.bz2 2252847
-SHA256 6f29cc34266ceb9b5ee27276677281deba8438b00d4ace7c018b2b5aa5a9d333 atlas3.7.34.tar.bz2 2252847
-MD5 5feace3f4507a92ef822b2e0b50151d7 lapack-lite-3.1.1.tgz 5332509
-RMD160 d81baafd1f0f9859d9f75ac9b658f743544b5f5b lapack-lite-3.1.1.tgz 5332509
-SHA256 505a13272d0d71c45ea52be2de74b0562b234ea3ccf5160665c7a2ee74a58437 lapack-lite-3.1.1.tgz 5332509
diff --git a/sci-libs/lapack-atlas/files/digest-lapack-atlas-3.8.0 b/sci-libs/lapack-atlas/files/digest-lapack-atlas-3.8.0
new file mode 100644
index 000000000000..d1b85cfc539f
--- /dev/null
+++ b/sci-libs/lapack-atlas/files/digest-lapack-atlas-3.8.0
@@ -0,0 +1,9 @@
+MD5 2923b57b4d67a25c2b76f5f32dba75f2 atlas-3.7.39-shared-libs.patch.bz2 6612
+RMD160 83d1167768e67128beccb88e6e291e0b63fd7837 atlas-3.7.39-shared-libs.patch.bz2 6612
+SHA256 c4f1c572a4506931c937d71f5b72709b36066e3c33b856a8a19444f72d2f9528 atlas-3.7.39-shared-libs.patch.bz2 6612
+MD5 fd42a00f36243bf4815d035b226ec305 atlas3.8.0.tar.bz2 2463051
+RMD160 16d52414c72f6a738823e0e93fdcd7dae8477bee atlas3.8.0.tar.bz2 2463051
+SHA256 e9131d8ffd2dfdd12312676e38183ca45a52547fad5498e46f90c95954bf121c atlas3.8.0.tar.bz2 2463051
+MD5 5feace3f4507a92ef822b2e0b50151d7 lapack-lite-3.1.1.tgz 5332509
+RMD160 d81baafd1f0f9859d9f75ac9b658f743544b5f5b lapack-lite-3.1.1.tgz 5332509
+SHA256 505a13272d0d71c45ea52be2de74b0562b234ea3ccf5160665c7a2ee74a58437 lapack-lite-3.1.1.tgz 5332509
diff --git a/sci-libs/lapack-atlas/lapack-atlas-3.7.34.ebuild b/sci-libs/lapack-atlas/lapack-atlas-3.7.34.ebuild
deleted file mode 100644
index 3ba29ab93383..000000000000
--- a/sci-libs/lapack-atlas/lapack-atlas-3.7.34.ebuild
+++ /dev/null
@@ -1,176 +0,0 @@
-# Copyright 1999-2007 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sci-libs/lapack-atlas/lapack-atlas-3.7.34.ebuild,v 1.3 2007/10/10 10:04:59 markusle Exp $
-
-inherit eutils flag-o-matic toolchain-funcs fortran versionator
-
-MY_PN="${PN/lapack-/}"
-L_PN="lapack"
-L_PV="3.1.1"
-BlasRelease=$(get_version_component_range 1-3)
-
-DESCRIPTION="Full LAPACK implementation using available ATLAS routines"
-LICENSE="BSD"
-HOMEPAGE="http://math-atlas.sourceforge.net/"
-SRC_URI1="mirror://sourceforge/math-atlas/${MY_PN}${PV}.tar.bz2"
-SRC_URI2="http://www.netlib.org/${L_PN}/${L_PN}-lite-${L_PV}.tgz"
-SRC_URI="${SRC_URI1} ${SRC_URI2}
- mirror://gentoo/${MY_PN}-${PV}-shared-libs.patch.bz2"
-
-SLOT="0"
-IUSE="doc"
-KEYWORDS="~alpha ~amd64 ~ppc ~ppc64 ~sparc ~x86"
-
-RDEPEND="virtual/blas
- app-admin/eselect-lapack"
-
-DEPEND="${RDEPEND}
- >=sys-devel/libtool-1.5
- ~sci-libs/blas-atlas-${BlasRelease}"
-
-PROVIDE="virtual/lapack"
-
-FORTRAN="g77 gfortran"
-
-S="${WORKDIR}/ATLAS"
-S_LAPACK="${WORKDIR}/${L_PN}-lite-${L_PV}"
-BLD_DIR="${S}/gentoo-build"
-RPATH="${DESTTREE}/$(get_libdir)/${L_PN}/${MY_PN}"
-
-src_unpack() {
- unpack ${A}
- cd "${WORKDIR}"
-
- epatch "${DISTDIR}"/${MY_PN}-${PV}-shared-libs.patch.bz2
- epatch "${FILESDIR}"/${MY_PN}-asm-gentoo.patch
-
- cd "${S}"
- mkdir ${BLD_DIR} || die "failed to generate build directory"
- cp "${FILESDIR}"/war "${BLD_DIR}" && chmod a+x "${BLD_DIR}"/war \
- || die "failed to install war"
-
- # make sure the compile picks up the proper includes
- sed -e "s|INCLUDES =|INCLUDES = -I/usr/include/atlas/|" \
- -e "s:= gcc:= $(tc-getCC) ${CFLAGS}:" \
- -i CONFIG/src/SpewMakeInc.c || \
- die "failed to append proper includes"
-
- # force proper 32/64bit libs
- local archselect
- if [[ "${ARCH}" == "amd64" || "${ARCH}" == "ppc64" ]]; then
- archselect="-b 64"
- elif [ "${ARCH}" == "alpha" ]; then
- archselect=""
- else
- archselect="-b 32"
- fi
-
- # set up compiler/flags using atlas' native configure
- local compdefs
- compdefs="${compdefs} -C xc '$(tc-getCC)' -F xc '${CFLAGS}'"
- compdefs="${compdefs} -C ic '$(tc-getCC)' -F ic '${CFLAGS}'"
- compdefs="${compdefs} -C sk '$(tc-getCC)' -F sk '${CFLAGS}'"
- compdefs="${compdefs} -C dk '$(tc-getCC)' -F dk '${CFLAGS}'"
- compdefs="${compdefs} -C sm '$(tc-getCC)' -F sm '${CFLAGS}'"
- compdefs="${compdefs} -C dm '$(tc-getCC)' -F dm '${CFLAGS}'"
- compdefs="${compdefs} -C if '${FORTRANC}' -F if '${FFLAGS}'"
- compdefs="${compdefs} -Ss pmake '\$(MAKE) ${MAKEOPTS}'"
- compdefs="${compdefs} -Si cputhrchk 0 ${archselect}"
-
- cd ${BLD_DIR} && ../configure ${compdefs} \
- || die "configure failed"
-
- cd "${S_LAPACK}"
- epatch "${FILESDIR}"/${L_PN}-reference-${L_PV}-autotool.patch
- epatch "${FILESDIR}"/${L_PN}-reference-${L_PV}-test-fix.patch
- eautoreconf
-
- # set up the testing routines
- cp make.inc.example make.inc || die "Failed to copy make.inc"
- sed -e "s:g77:${FORTRANC}:" \
- -e "s:-funroll-all-loops -O3:${FFLAGS}:" \
- -e "s:LOADOPTS =:LOADOPTS = ${LDFLAGS}:" \
- -e "s:../../blas\$(PLAT).a:-lblas -lcblas:" \
- -e "s:lapack\$(PLAT).a:SRC/.libs/liblapack.a:" \
- -e "s:EXT_ETIME$:INT_CPU_TIME:" \
- -i make.inc || die "Failed to set up make.inc"
-}
-
-src_compile() {
- # build atlas' part of lapack
- cd "${BLD_DIR}"/src/lapack
- make lib || die "Failed to make lib in ${BLD_DIR}/src/lapack"
-
- cd "${BLD_DIR}"/interfaces/lapack/C/src
- make lib || die "Failed to make lib in ${BLD_DIR}/interfaces/lapack/C/src"
-
- cd "${BLD_DIR}"/interfaces/lapack/F77/src
- make lib || die "Failed to make lib in ${BLD_DIR}/interfaces/lapack/F77/src"
-
- # build rest of lapack
- cd "${S_LAPACK}"
- econf || die "Failed to configure reference lapack lib"
- emake || die "Failed to make reference lapack lib"
-
- cd "${S_LAPACK}"/SRC
- einfo "Copying liblapack.a/*.o to ${S_LAPACK}/SRC"
- cp -sf "${BLD_DIR}"/gentoo/liblapack.a/*.o .
- einfo "Copying liblapack.a/*.lo to ${S_LAPACK}/SRC"
- cp -sf "${BLD_DIR}"/gentoo/liblapack.a/*.lo .
- einfo "Copying liblapack.a/.libs/*.o to ${S_LAPACK}/SRC"
- cp -sf "${BLD_DIR}"/gentoo/liblapack.a/.libs/*.o .libs/
-
- # make sure shared libs link against proper libraries
- if [[ ${FORTRANC} == "gfortran" ]]; then
- libs="${LDFLAGS} -lpthread -lgfortran"
- else
- libs="${LDFLAGS} -lpthread -lg2c"
- fi
-
- ../libtool --mode=link --tag=F77 ${FORTRANC} -lblas -lcblas \
- -latlas ${libs} -o liblapack.la *.lo -rpath "${RPATH}" \
- || die "Failed to create liblapack.la"
-}
-
-src_install () {
- dodir "${RPATH}"
-
- cd "${S_LAPACK}"/SRC
- ../libtool --mode=install install -s liblapack.la \
- "${D}/${RPATH}" \
- || die "Failed to install lapack-atlas library"
-
- eselect lapack add $(get_libdir) "${FILESDIR}"/eselect.lapack atlas
-
- insinto /usr/include/atlas
- cd "${S}"/include
- doins clapack.h || die "Failed to install clapack.h"
-
- cd "${S}"
- dodoc README doc/AtlasCredits.txt doc/ChangeLog || \
- die "Failed to install docs"
- if use doc; then
- dodoc doc/lapackqref.pdf || die "Failed to install docs"
- fi
-}
-
-src_test() {
- cd "${S_LAPACK}"/TESTING/MATGEN && emake || \
- die "Failed to create tmglib.a"
- cd ../ && emake || die "lapack-reference tests failed."
-}
-
-pkg_postinst() {
- if [[ -z "$(eselect lapack show)" ]]; then
- eselect lapack set atlas
- fi
-
- elog
- elog "To link with ATLAS LAPACK from C or Fortran, simply use:"
- elog
- elog "-llapack"
- elog
- elog "C users: your header is /usr/include/atlas/clapack.h"
- elog
- elog "Configuration now uses eselect rather than lapack-config."
-}
diff --git a/sci-libs/lapack-atlas/lapack-atlas-3.8.0.ebuild b/sci-libs/lapack-atlas/lapack-atlas-3.8.0.ebuild
new file mode 100644
index 000000000000..f7541b60efcd
--- /dev/null
+++ b/sci-libs/lapack-atlas/lapack-atlas-3.8.0.ebuild
@@ -0,0 +1,181 @@
+# Copyright 1999-2007 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sci-libs/lapack-atlas/lapack-atlas-3.8.0.ebuild,v 1.1 2007/10/16 22:23:42 markusle Exp $
+
+inherit eutils flag-o-matic toolchain-funcs fortran autotools versionator
+
+MY_PN="${PN/lapack-/}"
+PATCH_V="3.7.39"
+L_PN="lapack"
+L_PV="3.1.1"
+BlasRelease=$(get_version_component_range 1-3)
+
+DESCRIPTION="F77 and C LAPACK implementations using available ATLAS routines"
+LICENSE="BSD"
+HOMEPAGE="http://math-atlas.sourceforge.net/"
+SRC_URI1="mirror://sourceforge/math-atlas/${MY_PN}${PV}.tar.bz2"
+SRC_URI2="http://www.netlib.org/${L_PN}/${L_PN}-lite-${L_PV}.tgz"
+SRC_URI="${SRC_URI1} ${SRC_URI2}
+ mirror://gentoo/${MY_PN}-${PATCH_V}-shared-libs.patch.bz2"
+
+SLOT="0"
+IUSE=""
+KEYWORDS="~alpha ~amd64 ~ppc ~ppc64 ~sparc ~x86"
+
+DEPEND="virtual/blas
+ virtual/cblas
+ app-admin/eselect-lapack
+ ~sci-libs/blas-atlas-${BlasRelease}
+ >=sys-devel/libtool-1.5"
+
+RDEPEND="${DEPEND}
+ dev-util/pkgconfig"
+# this has to wait until lapack-docs available on all arches
+# doc? ( app-doc/lapack-docs )"
+
+FORTRAN="g77 gfortran ifc"
+
+S="${WORKDIR}/ATLAS"
+S_LAPACK="${WORKDIR}/${L_PN}-lite-${L_PV}"
+BLD_DIR="${S}/gentoo-build"
+RPATH="${DESTTREE}/$(get_libdir)/${L_PN}/${MY_PN}"
+
+src_unpack() {
+ unpack ${A}
+
+ cd "${S}"
+ epatch "${DISTDIR}"/${MY_PN}-${PATCH_V}-shared-libs.patch.bz2
+ epatch "${FILESDIR}"/${MY_PN}-asm-gentoo.patch
+
+ # make sure the compile picks up the proper includes
+ sed -i \
+ -e "s|INCLUDES.*=|INCLUDES = -I/usr/include/atlas/|" \
+ "${S}"/CONFIG/src/SpewMakeInc.c \
+ || die "failed to append proper includes"
+
+ BLD_DIR="${S}"/gentoo-build
+ mkdir "${BLD_DIR}" || die "failed to generate build directory"
+ cd "${BLD_DIR}"
+ cp "${FILESDIR}"/war . && chmod a+x war || die "failed to install war"
+
+ # force proper 32/64bit libs
+ local archselect
+ if use amd64 || use ppc64; then
+ archselect="-b 64"
+ elif use alpha; then
+ archselect=""
+ else
+ archselect="-b 32"
+ fi
+
+ ../configure \
+ --cc="$(tc-getCC)" \
+ --cflags="${CFLAGS}" \
+ --prefix="${D}/${DESTTREE}" \
+ --libdir="${D}/${DESTTREE}"/$(get_libdir)/atlas \
+ --incdir="${D}/${DESTTREE}"/include \
+ -C ac "$(tc-getCC)" -F ac "${CFLAGS}" \
+ -C if ${FORTRANC} -F if "${FFLAGS:--O2}" \
+ -Ss pmake "\$(MAKE) ${MAKEOPTS}" \
+ -Si cputhrchk 0 ${archselect} \
+ || die "configure failed"
+
+ cd "${S_LAPACK}"
+ epatch "${FILESDIR}"/${L_PN}-reference-${L_PV}-autotool.patch
+ epatch "${FILESDIR}"/${L_PN}-reference-${L_PV}-test-fix.patch
+ eautoreconf
+
+ # set up the testing routines
+ sed -e "s:g77:${FORTRANC}:" \
+ -e "s:-funroll-all-loops -O3:${FFLAGS} $(pkg-config --cflags blas cblas):" \
+ -e "s:LOADOPTS =:LOADOPTS = ${LDFLAGS} $(pkg-config --cflags blas cblas):" \
+ -e "s:../../blas\$(PLAT).a:$(pkg-config --libs blas cblas):" \
+ -e "s:lapack\$(PLAT).a:SRC/.libs/liblapack.so -Wl,-rpath,${S_LAPACK}/SRC/.libs:" \
+ -e "s:EXT_ETIME$:INT_CPU_TIME:" \
+ make.inc.example > make.inc \
+ || die "Failed to set up make.inc"
+}
+
+src_compile() {
+ # build atlas' part of lapack
+ cd "${BLD_DIR}"
+ for d in src/lapack interfaces/lapack/C/src interfaces/lapack/F77/src; do
+ cd "${BLD_DIR}"/${d}
+ make lib || die "Failed to make lib in ${d}"
+ done
+
+ # build rest of lapack
+ S_LAPACK="${WORKDIR}"/${L_PN}-lite-${L_PV}
+ cd "${S_LAPACK}"
+ econf || die "Failed to configure reference lapack lib"
+ emake || die "Failed to make reference lapack lib"
+
+ cd "${S_LAPACK}"/SRC
+ einfo "Copying liblapack.a/*.o to ${S_LAPACK}/SRC"
+ cp -sf "${BLD_DIR}"/gentoo/liblapack.a/*.o .
+ einfo "Copying liblapack.a/*.lo to ${S_LAPACK}/SRC"
+ cp -sf "${BLD_DIR}"/gentoo/liblapack.a/*.lo .
+ einfo "Copying liblapack.a/.libs/*.o to ${S_LAPACK}/SRC"
+ cp -sf "${BLD_DIR}"/gentoo/liblapack.a/.libs/*.o .libs/
+
+ RPATH="${DESTTREE}"/$(get_libdir)/${L_PN}/${MY_PN}
+ local flibs
+ [[ ${FORTRANC} == gfortran ]] && flibs=-lgfortran
+ [[ ${FORTRANC} == g77 ]] && flibs=-lg2c
+ ../libtool --mode=link --tag=F77 ${FORTRANC} \
+ $(pkg-config --libs blas cblas) -latlas ${flibs} \
+ -o liblapack.la *.lo -rpath "${RPATH}" \
+ || die "Failed to create liblapack.la"
+
+ # making pkg-config file
+ sed -e "s:@LIBDIR@:$(get_libdir):" \
+ -e "s:@PV@:${PV}:" \
+ -e "s:@EXTLIBS@:-lm ${flibs}:g" \
+ "${FILESDIR}"/lapack.pc.in > "${S}"/lapack.pc \
+ || die "sed lapack.pc failed"
+}
+
+src_install () {
+ dodir "${RPATH}"
+
+ cd "${S_LAPACK}"/SRC
+ ../libtool --mode=install cp liblapack.la "${D}/${RPATH}" \
+ || die "Failed to install lapack-atlas library"
+
+ ESELECT_PROF=atlas
+ eselect lapack add $(get_libdir) "${FILESDIR}"/eselect.lapack.atlas ${ESELECT_PROF}
+
+ insinto /usr/include/atlas
+ doins "${S}"/include/clapack.h || die "Failed to install clapack.h"
+
+ cd "${S}"
+ dodoc README doc/AtlasCredits.txt doc/ChangeLog \
+ || die "Failed to install docs"
+
+ insinto /usr/$(get_libdir)/lapack/atlas
+ doins "${S}"/lapack.pc || die "Failed to install lapack.pc"
+}
+
+src_test() {
+ cd "${S_LAPACK}"/TESTING/MATGEN
+ emake || die "Failed to create tmglib.a"
+ cd ..
+ emake || die "lapack-reference tests failed"
+}
+
+pkg_postinst() {
+ local current_lib=$(eselect lapack show | cut -d' ' -f2)
+ # this snippet works around the eselect bug #189942 and makes
+ # sure that users upgrading from a previous lapack-atlas
+ # version pick up the new pkg-config files
+ if [[ ${current_lib} == ${ESELECT_PROF} || -z ${current_lib} ]]; then
+ local configfile="${ROOT}"/etc/env.d/lapack/$(get_libdir)/config
+ [[ -e ${configfile} ]] && rm -f ${configfile}
+ eselect lapack set ${ESELECT_PROF}
+ elog "lapack has been eselected to ${ESELECT_PROF}"
+ else
+ elog "Current eselected lapack is ${current_lib}"
+ elog "To use blas ${ESELECT_PROF} implementation, you have to issue (as root):"
+ elog "\t eselect lapack set ${ESELECT_PROF}"
+ fi
+}