summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSebastien Fabbro <bicatali@gentoo.org>2011-03-07 05:33:34 +0000
committerSebastien Fabbro <bicatali@gentoo.org>2011-03-07 05:33:34 +0000
commit67e23369be9bc6f052392dd72f294dc74d4812e7 (patch)
tree348ebf26af9ae4f5640fa7013e2f27bb4bc903b8 /sci-libs
parentVersion bump. Added static-libs flag. (diff)
downloadhistorical-67e23369be9bc6f052392dd72f294dc74d4812e7.tar.gz
historical-67e23369be9bc6f052392dd72f294dc74d4812e7.tar.bz2
historical-67e23369be9bc6f052392dd72f294dc74d4812e7.zip
Initial import
Package-Manager: portage-2.1.9.42/cvs/Linux x86_64
Diffstat (limited to 'sci-libs')
-rw-r--r--sci-libs/dsdp/ChangeLog10
-rw-r--r--sci-libs/dsdp/Manifest14
-rw-r--r--sci-libs/dsdp/dsdp-5.8.ebuild63
-rw-r--r--sci-libs/dsdp/metadata.xml21
4 files changed, 108 insertions, 0 deletions
diff --git a/sci-libs/dsdp/ChangeLog b/sci-libs/dsdp/ChangeLog
new file mode 100644
index 000000000000..70e69f3a195f
--- /dev/null
+++ b/sci-libs/dsdp/ChangeLog
@@ -0,0 +1,10 @@
+# ChangeLog for sci-libs/dsdp
+# Copyright 1999-2011 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/sci-libs/dsdp/ChangeLog,v 1.1 2011/03/07 05:33:34 bicatali Exp $
+
+*dsdp-5.8 (07 Mar 2011)
+
+ 07 Mar 2011; SĂ©bastien Fabbro <bicatali@gentoo.org> +dsdp-5.8.ebuild,
+ +metadata.xml:
+ Initial import
+
diff --git a/sci-libs/dsdp/Manifest b/sci-libs/dsdp/Manifest
new file mode 100644
index 000000000000..c7f5f07f1224
--- /dev/null
+++ b/sci-libs/dsdp/Manifest
@@ -0,0 +1,14 @@
+-----BEGIN PGP SIGNED MESSAGE-----
+Hash: SHA1
+
+DIST DSDP5.8.tar.gz 2608518 RMD160 fb5fa1d701800f34774e75715c1e115bc6539238 SHA1 b2be496b0cda2d35c3af69a7a82cee88a8742e64 SHA256 26aa624525a636de272c0b329e2dfd01a0d5b7827f1c1c76f393d71e37dead70
+EBUILD dsdp-5.8.ebuild 1832 RMD160 f2d1ec9df6c691048416cbc4b39702748ead2f34 SHA1 a1b8ad974250f8ee84b25569e68c589a0e5e67ca SHA256 e18ca2cf7ed5609f6c7ab76e8e018e2558679f259b675aacc0bd7b1f50fab4e0
+MISC ChangeLog 334 RMD160 5c0ed2701e358d49acd26c44240231ec6a19344c SHA1 7772284a80868a67427a55528a63f7926177ca6d SHA256 62060568bd09ee7ccd27076286e53c33f596d186a6a79d87a20c4032b21b4f62
+MISC metadata.xml 1139 RMD160 6c919f3f1a96cd3ab5cbbf499238c093ce414f8d SHA1 7fa65f34ae4e175ee88f6897b6ba423db045526a SHA256 3db43025b10ad9d1bb8b109f4ab2bdac456520be5e81dd92cb5a92bab76a816f
+-----BEGIN PGP SIGNATURE-----
+Version: GnuPG v2.0.17 (GNU/Linux)
+
+iEYEARECAAYFAk10bjcACgkQ1ycZbhPLE2AFewCglz5YrAMcpSpfdTp0bbvbdRXv
+4kwAn0TIGzFANoPjLvAVA/7ZCkAFKqoT
+=/8Us
+-----END PGP SIGNATURE-----
diff --git a/sci-libs/dsdp/dsdp-5.8.ebuild b/sci-libs/dsdp/dsdp-5.8.ebuild
new file mode 100644
index 000000000000..5c8b8e42d2b5
--- /dev/null
+++ b/sci-libs/dsdp/dsdp-5.8.ebuild
@@ -0,0 +1,63 @@
+# Copyright 1999-2011 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sci-libs/dsdp/dsdp-5.8.ebuild,v 1.1 2011/03/07 05:33:34 bicatali Exp $
+
+EAPI="4"
+inherit eutils toolchain-funcs versionator
+
+MYP=DSDP${PV}
+DESCRIPTION="Software for interior-point for semidefinite programming"
+HOMEPAGE="http://www.mcs.anl.gov/hs/software/DSDP"
+SRC_URI="${HOMEPAGE}/${MYP}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="doc examples"
+
+RDEPEND="virtual/lapack"
+DEPEND="${RDEPEND}
+ dev-util/pkgconfig"
+
+S="${WORKDIR}/${MYP}"
+
+make_shared_lib() {
+ local soname=$(basename "${1%.a}").so.$(get_major_version)
+ einfo "Making ${soname}"
+ ${2:-$(tc-getCC)} ${LDFLAGS} \
+ -shared -Wl,-soname="${soname}" \
+ -Wl,--whole-archive "${1}" -Wl,--no-whole-archive \
+ -o $(dirname "${1}")/"${soname}" || return 1
+}
+
+src_prepare() {
+ # to do proper parallel compilation
+ find . -name Makefile -exec \
+ sed -i -e 's:make :$(MAKE) :g' '{}' \;
+ sed -i \
+ -e "s:#\(DSDPROOT[[:space:]]*=\).*:\1${S}:" \
+ -e "s:\(CC[[:space:]]*=\).*:\1$(tc-getCC):" \
+ -e "s:\(OPTFLAGS[[:space:]]*=\).*:\1${CFLAGS}:" \
+ -e "s:\(CLINKER[[:space:]]*=\).*:\1 \${CC} ${LDFLAGS}:" \
+ -e "s:\(LAPACKBLAS[[:space:]]*=\).*:\1 $(pkg-config --libs blas lapack):" \
+ -e "s:\(^ARCH[[:space:]]*=\).*:\1$(tc-getAR) cr:" \
+ -e "s:\(^RANLIB[[:space:]]*=\).*:\1$(tc-getRANLIB):" \
+ make.include || die
+}
+
+src_compile() {
+ emake OPTFLAGS="${CFLAGS} -fPIC" dsdplibrary
+ make_shared_lib lib/lib${PN}.a || die "doing shared lib failed"
+}
+
+src_test() {
+ emake -j1 example test
+}
+
+src_install() {
+ dolib.so lib/lib${PN}.so.$(get_major_version)
+ dosym lib${PN}.so.$(get_major_version) /usr/$(get_libdir)/lib${PN}.so
+ insinto /usr/share/doc/${PF}
+ use doc && dodoc docs/*.pdf
+ use examples && doins -r examples
+}
diff --git a/sci-libs/dsdp/metadata.xml b/sci-libs/dsdp/metadata.xml
new file mode 100644
index 000000000000..e5d1e51d7219
--- /dev/null
+++ b/sci-libs/dsdp/metadata.xml
@@ -0,0 +1,21 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+<herd>sci</herd>
+<longdescription lang="en">
+ The DSDP software is a free open source implementation of an
+ interior-point method for semidefinite programming. It provides
+ primal and dual solutions, exploits low-rank structure and sparsity
+ in the data, and has relatively low memory requirements for an
+ interior-point method. It allows feasible and infeasible starting
+ points and provides approximate certificates of infeasibility when
+ no feasible solution exists. The dual-scaling algorithm implemented
+ in this package has a convergence proof and worst-case polynomial
+ complexity under mild assumptions on the data. Furthermore, the
+ solver offers scalable parallel performance for large problems and a
+ well documented interface. Some of the most popular applications of
+ semidefinite programming and linear matrix inequalities (LMI) are
+ model control, truss topology design, and semidefinite relaxations
+ of combinatorial and global optimization problems.
+</longdescription>
+</pkgmetadata>