summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMark Wright <gienah@gentoo.org>2014-02-11 14:30:11 +0000
committerMark Wright <gienah@gentoo.org>2014-02-11 14:30:11 +0000
commit81154f0730103acf9f245625478e20114268ddc8 (patch)
treebbc7e525249ed6233840e612d593223373596258 /sci-mathematics/kodkod/kodkod-1.5.2.ebuild
parentStable for amd64 wrt bug #499838 (diff)
downloadhistorical-81154f0730103acf9f245625478e20114268ddc8.tar.gz
historical-81154f0730103acf9f245625478e20114268ddc8.tar.bz2
historical-81154f0730103acf9f245625478e20114268ddc8.zip
Fix bug 458462 - sci-mathematics/kodkod-1.5.2: fails to build with JAVA_PKG_STRICT, fix by me. Remove dosym which was a workaround to EAPI 5 subslot depends that has since been fixed in the java eclasses.
Package-Manager: portage-2.2.8-r1/cvs/Linux x86_64 Manifest-Sign-Key: 0x618E971F
Diffstat (limited to 'sci-mathematics/kodkod/kodkod-1.5.2.ebuild')
-rw-r--r--sci-mathematics/kodkod/kodkod-1.5.2.ebuild32
1 files changed, 29 insertions, 3 deletions
diff --git a/sci-mathematics/kodkod/kodkod-1.5.2.ebuild b/sci-mathematics/kodkod/kodkod-1.5.2.ebuild
index fe3a5f32b2c5..28686a339a36 100644
--- a/sci-mathematics/kodkod/kodkod-1.5.2.ebuild
+++ b/sci-mathematics/kodkod/kodkod-1.5.2.ebuild
@@ -1,6 +1,6 @@
-# Copyright 1999-2013 Gentoo Foundation
+# Copyright 1999-2014 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sci-mathematics/kodkod/kodkod-1.5.2.ebuild,v 1.2 2013/02/02 13:22:28 gienah Exp $
+# $Header: /var/cvsroot/gentoo-x86/sci-mathematics/kodkod/kodkod-1.5.2.ebuild,v 1.3 2014/02/11 14:29:54 gienah Exp $
EAPI="5"
@@ -48,6 +48,23 @@ src_prepare() {
|| die "Could not fix wscripts to respect LDFLAGS"
# Fix bug 453162 - sci-mathematics/kodkod-1.5.2: fails to build
epatch "${FILESDIR}/${PN}-1.5.2-changes-in-most-specific-varargs-method-selection.patch"
+
+ # Fix Bug 458462 sci-mathematics/kodkod-1.5.2: fails to build with JAVA_PKG_STRICT
+ local x=""
+ for i in $JAVACFLAGS
+ do
+ if [ "${x}" == "" ]; then
+ x="'${i}'"
+ else
+ x="${x}, '${i}'"
+ fi
+ done
+ for j in $(find . -name wscript -print)
+ do
+ sed -e "s@def configure(conf):@def configure(conf):\n conf.env.JAVACFLAGS = [${x}]@" \
+ -i "${j}" \
+ || die "Could not set JAVACFLAGS in ${j}"
+ done
}
# note: kodkod waf fails when passed --libdir:
@@ -64,6 +81,16 @@ src_configure() {
configure || die "configure failed"
}
+src_compile() {
+ waf-utils_src_compile
+ if has doc ${JAVA_PKG_IUSE} && use doc; then
+ pushd src/kodkod || die "Could not cd to src/kodkod"
+ javadoc $(find . -name \*.java -print) \
+ || die "javadoc failed"
+ popd
+ fi
+}
+
src_install() {
insinto "/usr/"$(get_libdir)
dodir ${LIBDIR}
@@ -76,7 +103,6 @@ src_install() {
einfo "java-pkg_dojar $i"
java-pkg_dojar $i
done
- dosym "/usr/share/${PN}-${SLOT}/package.env" "/usr/share/${PN}/package.env"
# javadoc
if has doc ${JAVA_PKG_IUSE} && use doc; then