summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMark Wright <gienah@gentoo.org>2012-05-30 00:53:38 +0000
committerMark Wright <gienah@gentoo.org>2012-05-30 00:53:38 +0000
commitc55fdd8ad6ce0b72ab60b5145e53f36ad117bfb8 (patch)
tree29418eb10f0ea77c834c0b96be3d0647a87574bb /sci-mathematics
parentAdd CVC3 automatic theorem prover, with optional Isabelle/HOL integration. (diff)
downloadhistorical-c55fdd8ad6ce0b72ab60b5145e53f36ad117bfb8.tar.gz
historical-c55fdd8ad6ce0b72ab60b5145e53f36ad117bfb8.tar.bz2
historical-c55fdd8ad6ce0b72ab60b5145e53f36ad117bfb8.zip
Add SPASS automated theorem prover, with optional Isabelle/HOL sledgehammer integration.
Package-Manager: portage-2.1.10.63/cvs/Linux x86_64
Diffstat (limited to 'sci-mathematics')
-rw-r--r--sci-mathematics/spass/ChangeLog10
-rw-r--r--sci-mathematics/spass/metadata.xml15
-rw-r--r--sci-mathematics/spass/spass-3.7.ebuild80
3 files changed, 105 insertions, 0 deletions
diff --git a/sci-mathematics/spass/ChangeLog b/sci-mathematics/spass/ChangeLog
new file mode 100644
index 000000000000..1a1431a80982
--- /dev/null
+++ b/sci-mathematics/spass/ChangeLog
@@ -0,0 +1,10 @@
+# ChangeLog for sci-mathematics/spass
+# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/sci-mathematics/spass/ChangeLog,v 1.1 2012/05/30 00:53:38 gienah Exp $
+
+*spass-3.7 (30 May 2012)
+
+ 30 May 2012; Mark Wright <gienah@gentoo.org> +metadata.xml, +spass-3.7.ebuild:
+ Add SPASS automated theorem prover, with optional Isabelle/HOL sledgehammer
+ integration.
+
diff --git a/sci-mathematics/spass/metadata.xml b/sci-mathematics/spass/metadata.xml
new file mode 100644
index 000000000000..c4c803fffe24
--- /dev/null
+++ b/sci-mathematics/spass/metadata.xml
@@ -0,0 +1,15 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+<maintainer>
+ <email>gienah@gentoo.org></email>
+</maintainer>
+<herd>sci-mathematics</herd>
+<longdescription lang='en'>
+SPASS: An Automated Theorem Prover for First-Order Logic with Equality.
+</longdescription>
+<use>
+ <flag name='isabelle'>Add integration support for the Isabelle/HOL
+ theorem prover.</flag>
+</use>
+</pkgmetadata>
diff --git a/sci-mathematics/spass/spass-3.7.ebuild b/sci-mathematics/spass/spass-3.7.ebuild
new file mode 100644
index 000000000000..b2c167570ec6
--- /dev/null
+++ b/sci-mathematics/spass/spass-3.7.ebuild
@@ -0,0 +1,80 @@
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sci-mathematics/spass/spass-3.7.ebuild,v 1.1 2012/05/30 00:53:38 gienah Exp $
+
+EAPI="4"
+
+inherit versionator
+
+MY_PV=$(delete_all_version_separators "${PV}")
+MY_P="${PN}${MY_PV}"
+
+DESCRIPTION="An Automated Theorem Prover for First-Order Logic with Equality"
+HOMEPAGE="http://www.spass-prover.org/"
+SRC_URI="http://www.spass-prover.org/download/sources/${MY_P}.tgz"
+
+LICENSE="BSD-2"
+SLOT="0"
+KEYWORDS="~x86 ~amd64"
+IUSE="doc isabelle"
+
+RDEPEND=""
+DEPEND="${RDEPEND}
+ isabelle? (
+ >=sci-mathematics/isabelle-2011.1-r1
+ )"
+
+S="${WORKDIR}/SPASS-${PV}"
+
+src_install() {
+ emake DESTDIR="${D}" install
+
+ if use examples; then
+ dodir /usr/share/${PN}/examples
+ insinto /usr/share/${PN}/examples
+ doins -r examples
+ fi
+
+ if use isabelle; then
+ ISABELLE_HOME="$(isabelle getenv ISABELLE_HOME | cut -d'=' -f 2)" \
+ || die "isabelle getenv ISABELLE_HOME failed"
+ if [[ -z "${ISABELLE_HOME}" ]]; then
+ die "ISABELLE_HOME empty"
+ fi
+ dodir "${ISABELLE_HOME}/contrib/${PN}-${PV}/etc"
+ cat <<- EOF >> "${S}/settings"
+ SPASS_HOME="${ROOT}usr/bin"
+ SPASS_VERSION="${PV}"
+ EOF
+ insinto "${ISABELLE_HOME}/contrib/${PN}-${PV}/etc"
+ doins "${S}/settings"
+ fi
+}
+
+pkg_postinst() {
+ if use isabelle; then
+ if [ -f "${ROOT}etc/isabelle/components" ]; then
+ if egrep "contrib/${PN}-[0-9.]*" "${ROOT}etc/isabelle/components"; then
+ sed -e "/contrib\/${PN}-[0-9.]*/d" \
+ -i "${ROOT}etc/isabelle/components"
+ fi
+ cat <<- EOF >> "${ROOT}etc/isabelle/components"
+ contrib/${PN}-${PV}
+ EOF
+ fi
+ fi
+}
+
+pkg_postrm() {
+ if use isabelle; then
+ if [ ! -f "${ROOT}usr/bin/SPASS" ]; then
+ if [ -f "${ROOT}etc/isabelle/components" ]; then
+ # Note: this sed should only match the version of this ebuild
+ # Which is what we want as we do not want to remove the line
+ # of a new E being installed during an upgrade.
+ sed -e "/contrib\/${PN}-${PV}/d" \
+ -i "${ROOT}etc/isabelle/components"
+ fi
+ fi
+ fi
+}