summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSamuli Suominen <ssuominen@gentoo.org>2013-02-08 17:33:43 +0000
committerSamuli Suominen <ssuominen@gentoo.org>2013-02-08 17:33:43 +0000
commit74b1ad618f94e846f5f46109b5f6ded4f7a787ee (patch)
tree65f5ca8d6513cc1b820120df9fa01692412abbfa /sys-apps/hotplug/hotplug-20040923-r1.ebuild
parentInitial import (diff)
downloadhistorical-74b1ad618f94e846f5f46109b5f6ded4f7a787ee.tar.gz
historical-74b1ad618f94e846f5f46109b5f6ded4f7a787ee.tar.bz2
historical-74b1ad618f94e846f5f46109b5f6ded4f7a787ee.zip
No more hotplug.
Diffstat (limited to 'sys-apps/hotplug/hotplug-20040923-r1.ebuild')
-rw-r--r--sys-apps/hotplug/hotplug-20040923-r1.ebuild71
1 files changed, 0 insertions, 71 deletions
diff --git a/sys-apps/hotplug/hotplug-20040923-r1.ebuild b/sys-apps/hotplug/hotplug-20040923-r1.ebuild
deleted file mode 100644
index 001bcf5e3df8..000000000000
--- a/sys-apps/hotplug/hotplug-20040923-r1.ebuild
+++ /dev/null
@@ -1,71 +0,0 @@
-# Copyright 1999-2012 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-apps/hotplug/hotplug-20040923-r1.ebuild,v 1.6 2012/06/04 01:12:43 ssuominen Exp $
-
-inherit eutils
-
-# source maintainers named it hotplug-YYYY_MM_DD instead of hotplug-YYYYMMDD
-MY_P=${PN}-${PV:0:4}_${PV:4:2}_${PV:6:2}
-S=${WORKDIR}/${MY_P}
-DESCRIPTION="USB and PCI hotplug scripts"
-HOMEPAGE="http://linux-hotplug.sourceforge.net"
-SRC_URI="mirror://kernel/linux/utils/kernel/hotplug/${MY_P}.tar.gz"
-
-LICENSE="GPL-2"
-SLOT="0"
-KEYWORDS="alpha amd64 arm hppa ia64 m68k ~mips ppc ppc64 s390 sh sparc x86"
-IUSE=""
-
-# hotplug needs pcimodules utility provided by pcitutils-2.1.9-r1
-DEPEND=">=sys-apps/pciutils-2.1.9
- >=sys-apps/usbutils-0.9
- sys-apps/hotplug-base"
-
-src_unpack() {
- unpack ${A}
- cd "${S}"
- epatch "${FILESDIR}"/${PN}-ifrename.patch
- epatch "${FILESDIR}"/${P}-scsi-agent-timeout.patch
-}
-
-src_install() {
- into /
- doman *.8
- dodoc README README.modules ChangeLog
-
- cd "${S}"/etc/hotplug
- insinto /etc/hotplug
- doins blacklist hotplug.functions *map || die
-
- exeinto /etc/hotplug
- doexe *.agent *.rc *.permissions || die
- # stupid isapnp.rc files...
- touch "${T}"/isapnp.rc.empty
- newexe "${T}"/isapnp.rc.empty isapnp.rc
-
- dodir /usr/lib/hotplug/firmware
- dodir /etc/hotplug/usb
- dodir /etc/hotplug/pci
- cd "${S}"/etc/hotplug.d/default
- exeinto /etc/hotplug.d/default
- doexe default.hotplug || die
-
- newinitd "${FILESDIR}"/hotplug.rc.empty hotplug
- newconfd "${FILESDIR}"/usb.confd usb
- dodir /var/run/usb
-}
-
-pkg_postinst() {
- ewarn "WARNING: The hotplug init script is now gone (dead and burried.)"
- ewarn "WARNING: If you want to load modules for hardware that was already"
- ewarn "WARNING: discovered at boot time, like the old hotplug init script"
- ewarn "WARNING: did, then emerge the coldplug package, and add coldplug to"
- ewarn "WARNING: a runlevel, e.g. # rc-update add coldplug boot"
- echo
- ewarn "WARNING: All firmware loaded by the hotplug scripts needs to be"
- ewarn "WARNING: moved to the /lib/firmware directory, as the scripts now"
- ewarn "WARNING: expect it to be in that location."
- echo
- ewarn "If you still have the file /etc/hotplug/isapnp.rc on your system,"
- ewarn "please delete it by hand, the file /etc/hotplug/pnp.rc superseeds it."
-}