summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMike Frysinger <vapier@gentoo.org>2002-10-19 03:42:44 +0000
committerMike Frysinger <vapier@gentoo.org>2002-10-19 03:42:44 +0000
commit6d29016c2cdaf9082860c3cba02855c5424bdd62 (patch)
treeb9b8955252d26c5093cd9a4ea18c67ce1bcae9ae /sys-apps/hotplug
parentlintool fixes for #9258 (diff)
downloadhistorical-6d29016c2cdaf9082860c3cba02855c5424bdd62.tar.gz
historical-6d29016c2cdaf9082860c3cba02855c5424bdd62.tar.bz2
historical-6d29016c2cdaf9082860c3cba02855c5424bdd62.zip
lintool fixes for #9258
Diffstat (limited to 'sys-apps/hotplug')
-rw-r--r--sys-apps/hotplug/hotplug-20020114.ebuild9
-rw-r--r--sys-apps/hotplug/hotplug-20020401.ebuild13
2 files changed, 11 insertions, 11 deletions
diff --git a/sys-apps/hotplug/hotplug-20020114.ebuild b/sys-apps/hotplug/hotplug-20020114.ebuild
index ff7caf59e373..7c644d9985e4 100644
--- a/sys-apps/hotplug/hotplug-20020114.ebuild
+++ b/sys-apps/hotplug/hotplug-20020114.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2002 Gentoo Technologies, Inc.
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-apps/hotplug/hotplug-20020114.ebuild,v 1.7 2002/10/04 06:25:56 vapier Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-apps/hotplug/hotplug-20020114.ebuild,v 1.8 2002/10/19 03:42:44 vapier Exp $
# source maintainers named it hotplug-YYYY_MM_DD instead of hotplug-YYYYMMDD
S=${WORKDIR}/${P}
@@ -15,8 +15,9 @@ LICENSE="GPL-2"
DEPEND="virtual/glibc
>=sys-apps/pciutils-2.1.9
>=sys-apps/usbutils-0.9"
+RDEPEND="${DEPEND}"
-src_unpack () {
+src_unpack() {
unpack ${A}
# move it to dir which matches ebuild name
@@ -28,13 +29,11 @@ src_unpack () {
}
src_compile() {
-
# compile fxload program
make PREFIX="" all || die
-
}
-src_install () {
+src_install() {
into /
dosbin sbin/hotplug
doman *.8
diff --git a/sys-apps/hotplug/hotplug-20020401.ebuild b/sys-apps/hotplug/hotplug-20020401.ebuild
index 25ad710561df..0fe863dd6592 100644
--- a/sys-apps/hotplug/hotplug-20020401.ebuild
+++ b/sys-apps/hotplug/hotplug-20020401.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2002 Gentoo Technologies, Inc.
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-apps/hotplug/hotplug-20020401.ebuild,v 1.5 2002/10/04 06:25:58 vapier Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-apps/hotplug/hotplug-20020401.ebuild,v 1.6 2002/10/19 03:42:44 vapier Exp $
# source maintainers named it hotplug-YYYY_MM_DD instead of hotplug-YYYYMMDD
MY_P=`echo ${P}|sed 's/-\(....\)\(..\)\(..\)/-\1_\2_\3/'`
@@ -16,8 +16,9 @@ LICENSE="GPL-2"
DEPEND="virtual/glibc
>=sys-apps/pciutils-2.1.9
>=sys-apps/usbutils-0.9"
+RDEPEND="${DEPEND}"
-src_unpack () {
+src_unpack() {
unpack ${A}
cd ${S}/etc/hotplug
@@ -25,7 +26,7 @@ src_unpack () {
patch -p0 < ${FILESDIR}/${P}-usb.rc-gentoo.diff
}
-src_install () {
+src_install() {
into /
dosbin sbin/hotplug
doman *.8
@@ -45,7 +46,7 @@ src_install () {
newins ${FILESDIR}/usb.conf usb
}
-pkg_postinst () {
- einfo WARNING: The fxload program was spliced off this package.
- einfo WARNING: emerge fxload if you need it.
+pkg_postinst() {
+ ewarn "WARNING: The fxload program was spliced off this package"
+ ewarn "WARNING: emerge fxload if you need it"
}