summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorNed Ludd <solar@gentoo.org>2006-06-25 15:22:24 +0000
committerNed Ludd <solar@gentoo.org>2006-06-25 15:22:24 +0000
commit0b4f5aa64ce4600d96756455ccdf57ee29eedde3 (patch)
tree5d64fef8eaf55fd4d214b46096964eae4114fd2d /sys-apps/paxctl/paxctl-0.4.ebuild
parentVersion bump. fixes bug #135269 Thanks to Boris Fersing <kernelsensei@gentoo.... (diff)
downloadhistorical-0b4f5aa64ce4600d96756455ccdf57ee29eedde3.tar.gz
historical-0b4f5aa64ce4600d96756455ccdf57ee29eedde3.tar.bz2
historical-0b4f5aa64ce4600d96756455ccdf57ee29eedde3.zip
- new version. This version obsoletes the need for chpax all together with the introduction of the -C flag which can create a new PT_PAX_FLAGS phdr in ELF 32/64 bit files
Package-Manager: portage-3387-svn
Diffstat (limited to 'sys-apps/paxctl/paxctl-0.4.ebuild')
-rw-r--r--sys-apps/paxctl/paxctl-0.4.ebuild27
1 files changed, 27 insertions, 0 deletions
diff --git a/sys-apps/paxctl/paxctl-0.4.ebuild b/sys-apps/paxctl/paxctl-0.4.ebuild
new file mode 100644
index 000000000000..20c969b3f995
--- /dev/null
+++ b/sys-apps/paxctl/paxctl-0.4.ebuild
@@ -0,0 +1,27 @@
+# Copyright 1999-2006 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sys-apps/paxctl/paxctl-0.4.ebuild,v 1.1 2006/06/25 15:22:24 solar Exp $
+
+inherit flag-o-matic
+
+DESCRIPTION="Manages various PaX related program header flags for Elf32, Elf64, binaries."
+SRC_URI="http://pax.grsecurity.net/paxctl-${PV}.tar.gz"
+HOMEPAGE="http://pax.grsecurity.net"
+KEYWORDS="~amd64 ~hppa ~ia64 ~mips ~ppc ~ppc64 ~sparc ~x86"
+IUSE=""
+LICENSE="GPL-2"
+SLOT="0"
+
+DEPEND=">=sys-devel/binutils-2.14.90.0.8-r1"
+RDEPEND=""
+
+#S=${WORKDIR}/${P}
+
+src_compile() {
+ emake CFLAGS="${CFLAGS}" LDFLAGS="${LDFLAGS}"
+}
+
+src_install() {
+ einstall DESTDIR="${D}"
+ dodoc README ChangeLog
+}