summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMike Frysinger <vapier@gentoo.org>2009-05-20 08:14:24 +0000
committerMike Frysinger <vapier@gentoo.org>2009-05-20 08:14:24 +0000
commit00283c42c826209f6404d882c799209f0a6bccc5 (patch)
tree56ba8e2b34942574ba3931abf74fa95b552e04a5 /sys-apps/sed
parentUpdate for bluez split. Works here. (diff)
downloadhistorical-00283c42c826209f6404d882c799209f0a6bccc5.tar.gz
historical-00283c42c826209f6404d882c799209f0a6bccc5.tar.bz2
historical-00283c42c826209f6404d882c799209f0a6bccc5.zip
old
Diffstat (limited to 'sys-apps/sed')
-rw-r--r--sys-apps/sed/sed-4.1.5.ebuild68
1 files changed, 0 insertions, 68 deletions
diff --git a/sys-apps/sed/sed-4.1.5.ebuild b/sys-apps/sed/sed-4.1.5.ebuild
deleted file mode 100644
index 9acf76832587..000000000000
--- a/sys-apps/sed/sed-4.1.5.ebuild
+++ /dev/null
@@ -1,68 +0,0 @@
-# Copyright 1999-2007 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-apps/sed/sed-4.1.5.ebuild,v 1.20 2007/11/04 03:34:44 vapier Exp $
-
-inherit flag-o-matic
-
-DESCRIPTION="Super-useful stream editor"
-HOMEPAGE="http://sed.sourceforge.net/"
-SRC_URI="mirror://gnu/sed/${P}.tar.gz"
-
-LICENSE="GPL-2"
-SLOT="0"
-KEYWORDS="alpha amd64 arm hppa ia64 m68k mips ppc ppc64 s390 sh sparc ~sparc-fbsd x86 ~x86-fbsd"
-IUSE="nls static"
-
-RDEPEND="nls? ( virtual/libintl )"
-DEPEND="${RDEPEND}
- nls? ( sys-devel/gettext )"
-
-src_bootstrap_sed() {
- # make sure system-sed works #40786
- export NO_SYS_SED=""
- if ! type -p sed ; then
- NO_SYS_SED="!!!"
- ./bootstrap.sh || die "couldnt bootstrap"
- cp sed/sed "${T}"/ || die "couldnt copy"
- export PATH="${PATH}:${T}"
- make clean || die "couldnt clean"
- fi
-}
-
-src_unpack() {
- unpack ${A}
- cd "${S}"
- epatch "${FILESDIR}"/${PN}-4.1.4-makeinfo-c-locale.patch
- epatch "${FILESDIR}"/${P}-alloca.patch
- # don't use sed here if we have to recover a broken host sed
-}
-
-src_compile() {
- src_bootstrap_sed
- # make sure all sed operations here are repeatable
- sed -i \
- -e '/docdir =/s:=.*/doc:= $(datadir)/doc/'${PF}'/html:' \
- doc/Makefile.in || die "sed html doc"
-
- local myconf= bindir=/bin
- if ! use userland_GNU ; then
- myconf="--program-prefix=g"
- bindir=/usr/bin
- fi
- use static && append-ldflags -static
- econf \
- --bindir=${bindir} \
- $(use_enable nls) \
- ${myconf} \
- || die "Configure failed"
- emake || die "build failed"
-}
-
-src_install() {
- emake install DESTDIR="${D}" || die "Install failed"
- dodoc NEWS README* THANKS AUTHORS BUGS ChangeLog
- docinto examples
- dodoc "${FILESDIR}"/{dos2unix,unix2dos}
-
- rm -f "${D}"/usr/lib/charset.alias "${D}"/usr/share/locale/locale.alias
-}