summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMartin Schlemmer <azarah@gentoo.org>2002-10-14 17:24:17 +0000
committerMartin Schlemmer <azarah@gentoo.org>2002-10-14 17:24:17 +0000
commitfe7658597e66c9aa4b3e1be2961963d60b8e80b0 (patch)
treed280f1a5dc014695bbb659ab7c8656a89dada39e /sys-apps
parentnew versions (diff)
downloadhistorical-fe7658597e66c9aa4b3e1be2961963d60b8e80b0.tar.gz
historical-fe7658597e66c9aa4b3e1be2961963d60b8e80b0.tar.bz2
historical-fe7658597e66c9aa4b3e1be2961963d60b8e80b0.zip
fix bug when using make -j5 or more
Diffstat (limited to 'sys-apps')
-rw-r--r--sys-apps/diffutils/ChangeLog8
-rw-r--r--sys-apps/diffutils/diffutils-2.8.4-r1.ebuild9
-rw-r--r--sys-apps/diffutils/files/diffutils-2.8.4-fix-multi-job-build.patch211
3 files changed, 18 insertions, 10 deletions
diff --git a/sys-apps/diffutils/ChangeLog b/sys-apps/diffutils/ChangeLog
index bff25976ce11..a98ee2a35399 100644
--- a/sys-apps/diffutils/ChangeLog
+++ b/sys-apps/diffutils/ChangeLog
@@ -1,15 +1,13 @@
# ChangeLog for sys-apps/diffutils
# Copyright 2002 Gentoo Technologies, Inc.; Distributed under the GPL
-# $Header: /var/cvsroot/gentoo-x86/sys-apps/diffutils/ChangeLog,v 1.7 2002/10/14 09:58:36 azarah Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-apps/diffutils/ChangeLog,v 1.8 2002/10/14 17:24:17 azarah Exp $
*diffutils-2.8.4-r1 (14 Oct 2002)
14 Oct 2002; Martin Schlemmer <azarah@gentoo.org> :
-
Build fails with make -j5 or greater on pentium4. This is because
- the .c.o rule should depend on paths.h, else they are being compiled
- at the same time of its generation. This *should* hopefully fix
- this problem. Cannot test it now though, as this is a celeron :/
+ the jobs creating the opjects, which depend on paths.h is sheduled
+ at the same time paths.h is generated. This closes bug #8934.
*diffutils-2.8.4 (25 Sep 2002)
diff --git a/sys-apps/diffutils/diffutils-2.8.4-r1.ebuild b/sys-apps/diffutils/diffutils-2.8.4-r1.ebuild
index 61f6d22989f7..05283544340c 100644
--- a/sys-apps/diffutils/diffutils-2.8.4-r1.ebuild
+++ b/sys-apps/diffutils/diffutils-2.8.4-r1.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2002 Gentoo Technologies, Inc.
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-apps/diffutils/diffutils-2.8.4-r1.ebuild,v 1.1 2002/10/14 09:58:36 azarah Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-apps/diffutils/diffutils-2.8.4-r1.ebuild,v 1.2 2002/10/14 17:24:17 azarah Exp $
IUSE="nls build"
@@ -33,11 +33,10 @@ src_unpack() {
fi
# Build fails with make -j5 or greater on pentium4. This is because
- # the .c.o rule should depend on paths.h, else they are being compiled
- # at the same time of its generation. This *should* hopefully fix
- # this problem. Cannot test it now though, as this is a celeron :/
+ # the jobs creating the opjects, which depend on paths.h is sheduled
+ # at the same time paths.h is generated. This closes bug #8934.
# <azarah@gentoo.org> (14 Oct 2002)
- cd ${S}; patch -p1 < ${FILESDIR}/${P}-fix-multi-job-build.patch || die
+ cd ${S}; patch -p1 < ${FILESDIR}/${P}-fix-multi-job-build.patch2 || die
}
src_compile() {
diff --git a/sys-apps/diffutils/files/diffutils-2.8.4-fix-multi-job-build.patch2 b/sys-apps/diffutils/files/diffutils-2.8.4-fix-multi-job-build.patch2
new file mode 100644
index 000000000000..bb704483224c
--- /dev/null
+++ b/sys-apps/diffutils/files/diffutils-2.8.4-fix-multi-job-build.patch2
@@ -0,0 +1,11 @@
+diff -urN diffutils-2.8.4/src/Makefile.in diffutils-2.8.4.azarah/src/Makefile.in
+--- diffutils-2.8.4/src/Makefile.in 2002-06-28 09:04:20.000000000 +0200
++++ diffutils-2.8.4.azarah/src/Makefile.in 2002-10-14 19:03:33.000000000 +0200
+@@ -410,6 +410,7 @@
+ uninstall-binPROGRAMS uninstall-info-am
+
+
++cmp.c diff3.c diff.c sdiff.c: paths.h
+ cmp.$(OBJEXT) diff3.$(OBJECT) diff.$(OBJECT) sdiff.$(OBJECT): paths.h
+ paths.h:
+ (echo '#define DEFAULT_DIFF_PROGRAM "$(bindir)/'`echo diff|sed '$(transform)'`'"' && \