summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAli Polatel <hawking@gentoo.org>2007-10-01 07:46:40 +0000
committerAli Polatel <hawking@gentoo.org>2007-10-01 07:46:40 +0000
commit2dbe459f6465da130aa3ba110fa6be8640e04744 (patch)
treea150c39554579720a8bed9970f10ffeee4ab6332 /sys-auth/pam_chroot/pam_chroot-0.9.2.ebuild
parentFix bug#194323 thanks to Jan Kundrát, resync with upstream (diff)
downloadhistorical-2dbe459f6465da130aa3ba110fa6be8640e04744.tar.gz
historical-2dbe459f6465da130aa3ba110fa6be8640e04744.tar.bz2
historical-2dbe459f6465da130aa3ba110fa6be8640e04744.zip
version bump.
Package-Manager: portage-2.1.3.11
Diffstat (limited to 'sys-auth/pam_chroot/pam_chroot-0.9.2.ebuild')
-rw-r--r--sys-auth/pam_chroot/pam_chroot-0.9.2.ebuild30
1 files changed, 30 insertions, 0 deletions
diff --git a/sys-auth/pam_chroot/pam_chroot-0.9.2.ebuild b/sys-auth/pam_chroot/pam_chroot-0.9.2.ebuild
new file mode 100644
index 000000000000..f156c043bea4
--- /dev/null
+++ b/sys-auth/pam_chroot/pam_chroot-0.9.2.ebuild
@@ -0,0 +1,30 @@
+# Copyright 1999-2007 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sys-auth/pam_chroot/pam_chroot-0.9.2.ebuild,v 1.1 2007/10/01 07:46:39 hawking Exp $
+
+inherit toolchain-funcs pam flag-o-matic eutils
+
+DESCRIPTION="Linux-PAM module that allows a user to be chrooted in auth, account, or session."
+HOMEPAGE="http://sourceforge.net/projects/pam-chroot/"
+SRC_URI="mirror://sourceforge/pam-chroot/${P}.tar.bz2"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~alpha ~hppa ~ia64 ~ppc ~ppc64 ~sparc ~x86"
+IUSE=""
+
+DEPEND="virtual/pam
+ !<sys-libs/pam-0.99"
+RDEPEND="${DEPEND}"
+
+src_compile() {
+ LDFLAGS="$(raw-ldflags)" emake \
+ CC="$(tc-getCC)" LD="$(tc-getLD)" || die "emake failed"
+}
+
+src_install() {
+ dopammod pam_chroot.so
+ dopamsecurity . chroot.conf
+
+ dodoc CREDITS README.history TROUBLESHOOTING options || die "dodoc failed"
+}