summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorChristian Zoffoli <xmerlin@gentoo.org>2005-04-28 00:40:10 +0000
committerChristian Zoffoli <xmerlin@gentoo.org>2005-04-28 00:40:10 +0000
commit92826bb1d46a3a880add4c2b479c1bbd97decb66 (patch)
tree3a481aefcfaebd66af0706762daf1e6b67958aa7 /sys-cluster
parentclean old ebuilds (diff)
downloadhistorical-92826bb1d46a3a880add4c2b479c1bbd97decb66.tar.gz
historical-92826bb1d46a3a880add4c2b479c1bbd97decb66.tar.bz2
historical-92826bb1d46a3a880add4c2b479c1bbd97decb66.zip
added the csync2 port to the /etc/services file
Package-Manager: portage-2.0.51.19
Diffstat (limited to 'sys-cluster')
-rw-r--r--sys-cluster/csync2/ChangeLog5
-rw-r--r--sys-cluster/csync2/Manifest10
-rw-r--r--sys-cluster/csync2/csync2-1.16.ebuild22
3 files changed, 30 insertions, 7 deletions
diff --git a/sys-cluster/csync2/ChangeLog b/sys-cluster/csync2/ChangeLog
index a976d9c985e2..a2e1135dbcc5 100644
--- a/sys-cluster/csync2/ChangeLog
+++ b/sys-cluster/csync2/ChangeLog
@@ -1,6 +1,9 @@
# ChangeLog for sys-cluster/csync2
# Copyright 1999-2005 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sys-cluster/csync2/ChangeLog,v 1.2 2005/04/27 21:19:34 xmerlin Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-cluster/csync2/ChangeLog,v 1.3 2005/04/28 00:40:10 xmerlin Exp $
+
+ 28 Apr 2005; Christian Zoffoli <xmerlin@gentoo.org> csync2-1.16.ebuild:
+ added the csync2 port to the /etc/services file
27 Apr 2005; Christian Zoffoli <xmerlin@gentoo.org> csync2-1.16.ebuild:
dep tuning.
diff --git a/sys-cluster/csync2/Manifest b/sys-cluster/csync2/Manifest
index ad2b4301842e..ec70d9daa62b 100644
--- a/sys-cluster/csync2/Manifest
+++ b/sys-cluster/csync2/Manifest
@@ -1,15 +1,15 @@
-----BEGIN PGP SIGNED MESSAGE-----
Hash: SHA1
-MD5 f305ff37c1f67c3015692211958663b6 csync2-1.16.ebuild 783
+MD5 cbc31c53ec5e282a4e6cfee79e360053 csync2-1.16.ebuild 1311
MD5 a64b9a1937a5cfc2fbaf373521f65d47 metadata.xml 223
-MD5 9b85e7844e81888e5e7894b544c39b57 ChangeLog 468
+MD5 8a5bbc04f06131b0938f9eb8a96c7b6c ChangeLog 593
MD5 8f6c0e3b7da5a8b1a5fd7730f6ae8bdd files/csync2.xinetd 388
MD5 4f935e316a184e40ddf6dfd0f386c761 files/digest-csync2-1.16 62
-----BEGIN PGP SIGNATURE-----
Version: GnuPG v1.4.1 (GNU/Linux)
-iD8DBQFCcAJ0gMUyd/cdjWsRApY1AKCDAs7k1Rx6I+kyH9aXWEKoc4y0HwCfSR37
-rGILGMgS/TK0ZEXzIdyv1fM=
-=4yCO
+iD8DBQFCcDGEgMUyd/cdjWsRAsxCAJ9So7Xj7AuHfuprn/fN88d9LF1vAACeJUkl
+4rQWhA3eEYxp8rGpRbU58Hg=
+=Ln2c
-----END PGP SIGNATURE-----
diff --git a/sys-cluster/csync2/csync2-1.16.ebuild b/sys-cluster/csync2/csync2-1.16.ebuild
index 1e8f7e773212..5d861c87bd94 100644
--- a/sys-cluster/csync2/csync2-1.16.ebuild
+++ b/sys-cluster/csync2/csync2-1.16.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2005 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-cluster/csync2/csync2-1.16.ebuild,v 1.2 2005/04/27 21:19:34 xmerlin Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-cluster/csync2/csync2-1.16.ebuild,v 1.3 2005/04/28 00:40:10 xmerlin Exp $
DESCRIPTION="Cluster synchronization tool."
SRC_URI="http://oss.linbit.com/csync2/${P}.tar.gz"
@@ -35,3 +35,23 @@ src_install() {
dodoc AUTHORS COPYING ChangeLog INSTALL NEWS README TODO
}
+pkg_postinst() {
+ echo
+ einfo "After you setup your conf file, edit the xinetd"
+ einfo "entry in /etc/xinetd.d/${PN} to enable, then"
+ einfo "start xinetd: /etc/init.d/xinetd start"
+ echo
+ einfo "To add ${PN} to your services file just run"
+ einfo "this command after you install:"
+ echo
+ einfo "ebuild /var/db/pkg/${CATEGORY}/${PF}/${PF}.ebuild config"
+}
+
+pkg_config() {
+ einfo "Updating /etc/services"
+ { grep -v ^${PN} /etc/services;
+ echo "csync2 30865/tcp"
+ } > /etc/services.new
+ mv -f /etc/services.new /etc/services
+
+}