summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTravis Tilley <lv@gentoo.org>2004-09-25 18:51:39 +0000
committerTravis Tilley <lv@gentoo.org>2004-09-25 18:51:39 +0000
commit7a998e96f9d6f95ff65dbf7b2e3f84cde005a634 (patch)
tree51dda6169a079450ae2cac92e07dbadd2df3339e /sys-devel/gcc/gcc-3.3.4-r1.ebuild
parentremoval of pcmcia-cs-drivers, never happened (diff)
downloadhistorical-7a998e96f9d6f95ff65dbf7b2e3f84cde005a634.tar.gz
historical-7a998e96f9d6f95ff65dbf7b2e3f84cde005a634.tar.bz2
historical-7a998e96f9d6f95ff65dbf7b2e3f84cde005a634.zip
update uclibc patched ebuilds to work properly with recent libtool eclass changes
Diffstat (limited to 'sys-devel/gcc/gcc-3.3.4-r1.ebuild')
-rw-r--r--sys-devel/gcc/gcc-3.3.4-r1.ebuild10
1 files changed, 6 insertions, 4 deletions
diff --git a/sys-devel/gcc/gcc-3.3.4-r1.ebuild b/sys-devel/gcc/gcc-3.3.4-r1.ebuild
index 9862de56f228..bce72643f9c4 100644
--- a/sys-devel/gcc/gcc-3.3.4-r1.ebuild
+++ b/sys-devel/gcc/gcc-3.3.4-r1.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2004 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-devel/gcc/gcc-3.3.4-r1.ebuild,v 1.15 2004/08/31 18:49:30 gustavoz Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-devel/gcc/gcc-3.3.4-r1.ebuild,v 1.16 2004/09/25 18:51:39 lv Exp $
inherit eutils flag-o-matic libtool gnuconfig
@@ -303,8 +303,6 @@ src_unpack() {
fi
cd ${S}
- # Fixup libtool to correctly generate .la files with portage
- elibtoolize --portage --shallow
# Branch update ...
if [ -n "${BRANCH_UPDATE}" ]
@@ -414,7 +412,11 @@ src_unpack() {
# http://gcc.gnu.org/bugzilla/show_bug.cgi?id=14992 (May 3 2004)
sed -i -e s/HAVE_LD_AS_NEEDED/USE_LD_AS_NEEDED/g ${S}/gcc/config.in
- use uclibc && gnuconfig_update
+ cd ${S}
+ # Fixup libtool to correctly generate .la files with portage
+ elibtoolize --portage --shallow
+
+ gnuconfig_update
cd ${S}; ./contrib/gcc_update --touch &> /dev/null
}