summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMike Frysinger <vapier@gentoo.org>2011-11-09 19:22:57 +0000
committerMike Frysinger <vapier@gentoo.org>2011-11-09 19:22:57 +0000
commit85e8ea2aab5e9397537d42fa7d93e40d189b6f35 (patch)
tree632efaea2c7d690146b2bb34e99d6988d18af0e2 /sys-devel/gcc/gcc-4.3.4.ebuild
parentInitial import. Thanks to James Le Cuirot <chewi@aura-online.co.uk> for the i... (diff)
downloadhistorical-85e8ea2aab5e9397537d42fa7d93e40d189b6f35.tar.gz
historical-85e8ea2aab5e9397537d42fa7d93e40d189b6f35.tar.bz2
historical-85e8ea2aab5e9397537d42fa7d93e40d189b6f35.zip
Drop most dependencies now that toolchain.eclass takes care of them. Also drop the ncurses dep as that seems to be purely a workaround for an ancient issue #4411 which we have addressed in different ways.
Package-Manager: portage-2.2.0_alpha72/cvs/Linux x86_64
Diffstat (limited to 'sys-devel/gcc/gcc-4.3.4.ebuild')
-rw-r--r--sys-devel/gcc/gcc-4.3.4.ebuild33
1 files changed, 2 insertions, 31 deletions
diff --git a/sys-devel/gcc/gcc-4.3.4.ebuild b/sys-devel/gcc/gcc-4.3.4.ebuild
index 1cdcbd18454f..a03a3e7b8e60 100644
--- a/sys-devel/gcc/gcc-4.3.4.ebuild
+++ b/sys-devel/gcc/gcc-4.3.4.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2011 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-devel/gcc/gcc-4.3.4.ebuild,v 1.18 2011/09/26 17:38:49 vapier Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-devel/gcc/gcc-4.3.4.ebuild,v 1.19 2011/11/09 19:22:57 vapier Exp $
GENTOO_PATCH_EXCLUDE="69_all_gcc43-pr39013.patch \
02_all_gcc-4.3-alpha-PR42113.patch" #262567 #309279
@@ -28,42 +28,13 @@ DESCRIPTION="The GNU Compiler Collection"
LICENSE="GPL-3 LGPL-3 || ( GPL-3 libgcc libstdc++ ) FDL-1.2"
KEYWORDS="alpha amd64 arm -hppa ia64 ~m68k ~mips ppc ppc64 s390 sh sparc x86 ~x86-fbsd"
-IUSE=""
-RDEPEND=">=sys-libs/zlib-1.1.4
- >=sys-devel/gcc-config-1.4
- virtual/libiconv
- >=dev-libs/gmp-4.2.1
- >=dev-libs/mpfr-2.3
- !build? (
- gcj? (
- gtk? (
- x11-libs/libXt
- x11-libs/libX11
- x11-libs/libXtst
- x11-proto/xproto
- x11-proto/xextproto
- =x11-libs/gtk+-2*
- x11-libs/pango
- )
- >=media-libs/libart_lgpl-2.1
- app-arch/zip
- app-arch/unzip
- )
- >=sys-libs/ncurses-5.2-r2
- nls? ( sys-devel/gettext )
- )"
+RDEPEND=""
DEPEND="${RDEPEND}
- test? ( sys-devel/autogen dev-util/dejagnu )
- >=sys-apps/texinfo-4.2-r4
- >=sys-devel/bison-1.875
- sys-devel/flex
- elibc_glibc? ( >=sys-libs/glibc-2.8 )
amd64? ( multilib? ( gcj? ( app-emulation/emul-linux-x86-xlibs ) ) )
ppc? ( >=${CATEGORY}/binutils-2.17 )
ppc64? ( >=${CATEGORY}/binutils-2.17 )
>=${CATEGORY}/binutils-2.15.94"
-PDEPEND=">=sys-devel/gcc-config-1.4"
if [[ ${CATEGORY} != cross-* ]] ; then
PDEPEND="${PDEPEND} elibc_glibc? ( >=sys-libs/glibc-2.8 )"
fi