summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTravis Tilley <lv@gentoo.org>2004-09-24 02:40:17 +0000
committerTravis Tilley <lv@gentoo.org>2004-09-24 02:40:17 +0000
commit4649fc32ef29576db91fdfc5714536bce70d0250 (patch)
treec41b3219816758a83122c0fc544935c8ae82ff3b /sys-devel/gdb/gdb-6.2.1.ebuild
parentUnmasking gnustep-apps/affiche-0.6.0 as it works now (diff)
downloadhistorical-4649fc32ef29576db91fdfc5714536bce70d0250.tar.gz
historical-4649fc32ef29576db91fdfc5714536bce70d0250.tar.bz2
historical-4649fc32ef29576db91fdfc5714536bce70d0250.zip
make CONF_LIBDIR aware again to fix a sandbox violation. lets hope nobody reverts the change this time.
Diffstat (limited to 'sys-devel/gdb/gdb-6.2.1.ebuild')
-rw-r--r--sys-devel/gdb/gdb-6.2.1.ebuild7
1 files changed, 5 insertions, 2 deletions
diff --git a/sys-devel/gdb/gdb-6.2.1.ebuild b/sys-devel/gdb/gdb-6.2.1.ebuild
index 1d183057531b..87449f4b9e1b 100644
--- a/sys-devel/gdb/gdb-6.2.1.ebuild
+++ b/sys-devel/gdb/gdb-6.2.1.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2004 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-devel/gdb/gdb-6.2.1.ebuild,v 1.1 2004/09/22 23:36:25 lu_zero Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-devel/gdb/gdb-6.2.1.ebuild,v 1.2 2004/09/24 02:40:17 lv Exp $
inherit flag-o-matic eutils
@@ -25,7 +25,9 @@ src_unpack() {
src_compile() {
replace-flags -O? -O2
- econf `use_enable nls` || die
+ econf \
+ `use_enable nls` \
+ --libdir=/usr/$(get_libdir) || die
make || die
}
@@ -33,6 +35,7 @@ src_install() {
make \
prefix=${D}/usr \
mandir=${D}/usr/share/man \
+ libdir=${D}/usr/$(get_libdir) \
infodir=${D}/usr/share/info \
install || die