summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorOlivier Crête <tester@gentoo.org>2003-11-06 11:53:54 +0000
committerOlivier Crête <tester@gentoo.org>2003-11-06 11:53:54 +0000
commit0e07bad448e6db6b562cb2b2a6f0d92243fd9090 (patch)
tree154e7570dc4e334da67de7bb8401de57895ad9d5 /sys-devel/omni
parentAdding omni 1.6 (diff)
downloadhistorical-0e07bad448e6db6b562cb2b2a6f0d92243fd9090.tar.gz
historical-0e07bad448e6db6b562cb2b2a6f0d92243fd9090.tar.bz2
historical-0e07bad448e6db6b562cb2b2a6f0d92243fd9090.zip
Adding omni 1.6
Diffstat (limited to 'sys-devel/omni')
-rw-r--r--sys-devel/omni/Manifest4
-rw-r--r--sys-devel/omni/files/digest-omni-1.60
-rw-r--r--sys-devel/omni/omni-1.6.ebuild72
3 files changed, 74 insertions, 2 deletions
diff --git a/sys-devel/omni/Manifest b/sys-devel/omni/Manifest
index a3e3f0d64a4b..9d543285e067 100644
--- a/sys-devel/omni/Manifest
+++ b/sys-devel/omni/Manifest
@@ -1,5 +1,5 @@
MD5 efc3c676a80ff817ed049c2e560703d0 omni-1.4a.ebuild 1635
-MD5 02ecda34f823fc83dbb3bdca886ebbac ChangeLog 469
-MD5 efc3c676a80ff817ed049c2e560703d0 omni-1.6.ebuild 1635
+MD5 6b35b209ee2f3fbeeb8648c582b6c98c ChangeLog 578
+MD5 404161054acfcfed9372b6035c3c378e omni-1.6.ebuild 1635
MD5 d41d8cd98f00b204e9800998ecf8427e files/digest-omni-1.6 0
MD5 d41d8cd98f00b204e9800998ecf8427e files/digest-omni-1.4a 0
diff --git a/sys-devel/omni/files/digest-omni-1.6 b/sys-devel/omni/files/digest-omni-1.6
new file mode 100644
index 000000000000..e69de29bb2d1
--- /dev/null
+++ b/sys-devel/omni/files/digest-omni-1.6
diff --git a/sys-devel/omni/omni-1.6.ebuild b/sys-devel/omni/omni-1.6.ebuild
new file mode 100644
index 000000000000..0683a1717dc6
--- /dev/null
+++ b/sys-devel/omni/omni-1.6.ebuild
@@ -0,0 +1,72 @@
+# Copyright 1999-2003 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sys-devel/omni/omni-1.6.ebuild,v 1.1 2003/11/06 11:53:48 tester Exp $
+
+DESCRIPTION="The Omni OpenMP Compiler"
+HOMEPAGE="http://phase.etl.go.jp/Omni/"
+LICENSE="Omni"
+SLOT="0"
+KEYWORDS="~x86"
+MY_P=Omni-${PV}
+S=${WORKDIR}/${MY_P}
+RESTRICT="fetch"
+
+IUSE="java doc"
+
+DEPEND="java? ( virtual/jdk
+ app-arch/zip )
+ sys-apps/sed"
+
+RDEPEND="java? ( virtual/jdk )"
+
+src_unpack() {
+
+ if [ ! -e ${DISTDIR}/${MY_P}.tar.gz ] ; then
+ einfo "Due to license issues you have to download"
+ einfo "the appropriate Omni archive:"
+ einfo "http://phase.etl.go.jp/Omni/Omni-release.html"
+ einfo "Please get the file "${MY_P}.tar.gz
+ einfo ""
+ einfo "The archive should be placed into ${DISTDIR}."
+
+ die "package archive not found"
+ fi
+
+ unpack ${MY_P}.tar.gz
+
+
+}
+
+src_compile() {
+ local myconf
+
+ myconf=""
+
+ # There is no configure script for the doc
+ if [ ! `use doc` ] ; then
+ dosed s/doc// Makefile.in
+ fi
+
+ use java && myconf="${myconf} --with-jvm=yes"
+ use java || myconf="${myconf} --with-jvm=no"
+
+ use doc && myconf="${myconf} --enable-installSample"
+
+ # scoredoc is just about the placement of the doc
+ econf ${myconf} --enable-gcc --disable-scoreDoc \
+ --with-thread=pthread || die
+
+ emake || die
+}
+
+src_install() {
+ make DESTDIR=${D} install || die
+
+
+ # Put the doc in the right place
+ dodir /usr/share/doc/
+ use doc && mv ${D}usr/lib/openmp/doc ${D}usr/share/doc/${P}
+ use doc && mv ${D}usr/lib/openmp/examples ${D}usr/share/doc/${P}
+
+ dodoc README COPYRIGHT LICENSE
+}