summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDiego Elio Pettenò <flameeyes@gentoo.org>2005-07-29 12:02:41 +0000
committerDiego Elio Pettenò <flameeyes@gentoo.org>2005-07-29 12:02:41 +0000
commit796dfa7d2f3cd056c1308864a4f82947e045cd3c (patch)
tree302de75007d634d73bb31f05a72d9e1a599d78c0 /sys-devel/pmake/pmake-1.111.1.ebuild
parentBetter detection of Berkeley DB. (diff)
downloadhistorical-796dfa7d2f3cd056c1308864a4f82947e045cd3c.tar.gz
historical-796dfa7d2f3cd056c1308864a4f82947e045cd3c.tar.bz2
historical-796dfa7d2f3cd056c1308864a4f82947e045cd3c.zip
New version (latest from Debian testing). Install as make for BSD userland systems, install mk files only on GNU userland systems. Maintainership took over by bsd herd.
Package-Manager: portage-2.0.51.22-r2
Diffstat (limited to 'sys-devel/pmake/pmake-1.111.1.ebuild')
-rw-r--r--sys-devel/pmake/pmake-1.111.1.ebuild73
1 files changed, 73 insertions, 0 deletions
diff --git a/sys-devel/pmake/pmake-1.111.1.ebuild b/sys-devel/pmake/pmake-1.111.1.ebuild
new file mode 100644
index 000000000000..d7ca74778a15
--- /dev/null
+++ b/sys-devel/pmake/pmake-1.111.1.ebuild
@@ -0,0 +1,73 @@
+# Copyright 1999-2005 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sys-devel/pmake/pmake-1.111.1.ebuild,v 1.1 2005/07/29 12:02:41 flameeyes Exp $
+
+inherit eutils toolchain-funcs versionator
+
+MY_P="${PN}-$(get_version_component_range 1-2)"
+DEBIAN_SOURCE="${PN}_$(get_version_component_range 1-2).orig.tar.gz"
+DEBIAN_PATCH="${PN}_$(replace_version_separator 2 '-').diff.gz"
+
+DESCRIPTION="BSD build tool to create programs in parallel. Debian's version of NetBSD's make"
+HOMEPAGE="http://www.netbsd.org/"
+SRC_URI="mirror://debian/pool/main/p/pmake/${DEBIAN_SOURCE}
+ mirror://debian/pool/main/p/pmake/${DEBIAN_PATCH}"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~ia64 ~mips ~ppc ~sparc ~x86"
+IUSE=""
+
+RDEPEND=""
+DEPEND=""
+
+S="${WORKDIR}/${PN}"
+
+src_unpack() {
+ unpack ${A} && cd ${S} || die
+
+ epatch ${WORKDIR}/${DEBIAN_PATCH/.gz/}
+
+ # pmake makes the assumption that . and .. are the first two
+ # entries in a directory, which doesn't always appear to be the
+ # case on ext3... (05 Apr 2004 agriffis)
+ epatch ${FILESDIR}/${PN}-1.98-skipdots.patch
+
+ # Clean up headers to reduce warnings
+ sed -i -e 's|^#endif.*|#endif|' *.h */*.h
+}
+
+src_compile() {
+ # The following CFLAGS are almost directly from Red Hat 8.0 and
+ # debian/rules, so assume it's okay to void out the __COPYRIGHT
+ # and __RCSID. I've checked the source and don't see the point,
+ # but whatever... (07 Feb 2004 agriffis)
+ CFLAGS="${CFLAGS} -Wall -Wno-unused -D_GNU_SOURCE \
+ -DHAVE_STRERROR -DHAVE_STRDUP -DHAVE_SETENV \
+ -D__COPYRIGHT\(x\)= -D__RCSID\(x\)= -I. \
+ -DMACHINE=\\\"gentoo\\\" -DMACHINE_ARCH=\\\"$(tc-arch-kernel)\\\""
+
+ make -f Makefile.boot \
+ CC="$(tc-getCC)" \
+ CFLAGS="${CFLAGS}" \
+ || die "make failed"
+}
+
+src_install() {
+ # Don't install these on BSD (or Darwin), else they conflicts
+ if [[ "${USERLAND}" == "GNU" ]]; then
+ insinto /usr/share/mk
+ doins mk/*
+ fi
+
+ newbin bmake pmake || die "newbin failed"
+ dobin mkdep || die "dobin failed"
+ mv make.1 pmake.1
+ doman mkdep.1 pmake.1
+ dodoc PSD.doc/tutorial.ms
+
+ if [[ "${USERLAND}" == "BSD" ]]; then
+ dosym pmake /usr/bin/make
+ dosym pmake.1.gz /usr/share/man/man1/make.1.gz
+ fi
+}