summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMike Frysinger <vapier@gentoo.org>2007-09-17 19:28:20 +0000
committerMike Frysinger <vapier@gentoo.org>2007-09-17 19:28:20 +0000
commit5ec492ad915ca5b10f6eea02e0e76a7bf0d6283e (patch)
tree026546384f69f8880a8a839c02ec5c4ad6c7fa1d /sys-devel/sparse/sparse-0.4.ebuild
parentrdepend to dev-util/mercurial fixed; thanks to R.Gruber on bug #192805 (diff)
downloadhistorical-5ec492ad915ca5b10f6eea02e0e76a7bf0d6283e.tar.gz
historical-5ec492ad915ca5b10f6eea02e0e76a7bf0d6283e.tar.bz2
historical-5ec492ad915ca5b10f6eea02e0e76a7bf0d6283e.zip
Version bump.
Package-Manager: portage-2.1.3.9
Diffstat (limited to 'sys-devel/sparse/sparse-0.4.ebuild')
-rw-r--r--sys-devel/sparse/sparse-0.4.ebuild32
1 files changed, 32 insertions, 0 deletions
diff --git a/sys-devel/sparse/sparse-0.4.ebuild b/sys-devel/sparse/sparse-0.4.ebuild
new file mode 100644
index 000000000000..e7874ec0329d
--- /dev/null
+++ b/sys-devel/sparse/sparse-0.4.ebuild
@@ -0,0 +1,32 @@
+# Copyright 1999-2007 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sys-devel/sparse/sparse-0.4.ebuild,v 1.1 2007/09/17 19:28:20 vapier Exp $
+
+inherit eutils multilib
+
+DESCRIPTION="C semantic parser"
+HOMEPAGE="http://kernel.org/pub/linux/kernel/people/josh/sparse/"
+SRC_URI="http://kernel.org/pub/linux/kernel/people/josh/sparse/dist/${P}.tar.gz"
+
+LICENSE="OSL-1.1"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~hppa ~ia64 ~ppc ~ppc64 ~s390 ~sh ~x86"
+IUSE=""
+
+DEPEND=""
+RDEPEND=""
+
+src_unpack() {
+ unpack ${A}
+ cd "${S}"
+ sed -i \
+ -e '/^PREFIX=/s:=.*:=/usr:' \
+ -e "/^LIBDIR=/s:/lib:/$(get_libdir):" \
+ Makefile || die
+ epatch "${FILESDIR}"/${P}-makefile-fix.patch
+}
+
+src_install() {
+ emake DESTDIR="${D}" install || die "make install failed"
+ dodoc FAQ README
+}