summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSeemant Kulleen <seemant@gentoo.org>2003-03-01 11:43:39 +0000
committerSeemant Kulleen <seemant@gentoo.org>2003-03-01 11:43:39 +0000
commit38e5e6a5e397b73c0ac5a57a97a4d795547a1562 (patch)
tree6b922384709d9854bad6d4029b841418776d4d2b /sys-kernel/redhat-sources
parentmoved to stable (diff)
downloadhistorical-38e5e6a5e397b73c0ac5a57a97a4d795547a1562.tar.gz
historical-38e5e6a5e397b73c0ac5a57a97a4d795547a1562.tar.bz2
historical-38e5e6a5e397b73c0ac5a57a97a4d795547a1562.zip
unpacking done in TMPDIR now
Diffstat (limited to 'sys-kernel/redhat-sources')
-rw-r--r--sys-kernel/redhat-sources/ChangeLog9
-rw-r--r--sys-kernel/redhat-sources/files/digest-redhat-sources-2.4.20.2.48-r11
-rw-r--r--sys-kernel/redhat-sources/redhat-sources-2.4.20.2.48-r1.ebuild57
3 files changed, 66 insertions, 1 deletions
diff --git a/sys-kernel/redhat-sources/ChangeLog b/sys-kernel/redhat-sources/ChangeLog
index 54acfa015680..0cc170d1dccd 100644
--- a/sys-kernel/redhat-sources/ChangeLog
+++ b/sys-kernel/redhat-sources/ChangeLog
@@ -1,6 +1,13 @@
# ChangeLog for sys-kernel/redhat-sources
# Copyright 2002-2003 Gentoo Technologies, Inc.; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sys-kernel/redhat-sources/ChangeLog,v 1.9 2003/02/23 08:22:30 blocke Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-kernel/redhat-sources/ChangeLog,v 1.10 2003/03/01 11:43:39 seemant Exp $
+
+*redhat-sources-2.4.20.2.48-r1 (01 Mar 2003)
+
+ 01 Mar 2003; Seemant Kulleen <seemant@gentoo.org>
+ redhat-sources-2.4.20.2.48-r1.ebuild:
+ rpm2targz uses TMPDIR now. Thanks to: Jamie Anderson
+ <gentoo.mail@jamieanderson.org> in bug #16586
*redhat-sources-2.4.20.2.48 (23 Feb 2003)
diff --git a/sys-kernel/redhat-sources/files/digest-redhat-sources-2.4.20.2.48-r1 b/sys-kernel/redhat-sources/files/digest-redhat-sources-2.4.20.2.48-r1
new file mode 100644
index 000000000000..854e7d6564f7
--- /dev/null
+++ b/sys-kernel/redhat-sources/files/digest-redhat-sources-2.4.20.2.48-r1
@@ -0,0 +1 @@
+MD5 4c01aef9c37c184cfe466b5b16c46176 kernel-source-2.4.20-2.48.i386.rpm 38677837
diff --git a/sys-kernel/redhat-sources/redhat-sources-2.4.20.2.48-r1.ebuild b/sys-kernel/redhat-sources/redhat-sources-2.4.20.2.48-r1.ebuild
new file mode 100644
index 000000000000..409fc1edf374
--- /dev/null
+++ b/sys-kernel/redhat-sources/redhat-sources-2.4.20.2.48-r1.ebuild
@@ -0,0 +1,57 @@
+# Copyright 1999-2003 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sys-kernel/redhat-sources/redhat-sources-2.4.20.2.48-r1.ebuild,v 1.1 2003/03/01 11:43:39 seemant Exp $
+#OKV=original kernel version, KV=patched kernel version. They can be the same.
+
+ETYPE="sources"
+inherit kernel
+OKV=2.4.20
+KV=2.4.20-2.48
+EXTRAVERSION="-2.48-rhcustom"
+S=${WORKDIR}/linux-${KV}
+
+# This package contains the Linux Kernel source for the version of the
+# Linux Kernel shipped by Red Hat, Inc. as part of their 8.0 distribution.
+#
+# Do not report problems with this source package or the resulting compiled
+# compiled kernel to Red Hat, Inc. Red Hat is not responsible for this
+# package and has offered no warranties or promises that the kernels
+# resulting from the compilation of this package will work on anything
+# except specific versions of the Red Hat distribution and specific
+# compiler revisions.
+#
+# Gentoo provides this package without any guarantees that this kernel
+# will compile and run correctly and will only respond to bug reports
+# dealing with Gentoo specific packaging problems.
+
+# The easiest way to grab Red Hat kernel sources is from the rpm file
+# itself. We used to generate a patch against vanilla sources trees but
+# the added dependency of rpm2targz is minimal compared with having to
+# generate a new diff for every minor version update. (Also not to many
+# people have 2.4.18 vanilla source tarballs floating around these days)
+
+DEPEND="${DEPEND} app-arch/rpm2targz"
+
+DESCRIPTION="Kernel source tree used in Red Hat distributions (not supported by Red Hat)"
+SRC_URI="http://csociety-ftp.ecn.purdue.edu/pub/redhat/linux/beta/phoebe/en/os/i386/RedHat/RPMS/kernel-source-${KV}.i386.rpm"
+HOMEPAGE="http://www.kernel.org/ http://www.redhat.com/"
+KEYWORDS="~x86"
+SLOT="${KV}"
+
+src_unpack() {
+
+ cd ${WORKDIR}
+ # Defining TMPDIR avoids breaking if /tmp is mounted in RAM
+ # and too small to hold all the temp files.
+ # Portage probably shouldn't create any files outside of
+ # /var/tmp/portage just yet anyway. :)
+ TMPDIR=${T} rpm2targz ${DISTDIR}/kernel-source-${KV}.i386.rpm
+ tar xvzf kernel-source-${KV}.i386.tar.gz
+
+ mv usr/src/linux-${KV} ${WORKDIR}
+
+ cd ${S}
+
+ kernel_universal_unpack
+}
+