summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMike Frysinger <vapier@gentoo.org>2009-02-15 22:58:33 +0000
committerMike Frysinger <vapier@gentoo.org>2009-02-15 22:58:33 +0000
commitc5a77be252ed1e79a7a30c4387d51aa132215a44 (patch)
tree3ab40f8de138f9928ee6d0f9eef1169725e896e0 /sys-libs/libstdc++-v3/libstdc++-v3-3.3.6.ebuild
parentFix bug 251779 with ebuild from Michael Mair-Keimberger <miki3@gmx.net>. Also... (diff)
downloadhistorical-c5a77be252ed1e79a7a30c4387d51aa132215a44.tar.gz
historical-c5a77be252ed1e79a7a30c4387d51aa132215a44.tar.bz2
historical-c5a77be252ed1e79a7a30c4387d51aa132215a44.zip
Use the common gcc patchset.
Package-Manager: portage-2.2_rc23/cvs/Linux x86_64
Diffstat (limited to 'sys-libs/libstdc++-v3/libstdc++-v3-3.3.6.ebuild')
-rw-r--r--sys-libs/libstdc++-v3/libstdc++-v3-3.3.6.ebuild9
1 files changed, 5 insertions, 4 deletions
diff --git a/sys-libs/libstdc++-v3/libstdc++-v3-3.3.6.ebuild b/sys-libs/libstdc++-v3/libstdc++-v3-3.3.6.ebuild
index 4087f68bb076..71cdb541060f 100644
--- a/sys-libs/libstdc++-v3/libstdc++-v3-3.3.6.ebuild
+++ b/sys-libs/libstdc++-v3/libstdc++-v3-3.3.6.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2009 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-libs/libstdc++-v3/libstdc++-v3-3.3.6.ebuild,v 1.20 2009/02/05 04:12:56 je_fro Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-libs/libstdc++-v3/libstdc++-v3-3.3.6.ebuild,v 1.21 2009/02/15 22:58:32 vapier Exp $
inherit eutils flag-o-matic libtool gnuconfig versionator
@@ -105,6 +105,7 @@ S=${WORKDIR}/gcc-${PV}
# Theoretical cross compiler support
[ ! -n "${CCHOST}" ] && export CCHOST="${CHOST}"
+PATCH_VER="1.6"
LOC="/usr"
#MY_PV="`echo ${PV} | awk -F. '{ gsub(/_pre.*|_alpha.*/, ""); print $1 "." $2 }'`"
#MY_PV_FULL="`echo ${PV} | awk '{ gsub(/_pre.*|_alpha.*/, ""); print $0 }'`"
@@ -118,7 +119,8 @@ DATAPATH="${LOC}/share/gcc-data/${CCHOST}/${MY_PV}"
# We will handle /usr/include/g++-v3/ with gcc-config ...
STDCXX_INCDIR="${LIBPATH}/include/g++-v${MY_PV/\.*/}"
-SRC_URI="ftp://gcc.gnu.org/pub/gcc/releases/gcc-${PV}/gcc-${PV}.tar.bz2"
+SRC_URI="ftp://gcc.gnu.org/pub/gcc/releases/gcc-${PV}/gcc-${PV}.tar.bz2
+ mirror://gentoo/gcc-${PV}-patches-${PATCH_VER}.tar.bz2"
DESCRIPTION="Compatibility package for running binaries linked against a pre gcc 3.4 libstdc++"
HOMEPAGE="http://gcc.gnu.org/libstdc++/"
@@ -158,8 +160,7 @@ src_unpack() {
unpack ${A}
cd "${S}"
-
- epatch "${FILESDIR}"/libstdc++-v3-open_missing_mode.patch || die "epatch failed"
+ EPATCH_SUFFIX="patch" epatch "${WORKDIR}"/patch
# Fixup libtool to correctly generate .la files with portage
elibtoolize --portage --shallow