summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMike Frysinger <vapier@gentoo.org>2012-10-09 17:07:32 +0000
committerMike Frysinger <vapier@gentoo.org>2012-10-09 17:07:32 +0000
commit06c8cf8ccc0f089728ff886fb9369f5b7ca39980 (patch)
treefa15e973649bb9e7fbb6a400c92286b5afdf8fc7 /sys-libs/libunwind/libunwind-1.1.ebuild
parentAdd m68k love #375737 by Ryan Hill. (diff)
downloadhistorical-06c8cf8ccc0f089728ff886fb9369f5b7ca39980.tar.gz
historical-06c8cf8ccc0f089728ff886fb9369f5b7ca39980.tar.bz2
historical-06c8cf8ccc0f089728ff886fb9369f5b7ca39980.zip
Version bump.
Package-Manager: portage-2.2.0_alpha131/cvs/Linux x86_64
Diffstat (limited to 'sys-libs/libunwind/libunwind-1.1.ebuild')
-rw-r--r--sys-libs/libunwind/libunwind-1.1.ebuild55
1 files changed, 55 insertions, 0 deletions
diff --git a/sys-libs/libunwind/libunwind-1.1.ebuild b/sys-libs/libunwind/libunwind-1.1.ebuild
new file mode 100644
index 000000000000..6f02822e32f6
--- /dev/null
+++ b/sys-libs/libunwind/libunwind-1.1.ebuild
@@ -0,0 +1,55 @@
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sys-libs/libunwind/libunwind-1.1.ebuild,v 1.1 2012/10/09 17:07:32 vapier Exp $
+
+EAPI="4"
+
+DESCRIPTION="Portable and efficient API to determine the call-chain of a program"
+HOMEPAGE="http://savannah.nongnu.org/projects/libunwind"
+SRC_URI="http://download.savannah.nongnu.org/releases/libunwind/${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="7"
+KEYWORDS="~amd64 ~arm ~ia64 ~ppc ~x86 ~amd64-fbsd ~x86-fbsd"
+IUSE="debug debug-frame static-libs"
+
+DOCS=( AUTHORS ChangeLog NEWS README TODO )
+
+QA_DT_NEEDED_x86_fbsd="usr/lib/libunwind.so.7.0.0"
+
+src_prepare() {
+ # These tests like to fail. bleh.
+ echo 'int main(){return 0;}' > tests/Gtest-dyn1.c
+ echo 'int main(){return 0;}' > tests/Ltest-dyn1.c
+}
+
+src_configure() {
+ # do not $(use_enable) because the configure.in is broken and parses
+ # --disable-debug the same as --enable-debug.
+ # https://savannah.nongnu.org/bugs/index.php?34324
+ # --enable-cxx-exceptions: always enable it, headers provide the interface
+ # and on some archs it is disabled by default causing a mismatch between the
+ # API and the ABI, bug #418253
+ # conservative-checks: validate memory addresses before use; as of 1.0.1,
+ # only x86_64 supports this, yet may be useful for debugging, couple it with
+ # debug useflag.
+ econf \
+ --enable-cxx-exceptions \
+ $(use_enable debug-frame) \
+ $(use_enable static-libs static) \
+ $(use_enable debug conservative_checks) \
+ $(use debug && echo --enable-debug)
+}
+
+src_test() {
+ # Explicitly allow parallel build of tests.
+ # Sandbox causes some tests to freak out.
+ SANDBOX_ON=0 emake check
+}
+
+src_install() {
+ default
+ # libunwind-ptrace.a (and libunwind-ptrace.h) is separate API and without
+ # shared library, so we keep it in any case
+ use static-libs || find "${ED}"usr '(' -name 'libunwind-generic.a' -o -name 'libunwind*.la' ')' -delete
+}