summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSamuli Suominen <ssuominen@gentoo.org>2013-09-12 19:15:41 +0000
committerSamuli Suominen <ssuominen@gentoo.org>2013-09-12 19:15:41 +0000
commit71e40576107afcde799f347205701aee6a9c129a (patch)
tree48bed8f3e21cd6b409a682558d962223b5ca1271 /sys-libs/libunwind/libunwind-1.1.ebuild
parentStable for ppc64, wrt bug #480094 (diff)
downloadhistorical-71e40576107afcde799f347205701aee6a9c129a.tar.gz
historical-71e40576107afcde799f347205701aee6a9c129a.tar.bz2
historical-71e40576107afcde799f347205701aee6a9c129a.zip
Correct LIBLZMA="-lzma" with LIBLZMA="-llzma" (and edit both configure and configure.ac to avoid running eautoreconf only for this) as per #444050 by Marcin Mirosław
Package-Manager: portage-2.2.2/cvs/Linux x86_64 Manifest-Sign-Key: 0x4868F14D
Diffstat (limited to 'sys-libs/libunwind/libunwind-1.1.ebuild')
-rw-r--r--sys-libs/libunwind/libunwind-1.1.ebuild8
1 files changed, 6 insertions, 2 deletions
diff --git a/sys-libs/libunwind/libunwind-1.1.ebuild b/sys-libs/libunwind/libunwind-1.1.ebuild
index 9098f779dcdd..2de35a5195e8 100644
--- a/sys-libs/libunwind/libunwind-1.1.ebuild
+++ b/sys-libs/libunwind/libunwind-1.1.ebuild
@@ -1,8 +1,8 @@
# Copyright 1999-2013 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-libs/libunwind/libunwind-1.1.ebuild,v 1.7 2013/03/17 15:54:03 ago Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-libs/libunwind/libunwind-1.1.ebuild,v 1.8 2013/09/12 19:15:36 ssuominen Exp $
-EAPI="4"
+EAPI="5"
inherit eutils
@@ -15,6 +15,8 @@ SLOT="7"
KEYWORDS="amd64 arm ~ia64 ~ppc ~ppc64 ~x86 ~amd64-fbsd ~x86-fbsd ~amd64-linux ~x86-linux"
IUSE="debug debug-frame libatomic lzma static-libs"
+RESTRICT="test" #461958 -- re-enable tests with >1.1 again for retesting, this is here for #461394
+
# We just use the header from libatomic.
RDEPEND="lzma? ( app-arch/xz-utils )"
DEPEND="${RDEPEND}
@@ -28,6 +30,8 @@ src_prepare() {
# These tests like to fail. bleh.
echo 'int main(){return 0;}' > tests/Gtest-dyn1.c
echo 'int main(){return 0;}' > tests/Ltest-dyn1.c
+
+ sed -i -e '/LIBLZMA/s:-lzma:-llzma:' configure{,.ac} || die #444050
}
src_configure() {