summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMike Frysinger <vapier@gentoo.org>2012-11-20 16:41:57 +0000
committerMike Frysinger <vapier@gentoo.org>2012-11-20 16:41:57 +0000
commitc547e6b843244f141d0d50c69622931b4f0c8da0 (patch)
tree500e437e9ad4c198bebb05291458b405e88d24bb /sys-libs/libunwind/libunwind-1.1.ebuild
parentstable ppc, bug #442600 (diff)
downloadhistorical-c547e6b843244f141d0d50c69622931b4f0c8da0.tar.gz
historical-c547e6b843244f141d0d50c69622931b4f0c8da0.tar.bz2
historical-c547e6b843244f141d0d50c69622931b4f0c8da0.zip
Add USE=lzma to control liblzma usage.
Package-Manager: portage-2.2.0_alpha142/cvs/Linux x86_64 Manifest-Sign-Key: 0xFB7C4156
Diffstat (limited to 'sys-libs/libunwind/libunwind-1.1.ebuild')
-rw-r--r--sys-libs/libunwind/libunwind-1.1.ebuild8
1 files changed, 6 insertions, 2 deletions
diff --git a/sys-libs/libunwind/libunwind-1.1.ebuild b/sys-libs/libunwind/libunwind-1.1.ebuild
index 1f1709bfb87a..703b7c9cb37b 100644
--- a/sys-libs/libunwind/libunwind-1.1.ebuild
+++ b/sys-libs/libunwind/libunwind-1.1.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2012 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-libs/libunwind/libunwind-1.1.ebuild,v 1.2 2012/11/02 00:48:02 blueness Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-libs/libunwind/libunwind-1.1.ebuild,v 1.3 2012/11/20 16:41:52 vapier Exp $
EAPI="4"
@@ -11,7 +11,10 @@ SRC_URI="http://download.savannah.nongnu.org/releases/libunwind/${P}.tar.gz"
LICENSE="MIT"
SLOT="7"
KEYWORDS="~amd64 ~arm ~ia64 ~ppc ~ppc64 ~x86 ~amd64-fbsd ~x86-fbsd"
-IUSE="debug debug-frame static-libs"
+IUSE="debug debug-frame lzma static-libs"
+
+RDEPEND="lzma? ( app-arch/xz-utils )"
+DEPEND="${RDEPEND}"
DOCS=( AUTHORS ChangeLog NEWS README TODO )
@@ -36,6 +39,7 @@ src_configure() {
econf \
--enable-cxx-exceptions \
$(use_enable debug-frame) \
+ $(use_enable lzma minidebuginfo) \
$(use_enable static-libs static) \
$(use_enable debug conservative_checks) \
$(use debug && echo --enable-debug)