summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMike Frysinger <vapier@gentoo.org>2003-08-03 04:41:56 +0000
committerMike Frysinger <vapier@gentoo.org>2003-08-03 04:41:56 +0000
commit0862b3e8a23e025e1dc306a48988681bdfd0df04 (patch)
tree3786ff5dc94d324ba91b3ace9569556c2a771b8e /sys-libs
parent$DEBUGBUILD -> use debug (diff)
downloadhistorical-0862b3e8a23e025e1dc306a48988681bdfd0df04.tar.gz
historical-0862b3e8a23e025e1dc306a48988681bdfd0df04.tar.bz2
historical-0862b3e8a23e025e1dc306a48988681bdfd0df04.zip
$DEBUGBUILD -> use debug
Diffstat (limited to 'sys-libs')
-rw-r--r--sys-libs/ncurses/ncurses-5.3-r1.ebuild13
-rw-r--r--sys-libs/ncurses/ncurses-5.3-r2.ebuild16
-rw-r--r--sys-libs/ncurses/ncurses-5.3-r3.ebuild12
3 files changed, 14 insertions, 27 deletions
diff --git a/sys-libs/ncurses/ncurses-5.3-r1.ebuild b/sys-libs/ncurses/ncurses-5.3-r1.ebuild
index 401cd7b03f26..9b960abb0d80 100644
--- a/sys-libs/ncurses/ncurses-5.3-r1.ebuild
+++ b/sys-libs/ncurses/ncurses-5.3-r1.ebuild
@@ -1,13 +1,10 @@
# Copyright 1999-2003 Gentoo Technologies, Inc.
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-libs/ncurses/ncurses-5.3-r1.ebuild,v 1.15 2003/06/22 05:10:31 seemant Exp $
-
-IUSE=""
+# $Header: /var/cvsroot/gentoo-x86/sys-libs/ncurses/ncurses-5.3-r1.ebuild,v 1.16 2003/08/03 04:41:56 vapier Exp $
inherit eutils flag-o-matic
-filter-flags "-fno-exceptions"
+filter-flags -fno-exceptions
-S="${WORKDIR}/${P}"
DESCRIPTION="Linux console display library"
HOMEPAGE="http://www.gnu.org/software/ncurses/ncurses.html"
SRC_URI="mirror://gnu/ncurses/${P}.tar.gz"
@@ -15,12 +12,12 @@ SRC_URI="mirror://gnu/ncurses/${P}.tar.gz"
LICENSE="MIT"
SLOT="5"
KEYWORDS="x86 ppc sparc alpha hppa arm mips"
+IUSE="debug"
DEPEND="virtual/glibc"
src_compile() {
-
- [ -z "${DEBUGBUILD}" ] && myconf="${myconf} --without-debug"
+ [ `use debug` ] && myconf="${myconf} --without-debug"
# From version 5.3, ncurses also build c++ bindings, and as
# we do not have a c++ compiler during bootstrap, disable
@@ -43,7 +40,6 @@ src_compile() {
}
src_install() {
-
make DESTDIR=${D} install || die "make install failed"
# Move static and extraneous ncurses libraries out of /lib
@@ -83,7 +79,6 @@ src_install() {
}
pkg_postinst() {
-
# Old ncurses may still be around from old build tbz2's.
rm -f /lib/libncurses.so.5.2
rm -f /usr/lib/lib{form,menu,panel}.so.5.2
diff --git a/sys-libs/ncurses/ncurses-5.3-r2.ebuild b/sys-libs/ncurses/ncurses-5.3-r2.ebuild
index 1afb20056ba5..0a2352f6fd32 100644
--- a/sys-libs/ncurses/ncurses-5.3-r2.ebuild
+++ b/sys-libs/ncurses/ncurses-5.3-r2.ebuild
@@ -1,13 +1,10 @@
# Copyright 1999-2003 Gentoo Technologies, Inc.
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-libs/ncurses/ncurses-5.3-r2.ebuild,v 1.6 2003/07/16 14:13:44 pvdabeel Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-libs/ncurses/ncurses-5.3-r2.ebuild,v 1.7 2003/08/03 04:41:56 vapier Exp $
-IUSE=""
+inherit flag-o-matic
+filter-flags -fno-exceptions
-inherit eutils flag-o-matic
-filter-flags "-fno-exceptions"
-
-S="${WORKDIR}/${P}"
DESCRIPTION="Linux console display library"
HOMEPAGE="http://www.gnu.org/software/ncurses/ncurses.html"
SRC_URI="mirror://gnu/ncurses/${P}.tar.gz"
@@ -15,18 +12,17 @@ SRC_URI="mirror://gnu/ncurses/${P}.tar.gz"
LICENSE="MIT"
SLOT="5"
KEYWORDS="amd64 ~x86 ppc ~sparc alpha ~hppa ~arm ~mips"
+IUSE="debug"
DEPEND="virtual/glibc"
src_unpack() {
-
unpack ${A}
epatch ${FILESDIR}/ncurses-5.3-xterm.patch
}
src_compile() {
-
- [ -z "${DEBUGBUILD}" ] && myconf="${myconf} --without-debug"
+ [ `use debug` ] && myconf="${myconf} --without-debug"
# From version 5.3, ncurses also build c++ bindings, and as
# we do not have a c++ compiler during bootstrap, disable
@@ -49,7 +45,6 @@ src_compile() {
}
src_install() {
-
make DESTDIR=${D} install || die "make install failed"
# Move static and extraneous ncurses libraries out of /lib
@@ -89,7 +84,6 @@ src_install() {
}
pkg_postinst() {
-
# Old ncurses may still be around from old build tbz2's.
rm -f /lib/libncurses.so.5.2
rm -f /usr/lib/lib{form,menu,panel}.so.5.2
diff --git a/sys-libs/ncurses/ncurses-5.3-r3.ebuild b/sys-libs/ncurses/ncurses-5.3-r3.ebuild
index b0a08a5cf671..00abbeebaadb 100644
--- a/sys-libs/ncurses/ncurses-5.3-r3.ebuild
+++ b/sys-libs/ncurses/ncurses-5.3-r3.ebuild
@@ -1,13 +1,10 @@
# Copyright 1999-2003 Gentoo Technologies, Inc.
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-libs/ncurses/ncurses-5.3-r3.ebuild,v 1.1 2003/08/01 13:17:04 agriffis Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-libs/ncurses/ncurses-5.3-r3.ebuild,v 1.2 2003/08/03 04:41:56 vapier Exp $
-IUSE=""
+inherit flag-o-matic
+filter-flags -fno-exceptions
-inherit eutils flag-o-matic
-filter-flags "-fno-exceptions"
-
-S="${WORKDIR}/${P}"
DESCRIPTION="Linux console display library"
HOMEPAGE="http://www.gnu.org/software/ncurses/ncurses.html"
SRC_URI="mirror://gnu/ncurses/${P}.tar.gz"
@@ -15,6 +12,7 @@ SRC_URI="mirror://gnu/ncurses/${P}.tar.gz"
LICENSE="MIT"
SLOT="5"
KEYWORDS="~amd64 ~x86 ~ppc ~sparc ~alpha ~hppa ~arm ~mips"
+IUSE="debug"
DEPEND="virtual/glibc"
@@ -24,7 +22,7 @@ src_unpack() {
}
src_compile() {
- [ -z "${DEBUGBUILD}" ] && myconf="${myconf} --without-debug"
+ [ `use debug` ] && myconf="${myconf} --without-debug"
# From version 5.3, ncurses also build c++ bindings, and as
# we do not have a c++ compiler during bootstrap, disable