summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2003-08-21 11:08:39 +0000
committerRobin H. Johnson <robbat2@gentoo.org>2003-08-21 11:08:39 +0000
commitecc761f03bf8f718688b048fba1ad2bb4bd5c488 (patch)
tree0ac95ad81a98a44fc262638ae06d2ebe1096226f /sys-libs
parentcrucial fix to all ebuilds db-3 or newer for bad symlinks in /usr/lib and /us... (diff)
downloadhistorical-ecc761f03bf8f718688b048fba1ad2bb4bd5c488.tar.gz
historical-ecc761f03bf8f718688b048fba1ad2bb4bd5c488.tar.bz2
historical-ecc761f03bf8f718688b048fba1ad2bb4bd5c488.zip
crucial fix to all ebuilds db-3 or newer for bad symlinks in /usr/lib and /usr/include, code is now in db.eclass
Diffstat (limited to 'sys-libs')
-rw-r--r--sys-libs/db/Manifest11
-rw-r--r--sys-libs/db/db-3.2.9-r8.ebuild141
-rw-r--r--sys-libs/db/db-4.0.14-r2.ebuild87
-rw-r--r--sys-libs/db/db-4.1.25_p1-r1.ebuild98
-rw-r--r--sys-libs/db/files/digest-db-3.2.9-r81
-rw-r--r--sys-libs/db/files/digest-db-4.0.14-r21
-rw-r--r--sys-libs/db/files/digest-db-4.1.25_p1-r12
7 files changed, 334 insertions, 7 deletions
diff --git a/sys-libs/db/Manifest b/sys-libs/db/Manifest
index 8371e5bf3d25..a2fbd8ae3298 100644
--- a/sys-libs/db/Manifest
+++ b/sys-libs/db/Manifest
@@ -1,19 +1,16 @@
MD5 23ef885593240daae90f0c3bc299054c db-3.3.11.ebuild 2407
MD5 f304a97a24cc12170b7859b425aa148e db-3.2.9-r6.ebuild 4321
MD5 4b430a40a2fbaf6adbc2f40ac901947a db-4.1.25_p1.ebuild 2765
-MD5 c71e9e2951f9aa78afcb5ba13a73edd7 db-3.2.9-r8.ebuild 3666
-MD5 f69e5301d05c3c1d5844ec5c944f3354 db-4.0.14-r2.ebuild~ 2017
-MD5 4169d650f0786d253d388cde119c9267 db-4.1.25_p1-r1.ebuild 2093
+MD5 61ed87c72011cdd9331f7d873f2199aa db-3.2.9-r8.ebuild 3424
+MD5 9eec15cea175a90e0f0ee5ec7a6653e7 db-4.1.25_p1-r1.ebuild 1894
MD5 d0744340471b0554a2f4ff62978e0258 db-1.85-r1.ebuild 1411
-MD5 009f72624194a7c0d37b0533db94d75c db-4.0.14-r2.ebuild 2029
+MD5 8595fb0e355bfbbca343059e9506f4f1 db-4.0.14-r2.ebuild 1856
MD5 3fa2f9737e2c0ac4230fd12f3c8b54a5 db-3.2.9-r7.ebuild 4370
MD5 09ddb16abbd409d87e899893d698dff3 db-3.2.9-r2.ebuild 3221
MD5 01e9f1d4c2c9ac3dd639d98bd03c768c db-4.1.25.ebuild 2259
-MD5 e64f4ad19c6a23cb87785a0911ed9c49 db-4.1.25_p1-r1.ebuild~ 2088
MD5 6f3169cda6bac26f0aaa65dd76331c76 db-4.0.14.ebuild 2386
-MD5 b50ca7abd6d995d163b19465313a5dcb ChangeLog 7977
+MD5 72eb7db9a2acbc0d1632ba5dbe185021 ChangeLog 8248
MD5 5c921197970cd970a8fbb4cad2d7df7b metadata.xml 1457
-MD5 c71e9e2951f9aa78afcb5ba13a73edd7 db-3.2.9-r8.ebuild~ 3666
MD5 e6fb267b86831c5399fe6bb12b062481 db-4.0.14-r1.ebuild 2706
MD5 eb9b0f2c1d8440c6c49fc1d916c2dc0e files/db-4.0.14-fix-dep-link.patch 1119
MD5 44c6041ae9527bfa8a4ff4cec7cf4a9a files/digest-db-3.2.9-r2 61
diff --git a/sys-libs/db/db-3.2.9-r8.ebuild b/sys-libs/db/db-3.2.9-r8.ebuild
new file mode 100644
index 000000000000..88305062011c
--- /dev/null
+++ b/sys-libs/db/db-3.2.9-r8.ebuild
@@ -0,0 +1,141 @@
+# Copyright 1999-2003 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sys-libs/db/db-3.2.9-r8.ebuild,v 1.1 2003/08/21 11:08:36 robbat2 Exp $
+
+IUSE="doc"
+
+inherit libtool
+inherit eutils
+inherit db
+
+S="${WORKDIR}/${P}"
+DESCRIPTION="Berkeley DB for transaction support in MySQL"
+SRC_URI="http://www.sleepycat.com/update/snapshot/${P}.tar.gz"
+HOMEPAGE="http://www.sleepycat.com/"
+
+SLOT="3"
+LICENSE="DB"
+# This ebuild is to be the compatibility ebuild for when db4 is put
+# in the tree.
+KEYWORDS="~x86 ~ppc ~sparc ~alpha ~mips ~hppa ~arm"
+
+RDEPEND="virtual/glibc"
+DEPEND="${RDEPEND}
+ =sys-libs/db-1.85-r1
+ sys-devel/libtool
+ sys-devel/m4"
+# We need m4 too else build fails without config.guess
+
+# This doesn't build without exceptions
+export CXXFLAGS="${CXXFLAGS/-fno-exceptions/-fexceptions}"
+
+src_unpack() {
+ unpack ${A}
+
+ chmod -R ug+w *
+
+ cd ${WORKDIR}/${P}
+ epatch ${FILESDIR}/patch.3.2.9.1
+ epatch ${FILESDIR}/patch.3.2.9.2
+
+ # Get db to link libdb* to correct dependencies ... for example if we use
+ # NPTL or NGPT, db detects usable mutexes, and should link against
+ # libpthread, but does not do so ...
+ # <azarah@gentoo.org> (23 Feb 2003)
+ epatch ${FILESDIR}/${P}-fix-dep-link.patch
+
+ # We should get dump185 to link against system db1 ..
+ # <azarah@gentoo.org> (23 Feb 2003)
+ mv ${S}/dist/Makefile.in ${S}/dist/Makefile.in.orig
+ sed -e 's:DB185INC=:DB185INC= -I/usr/include/db1:' \
+ -e 's:DB185LIB=:DB185LIB= -ldb1:' \
+ ${S}/dist/Makefile.in.orig > ${S}/dist/Makefile.in || die "Failed to sed"
+
+ # Fix invalid .la files
+ cd ${WORKDIR}/${P}/dist
+ rm -f ltversion.sh
+ # remove config.guess else we have problems with gcc-3.2
+ rm -f config.guess
+ sed -i "s,\(-D_GNU_SOURCE\),\1 ${CFLAGS}," configure
+}
+
+src_compile() {
+ local conf=
+
+ conf="--host=${CHOST} \
+ --build=${CHOST} \
+ --enable-cxx \
+ --enable-compat185 \
+ --enable-dump185 \
+ --prefix=/usr"
+ # --enable-rpc aparently does not work .. should verify this
+ # at some stage ...
+
+ # NOTE: we should not build both shared and static versions
+ # of the libraries in the same build root!
+
+ einfo "Configuring ${P} (static)..."
+ mkdir -p ${S}/build-static
+ cd ${S}/build-static
+ ../dist/configure ${conf} \
+ --enable-static || die
+
+ einfo "Configuring ${P} (shared)..."
+ mkdir -p ${S}/build-shared
+ cd ${S}/build-shared
+ ../dist/configure ${conf} \
+ --enable-shared || die
+
+ # Parallel make does not work
+ MAKEOPTS="${MAKEOPTS} -j1"
+ einfo "Building ${P} (static)..."
+ cd ${S}/build-static
+ emake || die "Static build failed"
+ einfo "Building ${P} (shared)..."
+ cd ${S}/build-shared
+ emake || die "Shared build failed"
+}
+
+src_install () {
+ cd ${S}/build-shared
+ make libdb=libdb-3.2.a \
+ libcxx=libcxx_3.2.a \
+ prefix=${D}/usr \
+ install || die
+
+ cd ${S}/build-static
+ cp libdb.a libdb-3.2.a
+ cp libdb_cxx.a libdb_cxx-3.2.a
+ dolib.a libdb-3.2.a libdb_cxx-3.2.a
+
+ db_src_install_headerslot
+
+ cd ${D}/usr/lib
+ ln -s libdb-3.2.so libdb.so.3
+
+ # For some reason, db.so's are *not* readable by group or others,
+ # resulting in no one but root being able to use them!!!
+ # This fixes it -- DR 15 Jun 2001
+ cd ${D}/usr/lib
+ chmod go+rx *.so
+ # The .la's aren't readable either
+ chmod go+r *.la
+
+ cd ${S}
+ dodoc README LICENSE
+
+ db_src_install_doc
+
+ db_src_install_usrbinslot
+
+ db_src_install_usrlibcleanup
+}
+
+pkg_postinst () {
+ db_fix_so
+}
+
+pkg_postrm () {
+ db_fix_so
+}
+
diff --git a/sys-libs/db/db-4.0.14-r2.ebuild b/sys-libs/db/db-4.0.14-r2.ebuild
new file mode 100644
index 000000000000..379263f88515
--- /dev/null
+++ b/sys-libs/db/db-4.0.14-r2.ebuild
@@ -0,0 +1,87 @@
+# Copyright 1999-2003 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sys-libs/db/db-4.0.14-r2.ebuild,v 1.1 2003/08/21 11:08:36 robbat2 Exp $
+
+IUSE="tcltk java doc"
+
+inherit eutils
+inherit db
+
+S="${WORKDIR}/${P}/build_unix"
+DESCRIPTION="Berkeley DB"
+SRC_URI="http://www.sleepycat.com/update/snapshot/${P}.tar.gz"
+HOMEPAGE="http://www.sleepycat.com"
+SLOT="4"
+LICENSE="DB"
+KEYWORDS="~x86"
+
+DEPEND="tcltk? ( dev-lang/tcl )
+ java? ( virtual/jdk )"
+
+src_unpack() {
+ unpack ${A}
+
+ # Get db to link libdb* to correct dependencies ... for example if we use
+ # NPTL or NGPT, db detects usable mutexes, and should link against
+ # libpthread, but does not do so ...
+ # <azarah@gentoo.org> (23 Feb 2003)
+ cd ${WORKDIR}/${P}; epatch ${FILESDIR}/${P}-fix-dep-link.patch
+}
+
+src_compile() {
+
+ local myconf=
+
+ use java \
+ && myconf="${myconf} --enable-java" \
+ || myconf="${myconf} --disable-java"
+
+ use tcltk \
+ && myconf="${myconf} --enable-tcl --with-tcl=/usr/lib" \
+ || myconf="${myconf} --disable-tcl"
+
+ if use java && [ -n "${JAVAC}" ]; then
+ export PATH=`dirname ${JAVAC}`:${PATH}
+ export JAVAC=`basename ${JAVAC}`
+ fi
+
+ ../dist/configure \
+ --prefix=/usr \
+ --mandir=/usr/share/man \
+ --infodir=/usr/share/info \
+ --datadir=/usr/share \
+ --sysconfdir=/etc \
+ --localstatedir=/var/lib \
+ --enable-compat185 \
+ --enable-cxx \
+ --with-uniquename \
+ ${myconf} || die
+
+# disable posix mutexes as they are not available in linuxthreads from
+# the standard profile and they should be autodetected if available
+#
+# --enable-posixmutexes \
+
+ emake || make || die
+}
+
+src_install () {
+
+ einstall || die
+
+ db_src_install_usrbinslot
+
+ db_src_install_headerslot
+
+ db_src_install_doc
+
+ db_src_install_usrlibcleanup
+}
+
+pkg_postinst () {
+ db_fix_so
+}
+
+pkg_postrm () {
+ db_fix_so
+}
diff --git a/sys-libs/db/db-4.1.25_p1-r1.ebuild b/sys-libs/db/db-4.1.25_p1-r1.ebuild
new file mode 100644
index 000000000000..4abcc46f42c0
--- /dev/null
+++ b/sys-libs/db/db-4.1.25_p1-r1.ebuild
@@ -0,0 +1,98 @@
+# Copyright 1999-2003 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sys-libs/db/db-4.1.25_p1-r1.ebuild,v 1.1 2003/08/21 11:08:36 robbat2 Exp $
+
+IUSE="tcltk java doc"
+
+inherit eutils
+inherit db
+
+#Number of official patches
+PATCHNO=`echo ${PV}|sed -e "s,\(.*_p\)\([0-9]*\),\2,"`
+if [ "${PATCHNO}" == "${PV}" ]; then
+ MY_PV=${PV}
+ MY_P=${P}
+ PATCHNO=0
+else
+ MY_PV=${PV/_p${PATCHNO}}
+ MY_P=${PN}-${MY_PV}
+fi
+
+S=${WORKDIR}/${MY_P}/build_unix
+DESCRIPTION="Berkeley DB"
+SRC_URI="http://www.sleepycat.com/update/snapshot/${MY_P}.tar.gz"
+
+for (( i=1 ; i<=$PATCHNO ; i++ ))
+do
+ export SRC_URI="${SRC_URI} http://www.sleepycat.com/update/${MY_PV}/patch.${MY_PV}.${i}"
+done
+
+HOMEPAGE="http://www.sleepycat.com"
+SLOT="4.1"
+LICENSE="DB"
+KEYWORDS="amd64"
+
+DEPEND="tcltk? ( dev-lang/tcl )
+ java? ( virtual/jdk )"
+
+src_unpack() {
+ unpack ${MY_P}.tar.gz
+ cd ${WORKDIR}/${MY_P}
+ for (( i=1 ; i<=$PATCHNO ; i++ ))
+ do
+ patch -p0 <${DISTDIR}/patch.${MY_PV}.${i}
+ done
+}
+
+src_compile() {
+
+ local myconf
+
+ use java \
+ && myconf="${myconf} --enable-java" \
+ || myconf="${myconf} --disable-java"
+
+ use tcltk \
+ && myconf="${myconf} --enable-tcl --with-tcl=/usr/lib" \
+ || myconf="${myconf} --disable-tcl"
+
+ if use java && [ -n "${JAVAC}" ]; then
+ export PATH=`dirname ${JAVAC}`:${PATH}
+ export JAVAC=`basename ${JAVAC}`
+ fi
+
+ ../dist/configure \
+ --prefix=/usr \
+ --mandir=/usr/share/man \
+ --infodir=/usr/share/info \
+ --datadir=/usr/share \
+ --sysconfdir=/etc \
+ --localstatedir=/var/lib \
+ --enable-compat185 \
+ --enable-cxx \
+ --with-uniquename \
+ ${myconf} || die
+
+ emake || make || die
+}
+
+src_install () {
+
+ einstall || die
+
+ db_src_install_usrbinslot
+
+ db_src_install_headerslot
+
+ db_src_install_doc
+
+ db_src_install_usrlibcleanup
+}
+
+pkg_postinst () {
+ db_fix_so
+}
+
+pkg_postrm () {
+ db_fix_so
+}
diff --git a/sys-libs/db/files/digest-db-3.2.9-r8 b/sys-libs/db/files/digest-db-3.2.9-r8
new file mode 100644
index 000000000000..cc0f167ea09b
--- /dev/null
+++ b/sys-libs/db/files/digest-db-3.2.9-r8
@@ -0,0 +1 @@
+MD5 4df5c7051b11411e0a970f6c91613942 db-3.2.9.tar.gz 2085238
diff --git a/sys-libs/db/files/digest-db-4.0.14-r2 b/sys-libs/db/files/digest-db-4.0.14-r2
new file mode 100644
index 000000000000..cb9924c89b80
--- /dev/null
+++ b/sys-libs/db/files/digest-db-4.0.14-r2
@@ -0,0 +1 @@
+MD5 12262c64fcd64b772e7cffad8e4d0ebc db-4.0.14.tar.gz 2701799
diff --git a/sys-libs/db/files/digest-db-4.1.25_p1-r1 b/sys-libs/db/files/digest-db-4.1.25_p1-r1
new file mode 100644
index 000000000000..4f81c12b1c1e
--- /dev/null
+++ b/sys-libs/db/files/digest-db-4.1.25_p1-r1
@@ -0,0 +1,2 @@
+MD5 df71961002b552c0e72c6e4e358f27e1 db-4.1.25.tar.gz 3080234
+MD5 1e073d12cd89f9345e281ca07368f74b patch.4.1.25.1 610