summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorChristian Ruppert <idl0r@gentoo.org>2012-11-06 20:54:47 +0000
committerChristian Ruppert <idl0r@gentoo.org>2012-11-06 20:54:47 +0000
commit102d036d207d2449dca368cb8e74fabc2d4c035f (patch)
tree0143f12dc8998fede434f9b1c209d0db6625246d /sys-process/htop/htop-1.0.2.ebuild
parentAdd mercurial as alternative to quilt. Fixes bug 196523 by James Rowe <jnrowe... (diff)
downloadhistorical-102d036d207d2449dca368cb8e74fabc2d4c035f.tar.gz
historical-102d036d207d2449dca368cb8e74fabc2d4c035f.tar.bz2
historical-102d036d207d2449dca368cb8e74fabc2d4c035f.zip
Version bump, bug 442098
Package-Manager: portage-2.2.0_alpha142/cvs/Linux x86_64 Manifest-Sign-Key: 0xB427ABC8
Diffstat (limited to 'sys-process/htop/htop-1.0.2.ebuild')
-rw-r--r--sys-process/htop/htop-1.0.2.ebuild61
1 files changed, 61 insertions, 0 deletions
diff --git a/sys-process/htop/htop-1.0.2.ebuild b/sys-process/htop/htop-1.0.2.ebuild
new file mode 100644
index 000000000000..54ea5740978b
--- /dev/null
+++ b/sys-process/htop/htop-1.0.2.ebuild
@@ -0,0 +1,61 @@
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sys-process/htop/htop-1.0.2.ebuild,v 1.1 2012/11/06 20:54:40 idl0r Exp $
+
+EAPI=4
+
+# autotools for auto* dependencies
+inherit autotools
+
+DESCRIPTION="interactive process viewer"
+HOMEPAGE="http://htop.sourceforge.net"
+SRC_URI="mirror://sourceforge/${PN}/${P}.tar.gz"
+
+LICENSE="BSD GPL-2"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~mips ~ppc ~ppc64 ~sh ~sparc ~x86 ~amd64-fbsd ~x86-fbsd ~x64-freebsd ~x86-freebsd ~amd64-linux ~x86-linux"
+IUSE="kernel_FreeBSD kernel_linux openvz unicode vserver"
+
+RDEPEND="sys-libs/ncurses[unicode?]"
+DEPEND="${RDEPEND}"
+
+DOCS=( ChangeLog README )
+
+pkg_setup() {
+ if use kernel_FreeBSD && ! [[ -f ${ROOT}/compat/linux/proc/stat && -f ${ROOT}/compat/linux/proc/meminfo ]]; then
+ eerror
+ eerror "htop requires linprocfs mounted at /compat/linux/proc to build and function."
+ eerror "To mount it, type:"
+ [ -d /compat/linux/proc ] || eerror "mkdir -p /compat/linux/proc"
+ eerror "mount -t linprocfs none /compat/linux/proc"
+ eerror "Alternatively, place this information into /etc/fstab"
+ eerror
+ die "htop needs /compat/linux/proc mounted"
+ fi
+
+ if ! has_version sys-process/lsof; then
+ ewarn "To use lsof features in htop(what processes are accessing"
+ ewarn "what files), you must have sys-process/lsof installed."
+ fi
+}
+
+src_prepare() {
+ sed -i -e '1c\#!'"${EPREFIX}"'/usr/bin/python' \
+ scripts/MakeHeader.py || die
+}
+
+src_configure() {
+ [[ $CBUILD != $CHOST ]] && export ac_cv_file__proc_{meminfo,stat}=yes #328971
+
+ myconf=''
+
+ use kernel_FreeBSD && myconf="${myconf} --with-proc=/compat/linux/proc"
+
+ econf \
+ $(use_enable openvz) \
+ $(use_enable kernel_linux cgroup) \
+ $(use_enable vserver) \
+ $(use_enable unicode) \
+ --enable-taskstats \
+ ${myconf}
+}