summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMike Frysinger <vapier@gentoo.org>2005-12-22 00:17:21 +0000
committerMike Frysinger <vapier@gentoo.org>2005-12-22 00:17:21 +0000
commit6b04b8693c3b067a41d8bfa22f7dbf66a69fa567 (patch)
treefb3dd3273952aed1e7db3b928d058bd0242b4d33 /sys-process/procps
parentold (diff)
downloadhistorical-6b04b8693c3b067a41d8bfa22f7dbf66a69fa567.tar.gz
historical-6b04b8693c3b067a41d8bfa22f7dbf66a69fa567.tar.bz2
historical-6b04b8693c3b067a41d8bfa22f7dbf66a69fa567.zip
Version bump.
Package-Manager: portage-2.0.53
Diffstat (limited to 'sys-process/procps')
-rw-r--r--sys-process/procps/ChangeLog11
-rw-r--r--sys-process/procps/files/digest-procps-3.2.61
-rw-r--r--sys-process/procps/files/procps-3.2.6-mips-n32_isnt_usable_on_mips64_yet.patch11
-rw-r--r--sys-process/procps/procps-3.2.6.ebuild74
4 files changed, 95 insertions, 2 deletions
diff --git a/sys-process/procps/ChangeLog b/sys-process/procps/ChangeLog
index 0a357477f498..52b0ef89d8c1 100644
--- a/sys-process/procps/ChangeLog
+++ b/sys-process/procps/ChangeLog
@@ -1,6 +1,13 @@
# ChangeLog for sys-process/procps
-# Copyright 2002-2005 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sys-process/procps/ChangeLog,v 1.7 2005/07/17 13:36:13 dertobi123 Exp $
+# Copyright 1999-2005 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/sys-process/procps/ChangeLog,v 1.8 2005/12/22 00:13:54 vapier Exp $
+
+*procps-3.2.6 (22 Dec 2005)
+
+ 22 Dec 2005; Mike Frysinger <vapier@gentoo.org>
+ +files/procps-3.2.6-mips-n32_isnt_usable_on_mips64_yet.patch,
+ +procps-3.2.6.ebuild:
+ Version bump.
17 Jul 2005; Tobias Scherbaum <dertobi123@gentoo.org>
procps-3.2.5-r1.ebuild:
diff --git a/sys-process/procps/files/digest-procps-3.2.6 b/sys-process/procps/files/digest-procps-3.2.6
new file mode 100644
index 000000000000..02981df289b4
--- /dev/null
+++ b/sys-process/procps/files/digest-procps-3.2.6
@@ -0,0 +1 @@
+MD5 7ce39ea27d7b3da0e8ad74dd41d06783 procps-3.2.6.tar.gz 279084
diff --git a/sys-process/procps/files/procps-3.2.6-mips-n32_isnt_usable_on_mips64_yet.patch b/sys-process/procps/files/procps-3.2.6-mips-n32_isnt_usable_on_mips64_yet.patch
new file mode 100644
index 000000000000..25e0f1b217fd
--- /dev/null
+++ b/sys-process/procps/files/procps-3.2.6-mips-n32_isnt_usable_on_mips64_yet.patch
@@ -0,0 +1,11 @@
+--- proc/procps.h.orig 2005-12-21 19:12:11.000000000 -0500
++++ proc/procps.h 2005-12-21 19:12:17.000000000 -0500
+@@ -31,7 +31,7 @@
+ //
+ // Unknown: PA-RISC and zSeries
+ //
+-#if defined(k64test) || (defined(_ABIN32) && _MIPS_SIM == _ABIN32)
++#if defined(k64test)
+ #define KLONG long long // not typedef; want "unsigned KLONG" to work
+ #define KLF "L"
+ #define STRTOUKL strtoull
diff --git a/sys-process/procps/procps-3.2.6.ebuild b/sys-process/procps/procps-3.2.6.ebuild
new file mode 100644
index 000000000000..cd10c06b4cf6
--- /dev/null
+++ b/sys-process/procps/procps-3.2.6.ebuild
@@ -0,0 +1,74 @@
+# Copyright 1999-2005 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sys-process/procps/procps-3.2.6.ebuild,v 1.1 2005/12/22 00:13:54 vapier Exp $
+
+inherit flag-o-matic eutils toolchain-funcs
+
+DESCRIPTION="Standard informational utilities and process-handling tools"
+HOMEPAGE="http://procps.sourceforge.net/"
+SRC_URI="http://procps.sourceforge.net/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~m68k ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86"
+IUSE="n32"
+
+RDEPEND=">=sys-libs/ncurses-5.2-r2"
+
+src_unpack() {
+ unpack ${A}
+ cd "${S}"
+
+ # Fix terminal breakage when sorting first column in top #80296
+ epatch "${FILESDIR}"/3.2.5-top-sort.patch
+ # Pretty up the /proc mount error message
+ epatch "${FILESDIR}"/procps-3.2.5-proc-mount.patch
+
+ # Clean up the makefile
+ # - we do stripping ourselves
+ # - punt fugly gcc flags
+ sed -i \
+ -e '/install/s: --strip : :' \
+ -e '/ALL_CFLAGS += $(call check_gcc,-fweb,)/d' \
+ -e '/ALL_CFLAGS += $(call check_gcc,-Wstrict-aliasing=2,)/s,=2,,' \
+ -e "/^lib64/s:=.*:=$(get_libdir):" \
+ -e 's:-m64::g' \
+ Makefile || die "sed Makefile"
+
+ # mips 2.4.23 headers (and 2.6.x) don't allow PAGE_SIZE to be defined in
+ # userspace anymore, so this patch instructs procps to get the
+ # value from sysconf().
+ epatch "${FILESDIR}"/${PN}-mips-define-pagesize.patch
+
+ # n32 isn't completly reliable of an ABI on mips64 at the current
+ # time. Eventually, it will be, but for now, we need to make sure
+ # procps doesn't try to force it on us.
+ if ! use n32 ; then
+ epatch "${FILESDIR}"/${P}-mips-n32_isnt_usable_on_mips64_yet.patch
+ fi
+}
+
+src_compile() {
+ replace-flags -O3 -O2
+ emake \
+ CC="$(tc-getCC)" \
+ CPPFLAGS="${CPPFLAGS}" \
+ CFLAGS="${CFLAGS}" \
+ LDFLAGS="${LDFLAGS}" \
+ || die "make failed"
+}
+
+src_install() {
+ make install ldconfig="true" DESTDIR="${D}" || die "install failed"
+
+ insinto /usr/include/proc
+ doins proc/*.h || die "doins include"
+
+ dodoc sysctl.conf BUGS NEWS TODO ps/HACKING
+}
+
+pkg_postinst() {
+ einfo "NOTE: With NPTL \"ps\" and \"top\" no longer"
+ einfo "show threads. You can use any of: -m m -L -T H"
+ einfo "in ps or the H key in top to show them"
+}