summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRenat Lumpau <rl03@gentoo.org>2006-08-17 15:59:22 +0000
committerRenat Lumpau <rl03@gentoo.org>2006-08-17 15:59:22 +0000
commit89f3568d9649c970a2d92a8abf751e1d31a0d983 (patch)
treead30643f97911f69c7812d548ea01b20530405ae /www-apps/sitebar
parentMake gcc-mips64 a blocker for kgcc64. (diff)
downloadhistorical-89f3568d9649c970a2d92a8abf751e1d31a0d983.tar.gz
historical-89f3568d9649c970a2d92a8abf751e1d31a0d983.tar.bz2
historical-89f3568d9649c970a2d92a8abf751e1d31a0d983.zip
Apply Debian patch wrt bug #142597.
Package-Manager: portage-2.1.1_pre2-r6
Diffstat (limited to 'www-apps/sitebar')
-rw-r--r--www-apps/sitebar/ChangeLog8
-rw-r--r--www-apps/sitebar/files/debian.patch11
-rw-r--r--www-apps/sitebar/files/digest-sitebar-3.3.8-r13
-rw-r--r--www-apps/sitebar/sitebar-3.3.8-r1.ebuild41
4 files changed, 62 insertions, 1 deletions
diff --git a/www-apps/sitebar/ChangeLog b/www-apps/sitebar/ChangeLog
index eaed9a1439ec..2c514229f758 100644
--- a/www-apps/sitebar/ChangeLog
+++ b/www-apps/sitebar/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for www-apps/sitebar
# Copyright 1999-2006 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/www-apps/sitebar/ChangeLog,v 1.10 2006/04/02 15:58:55 rl03 Exp $
+# $Header: /var/cvsroot/gentoo-x86/www-apps/sitebar/ChangeLog,v 1.11 2006/08/17 15:59:22 rl03 Exp $
+
+*sitebar-3.3.8-r1 (17 Aug 2006)
+
+ 17 Aug 2006; Renat Lumpau <rl03@gentoo.org> +files/debian.patch,
+ -sitebar-3.3.8.ebuild, +sitebar-3.3.8-r1.ebuild:
+ Apply Debian patch wrt bug #142597.
*sitebar-3.3.8 (02 Apr 2006)
diff --git a/www-apps/sitebar/files/debian.patch b/www-apps/sitebar/files/debian.patch
new file mode 100644
index 000000000000..42143bcc0257
--- /dev/null
+++ b/www-apps/sitebar/files/debian.patch
@@ -0,0 +1,11 @@
+--- sitebar-3.3.8.orig/command.php
++++ sitebar-3.3.8/command.php
+@@ -5809,7 +5809,7 @@
+ ?>
+ <div id="<?php echo ($cw->hasErrors()?$errId:'command').'Head'?>" class="cmnTitle">
+ <div id="help" onclick="SB_openHelp('<?php echo $onlineHelp ?>')">?</div>
+-<div id="command"><?php echo SB_T($cw->command)?></div>
++<div id="command"><?php echo htmlspecialchars(SB_T($cw->command))?></div>
+ </div>
+ <div id="<?php echo ($cw->hasErrors()?$errId:'command').'Body'?>">
+ <?php
diff --git a/www-apps/sitebar/files/digest-sitebar-3.3.8-r1 b/www-apps/sitebar/files/digest-sitebar-3.3.8-r1
new file mode 100644
index 000000000000..fc4df3df7b56
--- /dev/null
+++ b/www-apps/sitebar/files/digest-sitebar-3.3.8-r1
@@ -0,0 +1,3 @@
+MD5 612b808777160ce33d46ad603072b155 SiteBar-3.3.8.tar.bz2 525327
+RMD160 62887901b0444435e88baf19678ecba8b4ad0058 SiteBar-3.3.8.tar.bz2 525327
+SHA256 d25c492c6165564a8e4268627c86777dfc0428683c355235fb0d82866aca7fa3 SiteBar-3.3.8.tar.bz2 525327
diff --git a/www-apps/sitebar/sitebar-3.3.8-r1.ebuild b/www-apps/sitebar/sitebar-3.3.8-r1.ebuild
new file mode 100644
index 000000000000..a942dbb027c0
--- /dev/null
+++ b/www-apps/sitebar/sitebar-3.3.8-r1.ebuild
@@ -0,0 +1,41 @@
+# Copyright 1999-2006 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/www-apps/sitebar/sitebar-3.3.8-r1.ebuild,v 1.1 2006/08/17 15:59:22 rl03 Exp $
+
+inherit webapp eutils
+
+WEBAPP_MANUAL_SLOT="yes"
+SLOT="3.3.8"
+
+DESCRIPTION="The Bookmark Server for Personal and Team Use"
+HOMEPAGE="http://sitebar.sourceforge.net/"
+KEYWORDS="~amd64 ~ppc ~x86"
+
+IUSE="mysql"
+MY_PN=${PN/sitebar/SiteBar}
+S=${WORKDIR}/${MY_PN}-${PV}
+
+SRC_URI="mirror://sourceforge/${PN}/${MY_PN}-${PV}.tar.bz2"
+
+DEPEND="net-www/apache
+ virtual/php
+ mysql? ( >=dev-db/mysql-3.23 )"
+LICENSE="GPL-2"
+
+src_unpack() {
+ unpack ${A}
+ cd ${S}
+ epatch ${FILESDIR}/debian.patch
+}
+
+src_install() {
+ webapp_src_preinst
+ dodoc readme.txt doc/history.txt doc/install.txt doc/troubleshooting.txt
+ cp -R . ${D}/${MY_HTDOCSDIR}
+ rm -rf ${D}/${MY_HTDOCSDIR}/doc ${D}/${MY_HTDOCSDIR}/readme.txt
+
+ webapp_serverowned ${MY_HTDOCSDIR}/inc
+ webapp_postinst_txt en ${FILESDIR}/postinstall-en.txt
+
+ webapp_src_install
+}