summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSeemant Kulleen <seemant@gentoo.org>2006-03-31 21:09:35 +0000
committerSeemant Kulleen <seemant@gentoo.org>2006-03-31 21:09:35 +0000
commit8a0484f55edd67e6c60d13d25315734b9a74c414 (patch)
tree07165845ee8d9b2e1d89cd3ce7034069f2f680af /www-client/surfraw/surfraw-2.1.4.ebuild
parentChanged nomirror to mirror. (diff)
downloadhistorical-8a0484f55edd67e6c60d13d25315734b9a74c414.tar.gz
historical-8a0484f55edd67e6c60d13d25315734b9a74c414.tar.bz2
historical-8a0484f55edd67e6c60d13d25315734b9a74c414.zip
Version bump, thanks to Jay in bug #127549
Package-Manager: portage-2.1_pre7-r3
Diffstat (limited to 'www-client/surfraw/surfraw-2.1.4.ebuild')
-rw-r--r--www-client/surfraw/surfraw-2.1.4.ebuild62
1 files changed, 62 insertions, 0 deletions
diff --git a/www-client/surfraw/surfraw-2.1.4.ebuild b/www-client/surfraw/surfraw-2.1.4.ebuild
new file mode 100644
index 000000000000..8b0186e4b75b
--- /dev/null
+++ b/www-client/surfraw/surfraw-2.1.4.ebuild
@@ -0,0 +1,62 @@
+# Copyright 1999-2006 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/www-client/surfraw/surfraw-2.1.4.ebuild,v 1.1 2006/03/31 21:09:35 seemant Exp $
+
+inherit bash-completion eutils
+
+S=${WORKDIR}/${PN}
+DESCRIPTION="A fast unix command line interface to WWW"
+HOMEPAGE="http://alioth.debian.org/projects/surfraw/"
+SRC_URI="mirror://debian/pool/main/s/surfraw/${PN}_${PV}.tar.gz"
+
+SLOT="0"
+LICENSE="public-domain"
+KEYWORDS="~amd64 ~ppc ~sparc ~x86"
+IUSE=""
+
+src_unpack() {
+ unpack ${A}; cd ${S}
+
+ sed -i 's,/lib/,/share/,g' surfraw-bash-completion surfraw.1.in elvi.1sr.in
+ epatch ${FILESDIR}/${PN}-gentoo_pkg_tools.patch
+}
+
+src_compile() {
+ econf \
+ --with-elvidir='$(datadir)'/surfraw || die "./configure failed"
+ emake || die "make failed"
+}
+
+src_install() {
+ make DESTDIR=${D} install || die "make install failed"
+ dodoc debian/changelog AUTHORS HACKING NEWS README TODO
+
+ dobashcompletion surfraw-bash-completion
+}
+
+pkg_postinst() {
+ bash-completion_pkg_postinst
+ einfo
+ einfo "You can get a list of installed elvi by just typing 'surfraw' or"
+ einfo "the abbreviated 'sr'."
+ einfo
+ einfo "You can try some searches, for example:"
+ einfo "$ sr ask why is jeeves gay? "
+ einfo "$ sr google -results=100 RMS, GNU, which is sinner, which is sin?"
+ einfo "$ sr rhyme -method=perfect Julian"
+ einfo
+ einfo "The system configuration file is /etc/surfraw.conf"
+ einfo
+ einfo "Users can specify preferences in '~/.surfraw.conf' e.g."
+ einfo "SURFRAW_graphical_browser=mozilla"
+ einfo "SURFRAW_text_browser=w3m"
+ einfo "SURFRAW_graphical=no"
+ einfo
+ einfo "surfraw works with any graphical and/or text WWW browser"
+ einfo
+ if has_version '=www-client/surfraw-1.0.7'; then
+ ewarn "surfraw usage has changed slightly since version 1.0.7, elvi are now called"
+ ewarn "using the 'sr' wrapper script as described above. If you wish to return to"
+ ewarn "the old behaviour you can add /usr/share/surfraw to your \$PATH"
+ fi
+}