summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJory Pratt <anarchy@gentoo.org>2006-04-10 22:45:11 +0000
committerJory Pratt <anarchy@gentoo.org>2006-04-10 22:45:11 +0000
commiteaa523456d52dc841b8296d81e5155cf659aa910 (patch)
treed593eed1f0c3eb2ff70168fca3f4b5bbe27ea10a /www-client
parents390 love (diff)
downloadhistorical-eaa523456d52dc841b8296d81e5155cf659aa910.tar.gz
historical-eaa523456d52dc841b8296d81e5155cf659aa910.tar.bz2
historical-eaa523456d52dc841b8296d81e5155cf659aa910.zip
linguas fix wrt bug #124052
Package-Manager: portage-2.1_pre7-r3
Diffstat (limited to 'www-client')
-rw-r--r--www-client/mozilla-firefox/Manifest6
-rw-r--r--www-client/mozilla-firefox/mozilla-firefox-1.5.0.1-r4.ebuild25
2 files changed, 19 insertions, 12 deletions
diff --git a/www-client/mozilla-firefox/Manifest b/www-client/mozilla-firefox/Manifest
index 5e378ba81b30..7ed6f9d09bc7 100644
--- a/www-client/mozilla-firefox/Manifest
+++ b/www-client/mozilla-firefox/Manifest
@@ -64,6 +64,6 @@ SHA256 bdcc6bbbca462928df2252f5cbadd053a27371c1c8097c80b614da681d6d39ad mozilla-
MD5 d0bd46e41702ff6446015dc99407f659 mozilla-firefox-1.5.0.1-r3.ebuild 8678
RMD160 9b677edc645e7e6fcb7a5d0971090a3c5ac81a29 mozilla-firefox-1.5.0.1-r3.ebuild 8678
SHA256 613c9a12aef15ef1e6dabb93c566126f0cb4d0b820304a6e788351faf48fbef1 mozilla-firefox-1.5.0.1-r3.ebuild 8678
-MD5 e73cb3dbd0764621525b2442523d7975 mozilla-firefox-1.5.0.1-r4.ebuild 8881
-RMD160 70ee51c837bda134e47fd601bbc25562126cdd66 mozilla-firefox-1.5.0.1-r4.ebuild 8881
-SHA256 661b1fc09f878cd098770b0bfbb3744378cc0763c69ad89caa71de65db3a778f mozilla-firefox-1.5.0.1-r4.ebuild 8881
+MD5 703f41edab0049cce34b1a4226fe59a4 mozilla-firefox-1.5.0.1-r4.ebuild 9075
+RMD160 b1b261845303ee3457b22e01807a5a21dc477770 mozilla-firefox-1.5.0.1-r4.ebuild 9075
+SHA256 261ec3b716ba36b57ed094acc2542ffa4039d1494717fb409d18a50efb13060b mozilla-firefox-1.5.0.1-r4.ebuild 9075
diff --git a/www-client/mozilla-firefox/mozilla-firefox-1.5.0.1-r4.ebuild b/www-client/mozilla-firefox/mozilla-firefox-1.5.0.1-r4.ebuild
index 59edafadfd1e..418320978292 100644
--- a/www-client/mozilla-firefox/mozilla-firefox-1.5.0.1-r4.ebuild
+++ b/www-client/mozilla-firefox/mozilla-firefox-1.5.0.1-r4.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2006 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/www-client/mozilla-firefox/mozilla-firefox-1.5.0.1-r4.ebuild,v 1.3 2006/04/01 04:39:56 anarchy Exp $
+# $Header: /var/cvsroot/gentoo-x86/www-client/mozilla-firefox/mozilla-firefox-1.5.0.1-r4.ebuild,v 1.4 2006/04/10 22:45:11 anarchy Exp $
unset ALLOWED_FLAGS # stupid extra-functions.sh ... bug 49179
@@ -48,25 +48,32 @@ export BUILD_OFFICIAL=1
export MOZILLA_OFFICIAL=1
linguas() {
+ linguas=
local LANG
for LANG in ${LINGUAS}; do
if hasq ${LANG} ${LANGS//-/_} en; then
- echo -n "${LANG//_/-} "
+ hasq ${LANG//_/-} ${linguas} || \
+ linguas="${linguas} ${LANG//_/-}"
+ continue
else
local SLANG
for SLANG in ${SHORTLANGS}; do
- [[ ${LANG} == ${SLANG%%-*} ]] && \
- echo -n "${SLANG} "
+ if [[ ${LANG} == ${SLANG%%-*} ]]; then
+ hasq ${SLANG} ${linguas} || \
+ linguas="${linguas} ${SLANG}"
+ continue 2
+ fi
done
fi
+ ewarn "Sorry, but mozilla-firefox does not support the ${LANG} LINGUA"
done
}
src_unpack() {
unpack firefox-${PV}-source.tar.bz2 ${P}-patches-${PVER}.tar.bz2
- LINGUAS=$(linguas)
- for X in ${LINGUAS}; do
+ linguas
+ for X in ${linguas}; do
[[ ${X} != en ]] && xpi_unpack firefox-${X}-${PV}.xpi
done
@@ -184,12 +191,12 @@ src_install() {
dodir ${MOZILLA_FIVE_HOME}
cp -RL ${S}/dist/bin/* ${D}${MOZILLA_FIVE_HOME}
- LINGUAS=$(linguas)
- for X in ${LINGUAS}; do
+ linguas
+ for X in ${linguas}; do
[[ ${X} != en ]] && xpi_install ${WORKDIR}/firefox-${X}-${PV}
done
- local LANG=${LINGUAS%% *}
+ local LANG=${linguas%% *}
if [[ ${LANG} != "" && ${LANG} != "en" ]]; then
ebegin "Setting default locale to ${LANG}"
sed -i "s:pref(\"general.useragent.locale\", \"en-US\"):pref(\"general.useragent.locale\", \"${LANG}\"):" \