summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDonnie Berkholz <dberkholz@gentoo.org>2006-09-29 04:52:08 +0000
committerDonnie Berkholz <dberkholz@gentoo.org>2006-09-29 04:52:08 +0000
commit9257bd0ffc62b0ce4fdbcbbb7cad9b35716bfdfc (patch)
tree4a3469d1e6c9e6e62a9b6257c5f5dcd4ff2089ef /x11-drivers/xf86-video-savage/xf86-video-savage-2.1.2.ebuild
parentNew snapshot, with mmap support optional, a lot of Coverity fixes, and Shorte... (diff)
downloadhistorical-9257bd0ffc62b0ce4fdbcbbb7cad9b35716bfdfc.tar.gz
historical-9257bd0ffc62b0ce4fdbcbbb7cad9b35716bfdfc.tar.bz2
historical-9257bd0ffc62b0ce4fdbcbbb7cad9b35716bfdfc.zip
Bump. Adds EXA copy and solid support, PCI BAR refactoring in preparation for the PCI-rework addition post-7.2, fixes DRI locking, and some other fixes.
Package-Manager: portage-2.1.2_pre1-r3
Diffstat (limited to 'x11-drivers/xf86-video-savage/xf86-video-savage-2.1.2.ebuild')
-rw-r--r--x11-drivers/xf86-video-savage/xf86-video-savage-2.1.2.ebuild30
1 files changed, 30 insertions, 0 deletions
diff --git a/x11-drivers/xf86-video-savage/xf86-video-savage-2.1.2.ebuild b/x11-drivers/xf86-video-savage/xf86-video-savage-2.1.2.ebuild
new file mode 100644
index 000000000000..d26f0107e509
--- /dev/null
+++ b/x11-drivers/xf86-video-savage/xf86-video-savage-2.1.2.ebuild
@@ -0,0 +1,30 @@
+# Copyright 1999-2006 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/x11-drivers/xf86-video-savage/xf86-video-savage-2.1.2.ebuild,v 1.1 2006/09/29 04:52:08 dberkholz Exp $
+
+# Must be before x-modular eclass is inherited
+#SNAPSHOT="yes"
+
+inherit x-modular
+
+DESCRIPTION="X.Org driver for savage cards"
+KEYWORDS="~alpha ~amd64 ~arm ~ia64 ~ppc ~sh ~sparc ~x86 ~x86-fbsd"
+IUSE="dri"
+RDEPEND=">=x11-base/xorg-server-1.0.99"
+DEPEND="${RDEPEND}
+ x11-proto/fontsproto
+ x11-proto/randrproto
+ x11-proto/renderproto
+ x11-proto/videoproto
+ x11-proto/xextproto
+ x11-proto/xproto
+ dri? ( x11-proto/xf86driproto
+ >=x11-libs/libdrm-2 )"
+
+CONFIGURE_OPTIONS="$(use_enable dri)"
+
+pkg_setup() {
+ if use dri && ! built_with_use x11-base/xorg-server dri; then
+ die "Build x11-base/xorg-server with USE=dri."
+ fi
+}