summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSeemant Kulleen <seemant@gentoo.org>2002-08-12 14:33:14 +0000
committerSeemant Kulleen <seemant@gentoo.org>2002-08-12 14:33:14 +0000
commit6c7cea7024a2b2b792d6b9a717328c7b8533cfc1 (patch)
tree2eb25bdc79c2fffe7b255f04781de1c64e001277 /x11-libs/fltk/fltk-1.0.11-r3.ebuild
parentremove xv USE flag support for now (diff)
downloadhistorical-6c7cea7024a2b2b792d6b9a717328c7b8533cfc1.tar.gz
historical-6c7cea7024a2b2b792d6b9a717328c7b8533cfc1.tar.bz2
historical-6c7cea7024a2b2b792d6b9a717328c7b8533cfc1.zip
SLOTified and other changes
Diffstat (limited to 'x11-libs/fltk/fltk-1.0.11-r3.ebuild')
-rw-r--r--x11-libs/fltk/fltk-1.0.11-r3.ebuild45
1 files changed, 45 insertions, 0 deletions
diff --git a/x11-libs/fltk/fltk-1.0.11-r3.ebuild b/x11-libs/fltk/fltk-1.0.11-r3.ebuild
new file mode 100644
index 000000000000..c295aea7cd38
--- /dev/null
+++ b/x11-libs/fltk/fltk-1.0.11-r3.ebuild
@@ -0,0 +1,45 @@
+# Copyright 1999-2002 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License, v2 or later
+# $Header: /var/cvsroot/gentoo-x86/x11-libs/fltk/fltk-1.0.11-r3.ebuild,v 1.1 2002/08/12 14:33:14 seemant Exp $
+
+S=${WORKDIR}/${P}
+DESCRIPTION="C++ user interface toolkit for X and OpenGL."
+SRC_URI="ftp://ftp.fltk.org/pub/fltk/${PV}/${P}-source.tar.bz2"
+HOMEPAGE="http://www.fltk.org"
+
+SLOT="1.0"
+LICENSE="FLTK | GPL-2"
+KEYWORDS="x86"
+
+DEPEND="virtual/x11
+ opengl? ( virtual/opengl )"
+
+
+src_compile() {
+
+ local myconf
+ myconf="--enable-shared"
+
+ use opengl || myconf="${myconf} --disable-gl" #default enabled
+
+ econf \
+ --includedir=/usr/include/fltk-1.0 \
+ --libdir=/usr/lib/fltk-1.0 \
+ --program-suffix=-old \
+ ${myconf} || die "Configuration Failed"
+ emake || die "Parallel Make Failed"
+
+}
+
+src_install () {
+
+ einstall \
+ includedir=${D}/usr/include/fltk-1.0 \
+ libdir=${D}/usr/lib/fltk-1.0 || die "Installation Failed"
+
+ dodoc CHANGES COPYING README
+
+ dodir /usr/share/doc/${PF}/html
+ mv ${D}/usr/share/doc/fltk/* ${D}/usr/share/doc/${PF}/html
+ rmdir ${D}/usr/share/doc/fltk
+}