summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRyan Phillips <rphillips@gentoo.org>2005-04-01 21:12:09 +0000
committerRyan Phillips <rphillips@gentoo.org>2005-04-01 21:12:09 +0000
commit39d2da3e73ef844c8c567491326afc03a031831f (patch)
tree00183015399794d2df3a6198a87a2b7607f45131 /x11-libs/fox
parentStable on ppc. (diff)
downloadhistorical-39d2da3e73ef844c8c567491326afc03a031831f.tar.gz
historical-39d2da3e73ef844c8c567491326afc03a031831f.tar.bz2
historical-39d2da3e73ef844c8c567491326afc03a031831f.zip
updated ebuild to support einstall and econf
Diffstat (limited to 'x11-libs/fox')
-rw-r--r--x11-libs/fox/ChangeLog5
-rw-r--r--x11-libs/fox/Manifest4
-rw-r--r--x11-libs/fox/fox-1.4.11.ebuild38
3 files changed, 28 insertions, 19 deletions
diff --git a/x11-libs/fox/ChangeLog b/x11-libs/fox/ChangeLog
index 0deba679eb1d..da9f3373b09f 100644
--- a/x11-libs/fox/ChangeLog
+++ b/x11-libs/fox/ChangeLog
@@ -1,6 +1,9 @@
# ChangeLog for x11-libs/fox
# Copyright 2002-2005 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/x11-libs/fox/ChangeLog,v 1.37 2005/03/31 20:26:42 rphillips Exp $
+# $Header: /var/cvsroot/gentoo-x86/x11-libs/fox/ChangeLog,v 1.38 2005/04/01 21:12:09 rphillips Exp $
+
+ 01 Apr 2005; <rphillips@gentoo.org> fox-1.4.11.ebuild:
+ Updated ebuild to use emake and einstall. Thanks to Diego. Fixes #74872
*fox-1.4.11 (31 Mar 2005)
diff --git a/x11-libs/fox/Manifest b/x11-libs/fox/Manifest
index d64af6ed8d08..14f9a62f4217 100644
--- a/x11-libs/fox/Manifest
+++ b/x11-libs/fox/Manifest
@@ -1,10 +1,10 @@
MD5 042d23061d212f553c3b44d3e99f6a99 fox-1.0.43.ebuild 1146
MD5 f793254a74b6b00db3cc044bae1f2f62 fox-1.2.4.ebuild 1207
-MD5 4a2107accde163461abc16a73ea6d50d fox-1.4.11.ebuild 1455
+MD5 5c06d0dd1b742ba55f25cd0e21ba94cd fox-1.4.11.ebuild 1456
MD5 a5f1167fb465b82c2c240f208d924c3d fox-1.0.40.ebuild 1146
MD5 966e6344d9604197999a8415e2fb8874 fox-1.2.6-r2.ebuild 1449
MD5 d859eab1b76e952316741b414ef8acf6 fox-1.0.49.ebuild 1177
-MD5 22f2b7504e44ed1710f6fa0c3444d579 ChangeLog 4152
+MD5 6250bbee573581fb0751c1e382272192 ChangeLog 4285
MD5 059733ad92a101895ce18a1120b6eb55 metadata.xml 225
MD5 e66ac5665267aa76e1efc8da12cc8928 files/digest-fox-1.0.40 63
MD5 fb1e5d65f9c5bfd6f2f4e1b710c857d3 files/digest-fox-1.0.43 63
diff --git a/x11-libs/fox/fox-1.4.11.ebuild b/x11-libs/fox/fox-1.4.11.ebuild
index b6df2c691326..e1ddd3715ffb 100644
--- a/x11-libs/fox/fox-1.4.11.ebuild
+++ b/x11-libs/fox/fox-1.4.11.ebuild
@@ -1,35 +1,42 @@
# Copyright 1999-2005 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/x11-libs/fox/fox-1.4.11.ebuild,v 1.1 2005/03/31 20:26:42 rphillips Exp $
+# $Header: /var/cvsroot/gentoo-x86/x11-libs/fox/fox-1.4.11.ebuild,v 1.2 2005/04/01 21:12:09 rphillips Exp $
-IUSE="cups debug truetype opengl"
+IUSE="cups debug truetype opengl X tiff png jpeg zlib bzlib"
DESCRIPTION="C++ based Toolkit for developing Graphical User Interfaces easily and effectively"
SRC_URI="http://www.fox-toolkit.org/ftp/${P}.tar.gz"
HOMEPAGE="http://www.fox-toolkit.org"
SLOT="0"
-KEYWORDS="~x86 ~amd64 ~ppc ~sparc ~hppa ~alpha ~ppc64"
+KEYWORDS="~x86 ~amd64 ~ppc ~sparc ~hppa ~alpha"
LICENSE="GPL-2"
DEPEND="virtual/libc
virtual/x11
- truetype? ( >=media-libs/freetype-2.1.5-r1 )
- opengl? ( virtual/opengl )"
+ truetype? ( >=media-libs/freetype-2 )
+ opengl? ( virtual/opengl )
+ tiff? ( media-libs/tiff )
+ png? ( media-libs/libpng )
+ jpeg? ( media-libs/jpeg )
+ zlib? ( sys-libs/zlib )
+ bzlib? ( app-arch/bzip2 )"
src_compile() {
local myconf
- use opengl || myconf="$myconf --with-opengl=no" #default enabled
- myconf="$myconf `use_enable cups`" #default disabled
- myconf="$myconf `use_enable debug`" #default disabled
- use truetype && myconf="$myconf --with-xft" #default disabled
-
# Following line closes #61694
CPPFLAGS="$CPPFLAGS -I/usr/include/freetype2" \
- ./configure \
- --prefix=/usr \
- --mandir='${prefix}'/share/man \
- --host=${CHOST} \
+ econf \
+ `use_with opengl` \
+ `use_enable cups` \
+ `use_enable debug` \
+ `use_enable tiff` \
+ `use_enable jpeg` \
+ `use_enable png` \
+ `use_enable zlib` \
+ `use_enable bzlib bz2lib` \
+ `use_with truetype xft` \
+ `use_with X xshm` `use_with X xcursor` \
${myconf} || die "Configuration Failed"
emake || die "Parallel Make Failed"
@@ -37,8 +44,7 @@ src_compile() {
src_install () {
- make prefix=${D}/usr/ \
- install || die "Installation Failed"
+ einstall
dodoc README INSTALL LICENSE ADDITIONS AUTHORS TRACING