summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlastair Tse <liquidx@gentoo.org>2003-07-20 15:01:01 +0000
committerAlastair Tse <liquidx@gentoo.org>2003-07-20 15:01:01 +0000
commite115591d0e619761cd313939377fdd5f63856b59 (patch)
tree8d042a72d3f34503ab4a48b9f8fc7338ca37a4db /x11-libs/gtkscintilla2
parentnew code editing widget for gtk (diff)
downloadhistorical-e115591d0e619761cd313939377fdd5f63856b59.tar.gz
historical-e115591d0e619761cd313939377fdd5f63856b59.tar.bz2
historical-e115591d0e619761cd313939377fdd5f63856b59.zip
new code editing widget for gtk
Diffstat (limited to 'x11-libs/gtkscintilla2')
-rw-r--r--x11-libs/gtkscintilla2/Manifest3
-rw-r--r--x11-libs/gtkscintilla2/files/digest-gtkscintilla2-0.0.81
-rw-r--r--x11-libs/gtkscintilla2/gtkscintilla2-0.0.8.ebuild52
3 files changed, 55 insertions, 1 deletions
diff --git a/x11-libs/gtkscintilla2/Manifest b/x11-libs/gtkscintilla2/Manifest
index 47543db50700..e88dfca90a83 100644
--- a/x11-libs/gtkscintilla2/Manifest
+++ b/x11-libs/gtkscintilla2/Manifest
@@ -1,2 +1,3 @@
-MD5 e0d5e61e96dfc2593012652d30886657 gtkscintilla2-0.0.8.ebuild 1018
+MD5 1a1d9bbde615ec123f8c8a4bd682c7d8 gtkscintilla2-0.0.8.ebuild 1131
+MD5 3f569a2bac7b261e6ee6e6a22812e936 ChangeLog 447
MD5 f29bb40add3aa939317a482a5351a3fd files/digest-gtkscintilla2-0.0.8 71
diff --git a/x11-libs/gtkscintilla2/files/digest-gtkscintilla2-0.0.8 b/x11-libs/gtkscintilla2/files/digest-gtkscintilla2-0.0.8
new file mode 100644
index 000000000000..9da38243be95
--- /dev/null
+++ b/x11-libs/gtkscintilla2/files/digest-gtkscintilla2-0.0.8
@@ -0,0 +1 @@
+MD5 e275b450c59575adef18175c099df79d GtkScintilla2-0.0.8.tar.gz 444968
diff --git a/x11-libs/gtkscintilla2/gtkscintilla2-0.0.8.ebuild b/x11-libs/gtkscintilla2/gtkscintilla2-0.0.8.ebuild
new file mode 100644
index 000000000000..9a3a2175b8e7
--- /dev/null
+++ b/x11-libs/gtkscintilla2/gtkscintilla2-0.0.8.ebuild
@@ -0,0 +1,52 @@
+# Copyright 1999-2003 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/x11-libs/gtkscintilla2/gtkscintilla2-0.0.8.ebuild,v 1.1 2003/07/20 15:00:39 liquidx Exp $
+
+MY_P="GtkScintilla2-${PV}"
+DESCRIPTION="Gtk-2 wrappers for the Scintilla source editing components."
+HOMEPAGE="http://www.gphpedit.org/"
+SRC_URI="http://gphpedit.org/releases/${MY_P}.tar.gz"
+
+IUSE=""
+SLOT="0"
+KEYWORDS="~x86"
+LICENSE="GPL-2"
+
+RDEPEND=">=x11-libs/gtk+-2.0"
+
+DEPEND=">=dev-util/pkgconfig-0.12.0
+ >=dev-lang/python-2.2
+ ${RDEPEND}"
+
+S="${WORKDIR}/${MY_P}"
+
+src_unpack() {
+
+ unpack ${A}
+ cd ${S}
+
+ # some quick touches to the Makefile, bump the version
+ # and make use of our CFLAGS
+ cp Makefile Makefile.orig
+ sed -e "/VERSION/s,0.0.3,${PV}," \
+ -e "/CFLAGS/s,-g,${CFLAGS}," < Makefile.orig > Makefile
+
+ # and again, in the scintilla part
+ cd ${S}/scintilla/gtk
+ cp makefile makefile.orig
+ sed -e "/CXXFLAGS/s,-Os,${CFLAGS}," < makefile.orig > makefile
+
+}
+
+src_compile() {
+
+ emake || die
+
+}
+
+src_install() {
+
+ make DESTDIR=${D} install || die
+ dodoc COPYING README
+
+}