summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTomas Chvatal <scarabeus@gentoo.org>2010-11-01 14:28:03 +0000
committerTomas Chvatal <scarabeus@gentoo.org>2010-11-01 14:28:03 +0000
commit1e59ac51ffdb58190a9bc4329318475b7d560ff8 (patch)
tree6b2044ba955f8d7d4398efe828e5cede53222e43 /x11-libs/libFS
parentppc64 stable wrt #324077 (diff)
downloadhistorical-1e59ac51ffdb58190a9bc4329318475b7d560ff8.tar.gz
historical-1e59ac51ffdb58190a9bc4329318475b7d560ff8.tar.bz2
historical-1e59ac51ffdb58190a9bc4329318475b7d560ff8.zip
Move proto to be always in rdepend just to play on safe side.
Package-Manager: portage-2.2_rc98/cvs/Linux x86_64
Diffstat (limited to 'x11-libs/libFS')
-rw-r--r--x11-libs/libFS/libFS-1.0.3.ebuild12
1 files changed, 8 insertions, 4 deletions
diff --git a/x11-libs/libFS/libFS-1.0.3.ebuild b/x11-libs/libFS/libFS-1.0.3.ebuild
index 31c114feb8e6..0ff6f112c257 100644
--- a/x11-libs/libFS/libFS-1.0.3.ebuild
+++ b/x11-libs/libFS/libFS-1.0.3.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2010 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/x11-libs/libFS/libFS-1.0.3.ebuild,v 1.1 2010/10/28 11:06:20 scarabeus Exp $
+# $Header: /var/cvsroot/gentoo-x86/x11-libs/libFS/libFS-1.0.3.ebuild,v 1.2 2010/11/01 14:28:00 scarabeus Exp $
EAPI=3
inherit xorg-2
@@ -10,9 +10,13 @@ DESCRIPTION="X.Org FS library"
KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86 ~x86-fbsd"
IUSE="ipv6"
-RDEPEND="x11-libs/xtrans"
-DEPEND="${RDEPEND}
+RDEPEND="x11-libs/xtrans
x11-proto/xproto
x11-proto/fontsproto"
+DEPEND="${RDEPEND}"
-CONFIGURE_OPTIONS="$(use_enable ipv6)"
+pkg_setup() {
+ xorg-2_pkg_setup
+
+ CONFIGURE_OPTIONS="$(use_enable ipv6)"
+}