summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMarkos Chandras <hwoarang@gentoo.org>2010-06-08 12:24:25 +0000
committerMarkos Chandras <hwoarang@gentoo.org>2010-06-08 12:24:25 +0000
commit7b4707dcae03ce99fd2b5c59597b4f61b4897b14 (patch)
treece38f4ce519e28e4232c08492f7ec43794a844cd /x11-libs/qt-assistant
parentDon't define _XOPEN_SOURCE on Solaris either, such that we can compile there ... (diff)
downloadhistorical-7b4707dcae03ce99fd2b5c59597b4f61b4897b14.tar.gz
historical-7b4707dcae03ce99fd2b5c59597b4f61b4897b14.tar.bz2
historical-7b4707dcae03ce99fd2b5c59597b4f61b4897b14.zip
Qt release version bump
Package-Manager: portage-2.2_rc67/cvs/Linux x86_64
Diffstat (limited to 'x11-libs/qt-assistant')
-rw-r--r--x11-libs/qt-assistant/ChangeLog8
-rw-r--r--x11-libs/qt-assistant/files/qt-assistant-4.6.3-tools.patch40
-rw-r--r--x11-libs/qt-assistant/qt-assistant-4.6.3.ebuild82
3 files changed, 129 insertions, 1 deletions
diff --git a/x11-libs/qt-assistant/ChangeLog b/x11-libs/qt-assistant/ChangeLog
index 61813722477f..74069ed291b9 100644
--- a/x11-libs/qt-assistant/ChangeLog
+++ b/x11-libs/qt-assistant/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for x11-libs/qt-assistant
# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/x11-libs/qt-assistant/ChangeLog,v 1.78 2010/05/04 13:49:28 hwoarang Exp $
+# $Header: /var/cvsroot/gentoo-x86/x11-libs/qt-assistant/ChangeLog,v 1.79 2010/06/08 12:14:22 hwoarang Exp $
+
+*qt-assistant-4.6.3 (08 Jun 2010)
+
+ 08 Jun 2010; Markos Chandras <hwoarang@gentoo.org>
+ +qt-assistant-4.6.3.ebuild, +files/qt-assistant-4.6.3-tools.patch:
+ Version bump
*qt-assistant-4.6.2-r2 (04 May 2010)
diff --git a/x11-libs/qt-assistant/files/qt-assistant-4.6.3-tools.patch b/x11-libs/qt-assistant/files/qt-assistant-4.6.3-tools.patch
new file mode 100644
index 000000000000..7f5a54370abe
--- /dev/null
+++ b/x11-libs/qt-assistant/files/qt-assistant-4.6.3-tools.patch
@@ -0,0 +1,40 @@
+Index: qt-everywhere-opensource-src-4.6.3/tools/tools.pro
+===================================================================
+--- qt-everywhere-opensource-src-4.6.3.orig/tools/tools.pro
++++ qt-everywhere-opensource-src-4.6.3/tools/tools.pro
+@@ -4,34 +4,9 @@ no-png {
+ message("Some graphics-related tools are unavailable without PNG support")
+ } else {
+ SUBDIRS += assistant \
+- pixeltool \
+- porting \
+- qtestlib \
+- qttracereplay
+- contains(QT_EDITION, Console) {
+- SUBDIRS += designer/src/uitools # Linguist depends on this
+- } else {
+- SUBDIRS += designer
+- }
+- SUBDIRS += linguist
+- symbian: SUBDIRS = designer
+- wince*: SUBDIRS = qtestlib designer
+- unix:!mac:!embedded:contains(QT_CONFIG, qt3support):SUBDIRS += qtconfig
+- win32:!wince*:SUBDIRS += activeqt
++ pixeltool
+ }
+
+-mac {
+- SUBDIRS += macdeployqt
+-}
+-
+-embedded:SUBDIRS += kmap2qmap
+-
+-contains(QT_CONFIG, declarative):SUBDIRS += qmlviewer qmldebugger
+-contains(QT_CONFIG, dbus):SUBDIRS += qdbus
+-# We don't need these command line utilities on embedded platforms.
+-!wince*:!symbian:contains(QT_CONFIG, xmlpatterns): SUBDIRS += xmlpatterns xmlpatternsvalidator
+-embedded: SUBDIRS += makeqpf
+-
+ !wince*:!cross_compile:SUBDIRS += qdoc3
+
+ CONFIG+=ordered
diff --git a/x11-libs/qt-assistant/qt-assistant-4.6.3.ebuild b/x11-libs/qt-assistant/qt-assistant-4.6.3.ebuild
new file mode 100644
index 000000000000..f6166d3469eb
--- /dev/null
+++ b/x11-libs/qt-assistant/qt-assistant-4.6.3.ebuild
@@ -0,0 +1,82 @@
+# Copyright 1999-2010 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/x11-libs/qt-assistant/qt-assistant-4.6.3.ebuild,v 1.1 2010/06/08 12:14:22 hwoarang Exp $
+
+EAPI="2"
+inherit qt4-build
+
+DESCRIPTION="The assistant help module for the Qt toolkit"
+SLOT="4"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~ppc ~ppc64 -sparc ~x86 ~x86-fbsd ~amd64-linux ~x86-linux ~ppc-macos ~x86-macos ~x64-solaris ~x86-solaris"
+IUSE="trace"
+
+DEPEND="~x11-libs/qt-gui-${PV}[aqua=,trace?]
+ ~x11-libs/qt-sql-${PV}[aqua=,sqlite]
+ ~x11-libs/qt-webkit-${PV}[aqua=]"
+RDEPEND="${DEPEND}"
+
+PATCHES=( "${FILESDIR}/${P}-tools.patch" )
+
+# Pixeltool isn't really assistant related, but it relies on
+# the assistant libraries. doc/qch/
+QT4_TARGET_DIRECTORIES="
+tools/assistant
+tools/pixeltool
+tools/qdoc3"
+QT4_EXTRACT_DIRECTORIES="
+tools/
+demos/
+examples/
+src/
+include/
+doc/"
+
+pkg_setup() {
+ use trace && QT4_TARGET_DIRECTORIES="${QT4_TARGET_DIRECTORIES}
+ tools/qttracereplay"
+ QT4_EXTRACT_DIRECTORIES="${QT4_TARGET_DIRECTORIES} \
+ ${QT4_EXTRACT_DIRECTORIES}"
+ qt4-build_pkg_setup
+}
+
+src_configure() {
+ myconf="${myconf} -no-xkb -no-fontconfig -no-xrender -no-xrandr
+ -no-xfixes -no-xcursor -no-xinerama -no-xshape -no-sm -no-opengl
+ -no-nas-sound -no-dbus -iconv -no-cups -no-nis -no-gif -no-libpng
+ -no-libmng -no-libjpeg -no-openssl -system-zlib -no-phonon
+ -no-xmlpatterns -no-freetype -no-libtiff -no-accessibility
+ -no-fontconfig -no-glib -no-multimedia -no-qt3support -no-svg"
+ qt4-build_src_configure
+}
+
+src_compile() {
+ # help libQtHelp find freshly built libQtCLucene (bug #289811)
+ export LD_LIBRARY_PATH="${S}/lib"
+ export DYLD_LIBRARY_PATH="${S}/lib:${S}/lib/QtHelp.framework"
+ qt4-build_src_compile
+ # ugly hack to build docs
+ cd "${S}"
+ qmake "LIBS+=-L${QTLIBDIR}" "CONFIG+=nostrip" projects.pro || die "qmake projects faied"
+ emake qch_docs || die "emake docs failed"
+}
+
+src_install() {
+ qt4-build_src_install
+ # install documentation
+ # note that emake install_qchdocs fails for undefined reason so we use a
+ # workaround
+ cd "${S}"
+ insinto ${QTDOCDIR#${EPREFIX}}
+ doins -r "${S}"/doc/qch || die "doins qch documentation failed"
+ dobin "${S}"/bin/qdoc3 || die "Installing qdoc3 failed"
+ #emake INSTALL_ROOT="${D}" install_qchdocs || die "emake install_qchdocs failed"
+ # install correct assistant icon, bug 241208
+ dodir /usr/share/pixmaps/ || die "dodir failed"
+ insinto /usr/share/pixmaps/ || die "insinto failed"
+ doins tools/assistant/tools/assistant/images/assistant.png \
+ || die "doins failed"
+ # Note: absolute image path required here!
+ make_desktop_entry /usr/bin/assistant Assistant \
+ /usr/share/pixmaps/assistant.png 'Qt;Development;GUIDesigner' \
+ || die "make_desktop_entry failed"
+}