summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJonathan Callen <jcallen@gentoo.org>2009-11-16 04:54:48 +0000
committerJonathan Callen <jcallen@gentoo.org>2009-11-16 04:54:48 +0000
commitdc7f3b0a290bce29f7104b2f65126621eadff497 (patch)
tree945918b8a23a589960422c2c80abc00596c04122 /x11-libs/qt-core
parentDrop unused file (diff)
downloadhistorical-dc7f3b0a290bce29f7104b2f65126621eadff497.tar.gz
historical-dc7f3b0a290bce29f7104b2f65126621eadff497.tar.bz2
historical-dc7f3b0a290bce29f7104b2f65126621eadff497.zip
Drop unused files
Package-Manager: portage--svn/cvs/Linux i686
Diffstat (limited to 'x11-libs/qt-core')
-rw-r--r--x11-libs/qt-core/ChangeLog9
-rw-r--r--x11-libs/qt-core/files/0167-fix-group-reading.diff28
-rw-r--r--x11-libs/qt-core/files/0253-qmake_correct_path_separators.diff65
-rw-r--r--x11-libs/qt-core/files/0257-qurl-validate-speedup.diff23
-rw-r--r--x11-libs/qt-core/files/qt-core-4.5-boilerplate.diff40
5 files changed, 8 insertions, 157 deletions
diff --git a/x11-libs/qt-core/ChangeLog b/x11-libs/qt-core/ChangeLog
index 27ec46cdf4bb..09c22e534083 100644
--- a/x11-libs/qt-core/ChangeLog
+++ b/x11-libs/qt-core/ChangeLog
@@ -1,6 +1,13 @@
# ChangeLog for x11-libs/qt-core
# Copyright 1999-2009 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/x11-libs/qt-core/ChangeLog,v 1.74 2009/11/11 15:26:48 yngwin Exp $
+# $Header: /var/cvsroot/gentoo-x86/x11-libs/qt-core/ChangeLog,v 1.75 2009/11/16 04:48:16 abcd Exp $
+
+ 16 Nov 2009; Jonathan Callen <abcd@gentoo.org>
+ -files/0167-fix-group-reading.diff,
+ -files/0253-qmake_correct_path_separators.diff,
+ -files/0257-qurl-validate-speedup.diff,
+ -files/qt-core-4.5-boilerplate.diff:
+ Drop unused files
11 Nov 2009; Ben de Groot <yngwin@gentoo.org> -qt-core-4.4.2.ebuild,
-qt-core-4.4.2-r2.ebuild, -qt-core-4.5.1.ebuild, -qt-core-4.5.2.ebuild,
diff --git a/x11-libs/qt-core/files/0167-fix-group-reading.diff b/x11-libs/qt-core/files/0167-fix-group-reading.diff
deleted file mode 100644
index 5c7ca33c4156..000000000000
--- a/x11-libs/qt-core/files/0167-fix-group-reading.diff
+++ /dev/null
@@ -1,28 +0,0 @@
-qt-bugs@ issue : none
-Trolltech task ID : none yet
-bugs.kde.org number : None
-applied: no
-author: Dirk Mueller <mueller@kde.org>
-
-in big user environments, getgrgid_r() needs more memory than sysconf() returns.
-Try a bit harder.
-
---- src/corelib//io/qfsfileengine_unix.cpp
-+++ src/corelib//io/qfsfileengine_unix.cpp
-@@ -835,9 +835,13 @@
- size_max = sysconf(_SC_GETGR_R_SIZE_MAX);
- if (size_max == -1)
- size_max = 1024;
-- buf.resize(size_max);
-- struct group entry;
-- getgrgid_r(ownerId(own), &entry, buf.data(), buf.size(), &gr);
-+ for (;size_max < 256000; size_max += size_max) {
-+ buf.resize(size_max);
-+ struct group entry;
-+ if (!getgrgid_r(ownerId(own), &entry, buf.data(), buf.size(), &gr) || errno != ERANGE)
-+ break;
-+
-+ }
- #else
- gr = getgrgid(ownerId(own));
- #endif
diff --git a/x11-libs/qt-core/files/0253-qmake_correct_path_separators.diff b/x11-libs/qt-core/files/0253-qmake_correct_path_separators.diff
deleted file mode 100644
index 007146169cd7..000000000000
--- a/x11-libs/qt-core/files/0253-qmake_correct_path_separators.diff
+++ /dev/null
@@ -1,65 +0,0 @@
-qt-bugs@ issue : none
-Trolltech task ID : 214661
-applied: no
-author: Christian Ehrlicher <ch.ehrlicher@gmx.de>
-
-When using qmake outside qt src tree, it sometimes generates wrong
-paths (wrong path separator)
-
-
---- qmake/property.cpp.orig 2008-05-08 21:16:15.902625000 +0200
-+++ qmake/property.cpp 2008-05-08 21:16:10.481500000 +0200
-@@ -83,29 +83,32 @@
- QString
- QMakeProperty::value(QString v, bool just_check)
- {
-+ QString ret;
- if(v == "QT_INSTALL_PREFIX")
-- return QLibraryInfo::location(QLibraryInfo::PrefixPath);
-+ ret = QLibraryInfo::location(QLibraryInfo::PrefixPath);
- else if(v == "QT_INSTALL_DATA")
-- return QLibraryInfo::location(QLibraryInfo::DataPath);
-+ ret = QLibraryInfo::location(QLibraryInfo::DataPath);
- else if(v == "QT_INSTALL_DOCS")
-- return QLibraryInfo::location(QLibraryInfo::DocumentationPath);
-+ ret = QLibraryInfo::location(QLibraryInfo::DocumentationPath);
- else if(v == "QT_INSTALL_HEADERS")
-- return QLibraryInfo::location(QLibraryInfo::HeadersPath);
-+ ret = QLibraryInfo::location(QLibraryInfo::HeadersPath);
- else if(v == "QT_INSTALL_LIBS")
-- return QLibraryInfo::location(QLibraryInfo::LibrariesPath);
-+ ret = QLibraryInfo::location(QLibraryInfo::LibrariesPath);
- else if(v == "QT_INSTALL_BINS")
-- return QLibraryInfo::location(QLibraryInfo::BinariesPath);
-+ ret = QLibraryInfo::location(QLibraryInfo::BinariesPath);
- else if(v == "QT_INSTALL_PLUGINS")
-- return QLibraryInfo::location(QLibraryInfo::PluginsPath);
-+ ret = QLibraryInfo::location(QLibraryInfo::PluginsPath);
- else if(v == "QT_INSTALL_TRANSLATIONS")
-- return QLibraryInfo::location(QLibraryInfo::TranslationsPath);
-+ ret = QLibraryInfo::location(QLibraryInfo::TranslationsPath);
- else if(v == "QT_INSTALL_CONFIGURATION")
-- return QLibraryInfo::location(QLibraryInfo::SettingsPath);
-+ ret = QLibraryInfo::location(QLibraryInfo::SettingsPath);
- else if(v == "QT_INSTALL_EXAMPLES")
-- return QLibraryInfo::location(QLibraryInfo::ExamplesPath);
-+ ret = QLibraryInfo::location(QLibraryInfo::ExamplesPath);
- else if(v == "QT_INSTALL_DEMOS")
-- return QLibraryInfo::location(QLibraryInfo::DemosPath);
-- else if(v == "QMAKE_MKSPECS")
-+ ret = QLibraryInfo::location(QLibraryInfo::DemosPath);
-+ if(!ret.isEmpty())
-+ return QDir::toNativeSeparators(ret);
-+ if(v == "QMAKE_MKSPECS")
- return qmake_mkspec_paths().join(Option::target_mode == Option::TARG_WIN_MODE ? ";" : ":");
- else if(v == "QMAKE_VERSION")
- return qmake_version();
-@@ -118,7 +121,7 @@
- int slash = v.lastIndexOf('/');
- QVariant var = settings->value(keyBase(slash == -1) + v);
- bool ok = var.isValid();
-- QString ret = var.toString();
-+ ret = var.toString();
- if(!ok) {
- QString version = qmake_version();
- if(slash != -1) {
diff --git a/x11-libs/qt-core/files/0257-qurl-validate-speedup.diff b/x11-libs/qt-core/files/0257-qurl-validate-speedup.diff
deleted file mode 100644
index c3eaa1b6fa7e..000000000000
--- a/x11-libs/qt-core/files/0257-qurl-validate-speedup.diff
+++ /dev/null
@@ -1,23 +0,0 @@
-qt-bugs@ issue : N234179
-Trolltech task ID : none
-bugs.kde.org number : 174144
-applied: no
-author: David Faure <faure@kde.org> (and Qt Software, independently)
-
-QUrl is supposed to have flags for parsing and validating a given URL only once.
-However it only sets the Validated flag on error, not after successful validation.
-So a valid url will be validated over and over again, every time e.g. port() or isValid() is called.
-
-Included in Qt 4.5
-
---- src/corelib/io/qurl.cpp
-+++ src/corelib/io/qurl.cpp
-@@ -3414,6 +3414,8 @@ void QUrlPrivate::validate() const
- that->encodedOriginal = that->toEncoded(); // may detach
- parse(ParseOnly);
-
-+ QURL_SETFLAG(that->stateFlags, Validated);
-+
- if (!isValid)
- return;
-
diff --git a/x11-libs/qt-core/files/qt-core-4.5-boilerplate.diff b/x11-libs/qt-core/files/qt-core-4.5-boilerplate.diff
deleted file mode 100644
index ca9c028774a8..000000000000
--- a/x11-libs/qt-core/files/qt-core-4.5-boilerplate.diff
+++ /dev/null
@@ -1,40 +0,0 @@
-
---- src/corelib/global/qlibraryinfo.cpp
-+++ src/corelib/global/qlibraryinfo.cpp
-@@ -525,35 +525,6 @@ void qt_core_init_boilerplate() __attrib
- asm ("syscall\n" \
- : : "a" (SYS_exit), "D" (0)); _exit(c)
-
--# elif defined(QT_ARCH_IA64)
--#define sysinit() \
-- asm volatile ("{.mlx\n" \
-- " nop.m 0\n" \
-- " movl r2 = @pcrel(boilerplate);;" \
-- "}\n" \
-- "{.mii\n" \
-- " mov r10 = @ltoffx(boilerplate)\n" \
-- " mov r1 = ip\n" \
-- " adds r2 = -16, r2\n;;\n" \
-- "}\n" \
-- " add r1 = r2, r1;;\n" \
-- " sub r1 = r1, r10;;\n" \
-- : : : "r2", "r10")
--#define syswrite(msg, len) \
-- ({ const char *_msg = msg; \
-- asm ("mov out0=%1\n" \
-- "mov out1=%2\n" \
-- "mov out2=%3\n" \
-- ";;\n" \
-- "mov r15=%0\n" \
-- "break 0x100000;;\n" \
-- : : "I" (SYS_write), "I" (1), "r" (_msg), "r" (len)); })
--#define sysexit(c) \
-- asm ("mov out0=%1\n" \
-- ";;\n" \
-- "mov r15=%0\n" \
-- "break 0x100000;;\n" \
-- : : "I" (SYS_exit), "O" (0)); write(1, 0, 0); _exit(c)
- # else
- #define sysinit() (void)0
- #define syswrite(msg, len) (msg); (len)
-