summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAron Griffis <agriffis@gentoo.org>2004-06-24 00:20:49 +0000
committerAron Griffis <agriffis@gentoo.org>2004-06-24 00:20:49 +0000
commit0a59b0ebac2f759cd8d0e99ac3d28ec0fe793bc5 (patch)
tree48c47b4ade8f512a944468ba8a47beb78c2ea1bc /x11-libs/qt-embedded
parentQA - fix use invocation, run gnuconfig_update everywhere instead of select ar... (diff)
downloadhistorical-0a59b0ebac2f759cd8d0e99ac3d28ec0fe793bc5.tar.gz
historical-0a59b0ebac2f759cd8d0e99ac3d28ec0fe793bc5.tar.bz2
historical-0a59b0ebac2f759cd8d0e99ac3d28ec0fe793bc5.zip
QA - fix use invocation
Diffstat (limited to 'x11-libs/qt-embedded')
-rw-r--r--x11-libs/qt-embedded/ChangeLog6
-rw-r--r--x11-libs/qt-embedded/qt-embedded-3.0.5.ebuild8
-rw-r--r--x11-libs/qt-embedded/qt-embedded-3.1.2.ebuild8
3 files changed, 13 insertions, 9 deletions
diff --git a/x11-libs/qt-embedded/ChangeLog b/x11-libs/qt-embedded/ChangeLog
index 948ae39fb7db..ff8ffa570904 100644
--- a/x11-libs/qt-embedded/ChangeLog
+++ b/x11-libs/qt-embedded/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for x11-libs/qt-embedded
# Copyright 2002-2004 Gentoo Technologies, Inc.; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/x11-libs/qt-embedded/ChangeLog,v 1.4 2004/04/17 23:02:17 aliz Exp $
+# $Header: /var/cvsroot/gentoo-x86/x11-libs/qt-embedded/ChangeLog,v 1.5 2004/06/24 00:20:49 agriffis Exp $
+
+ 23 Jun 2004; Aron Griffis <agriffis@gentoo.org> qt-embedded-3.0.5.ebuild,
+ qt-embedded-3.1.2.ebuild:
+ QA - fix use invocation
17 Apr 2004; Daniel Ahlberg <aliz@gentoo.org> qt-embedded-3.0.5.ebuild,
qt-embedded-3.1.2.ebuild:
diff --git a/x11-libs/qt-embedded/qt-embedded-3.0.5.ebuild b/x11-libs/qt-embedded/qt-embedded-3.0.5.ebuild
index 247d474f9b1c..76f1b0c7f378 100644
--- a/x11-libs/qt-embedded/qt-embedded-3.0.5.ebuild
+++ b/x11-libs/qt-embedded/qt-embedded-3.0.5.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2004 Gentoo Technologies, Inc.
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/x11-libs/qt-embedded/qt-embedded-3.0.5.ebuild,v 1.11 2004/04/17 23:02:17 aliz Exp $
+# $Header: /var/cvsroot/gentoo-x86/x11-libs/qt-embedded/qt-embedded-3.0.5.ebuild,v 1.12 2004/06/24 00:20:49 agriffis Exp $
DESCRIPTION="QT version ${PV}"
HOMEPAGE="http://www.trolltech.com/"
@@ -29,7 +29,7 @@ QTBASE=/usr/qt/3-embedded
export QTDIR=${S}
pkg_setup() {
- if [ `use build` ] ; then
+ if use build ; then
return 0
else
ewarn "Note: this will build a rather bloated qt/e, with all features enabled."
@@ -54,7 +54,7 @@ src_compile() {
export YACC='byacc -d'
export LDFLAGS="-ldl"
- if [ -z "`use build`" ]; then
+ if ! use build; then
# ordinary setup, rather bloated
use gif && myconf="${myconf} -qt-gif"
use mysql && myconf="${myconf} -plugin-sql-mysql -I/usr/include/mysql -L/usr/lib/mysql"
@@ -62,7 +62,7 @@ src_compile() {
use odbc && myconf="${myconf} -plugin-sql-odbc"
use debug && myconf="${myconf} -debug" || myconf="${myconf} -release -no-g++-exceptions"
- if [ "`use x86`" ]; then
+ if use x86; then
myconf="$myconf -embedded x86" # -xplatform linux-g++ -platform linux-g++"
else
# and i've no idea if it'll work
diff --git a/x11-libs/qt-embedded/qt-embedded-3.1.2.ebuild b/x11-libs/qt-embedded/qt-embedded-3.1.2.ebuild
index 9228aeaf87b2..c0fea1e616b8 100644
--- a/x11-libs/qt-embedded/qt-embedded-3.1.2.ebuild
+++ b/x11-libs/qt-embedded/qt-embedded-3.1.2.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2004 Gentoo Technologies, Inc.
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/x11-libs/qt-embedded/qt-embedded-3.1.2.ebuild,v 1.6 2004/04/17 23:02:17 aliz Exp $
+# $Header: /var/cvsroot/gentoo-x86/x11-libs/qt-embedded/qt-embedded-3.1.2.ebuild,v 1.7 2004/06/24 00:20:49 agriffis Exp $
DESCRIPTION="QT version ${PV}"
HOMEPAGE="http://www.trolltech.com/"
@@ -29,7 +29,7 @@ QTBASE=/usr/qt/3-embedded
export QTDIR=${S}
pkg_setup() {
- if [ `use build` ] ; then
+ if use build ; then
return 0
else
ewarn "Note: this will build a rather bloated qt/e, with all features enabled."
@@ -54,7 +54,7 @@ src_compile() {
export YACC='byacc -d'
export LDFLAGS="-ldl"
- if [ -z "`use build`" ]; then
+ if ! use build; then
# ordinary setup, rather bloated
use gif && myconf="${myconf} -qt-gif"
use mysql && myconf="${myconf} -plugin-sql-mysql -I/usr/include/mysql -L/usr/lib/mysql"
@@ -62,7 +62,7 @@ src_compile() {
use odbc && myconf="${myconf} -plugin-sql-odbc"
use debug && myconf="${myconf} -debug" || myconf="${myconf} -release -no-g++-exceptions"
- if [ "`use x86`" ]; then
+ if use x86; then
myconf="$myconf -embedded x86" # -xplatform linux-g++ -platform linux-g++"
else
# and i've no idea if it'll work