summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorNick Hadaway <raker@gentoo.org>2002-07-17 05:40:09 +0000
committerNick Hadaway <raker@gentoo.org>2002-07-17 05:40:09 +0000
commitc4020788c154d9da7720362e7ef0c1931fcedb5a (patch)
treeb84efa27caa3a7b2a228621e1018a21af51980fd /x11-misc
parentadded MISSING DIGEST, and AGAIN repoman fixes -- LAMER PAY ATTENTION (diff)
downloadhistorical-c4020788c154d9da7720362e7ef0c1931fcedb5a.tar.gz
historical-c4020788c154d9da7720362e7ef0c1931fcedb5a.tar.bz2
historical-c4020788c154d9da7720362e7ef0c1931fcedb5a.zip
Updated wmakerconf to the latest version. Currently works great but
working on also getting libwmfun support.
Diffstat (limited to 'x11-misc')
-rw-r--r--x11-misc/wmakerconf/ChangeLog9
-rw-r--r--x11-misc/wmakerconf/files/digest-wmakerconf-2.91
-rw-r--r--x11-misc/wmakerconf/wmakerconf-2.9.ebuild52
3 files changed, 61 insertions, 1 deletions
diff --git a/x11-misc/wmakerconf/ChangeLog b/x11-misc/wmakerconf/ChangeLog
index 0797eb961320..875d4075bf1c 100644
--- a/x11-misc/wmakerconf/ChangeLog
+++ b/x11-misc/wmakerconf/ChangeLog
@@ -1,6 +1,13 @@
# ChangeLog for x11-misc/wmakerconf
# Copyright 2002 Gentoo Technologies, Inc.; Distributed under the GPL
-# $Header: /var/cvsroot/gentoo-x86/x11-misc/wmakerconf/ChangeLog,v 1.2 2002/06/19 21:59:29 seemant Exp $
+# $Header: /var/cvsroot/gentoo-x86/x11-misc/wmakerconf/ChangeLog,v 1.3 2002/07/17 05:40:08 raker Exp $
+
+*wmakerconf-2.9 (16 Jul 2002)
+
+ 16 Jul 2002; Nick Hadaway <raker@gentoo.org>
+ wmakerconf-2.9.ebuild, files/digest-wmakerconf-2.9 :
+
+ Updated to latest version. We don't have libwmfun support yet.
*wmakerconf-2.8.1-r2 (19 Jun 2002)
diff --git a/x11-misc/wmakerconf/files/digest-wmakerconf-2.9 b/x11-misc/wmakerconf/files/digest-wmakerconf-2.9
new file mode 100644
index 000000000000..f5f56ab84608
--- /dev/null
+++ b/x11-misc/wmakerconf/files/digest-wmakerconf-2.9
@@ -0,0 +1 @@
+MD5 da02991fc9e8e09c99c1d159f45afe1e wmakerconf-2.9.tar.bz2 499800
diff --git a/x11-misc/wmakerconf/wmakerconf-2.9.ebuild b/x11-misc/wmakerconf/wmakerconf-2.9.ebuild
new file mode 100644
index 000000000000..b66d4d47ad61
--- /dev/null
+++ b/x11-misc/wmakerconf/wmakerconf-2.9.ebuild
@@ -0,0 +1,52 @@
+# Copyright 1999-2002 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/x11-misc/wmakerconf/wmakerconf-2.9.ebuild,v 1.1 2002/07/17 05:40:09 raker Exp $
+
+S=${WORKDIR}/${P}
+DESCRIPTION="X based config tool for the windowmaker X windowmanager."
+SRC_URI="http://www.windowmaker.org/pub/contrib/source/wmakerconf/${P}.tar.bz2"
+# Homepage appears not to be up anymore
+HOMEPAGE="http://ulli.on.openave.net/wmakerconf/"
+SLOT="0"
+LICENSE="GPL-2"
+KEYWORDS="x86"
+
+DEPEND="=x11-libs/gtk+-1.2*
+ x11-wm/WindowMaker
+ gnome? ( =gnome-base/gnome-libs-1.4* )
+ imlib? ( media-libs/imlib )"
+
+
+RDEPEND="nls? ( sys-devel/gettext )
+ perl? ( sys-devel/perl
+ net-misc/wget )"
+
+src_compile() {
+
+ local myconf
+
+ use nls || myconf="${myconf} --disable-nls"
+
+ use imlib || myconf="${myconf} --disable-imlibtest"
+
+ use gnome || myconf="${myconf} --without-gnome"
+
+ ./configure \
+ --prefix=/usr \
+ --host=${CHOST} \
+ --sysconfdir=/etc \
+ ${myconf} || die
+ emake || die
+
+}
+
+src_install() {
+
+ make \
+ prefix=${D}/usr \
+ GNOMEDIR=${D}/usr/share/gnome/apps/Settings \
+ install || die
+
+ dodoc README MANUAL AUTHORS TODO COPYING ChangeLog
+ dohtml -r .
+}