summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorNick Hadaway <raker@gentoo.org>2002-10-04 16:05:45 +0000
committerNick Hadaway <raker@gentoo.org>2002-10-04 16:05:45 +0000
commit70971eba4c28deb0c473d71f9430bb3983ba4e50 (patch)
tree67c4b8fe9b135ff6ffae0719d53a7ba29b986196 /x11-plugins
parentInitial ebuild added to portage. (diff)
downloadhistorical-70971eba4c28deb0c473d71f9430bb3983ba4e50.tar.gz
historical-70971eba4c28deb0c473d71f9430bb3983ba4e50.tar.bz2
historical-70971eba4c28deb0c473d71f9430bb3983ba4e50.zip
Initial add of ebuild to portage. More dockapps. w00t!
Diffstat (limited to 'x11-plugins')
-rw-r--r--x11-plugins/wmsmixer/ChangeLog9
-rw-r--r--x11-plugins/wmsmixer/files/digest-wmsmixer-0.51
-rw-r--r--x11-plugins/wmsmixer/files/gcc3.diff12
-rw-r--r--x11-plugins/wmsmixer/files/makefile.diff31
-rw-r--r--x11-plugins/wmsmixer/wmsmixer-0.5.ebuild41
5 files changed, 94 insertions, 0 deletions
diff --git a/x11-plugins/wmsmixer/ChangeLog b/x11-plugins/wmsmixer/ChangeLog
new file mode 100644
index 000000000000..c193df730c04
--- /dev/null
+++ b/x11-plugins/wmsmixer/ChangeLog
@@ -0,0 +1,9 @@
+# ChangeLog for x11-plugins/wmsmixer
+# Copyright 2002 Gentoo Technologies, Inc.; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/x11-plugins/wmsmixer/ChangeLog,v 1.1 2002/10/04 16:05:45 raker Exp $
+
+*wmsmixer-0.5 (04 Oct 2002)
+
+ 04 Oct 2002; Nick Hadaway <raker@gentoo.org> wmsmixer-0.5.ebulid,
+ files/digest-wmsmixer-0.5, files/gcc3.diff, files/makefile.diff :
+ Initial add of ebuild to portage.
diff --git a/x11-plugins/wmsmixer/files/digest-wmsmixer-0.5 b/x11-plugins/wmsmixer/files/digest-wmsmixer-0.5
new file mode 100644
index 000000000000..ec531d5c740b
--- /dev/null
+++ b/x11-plugins/wmsmixer/files/digest-wmsmixer-0.5
@@ -0,0 +1 @@
+MD5 8b4d739832a6b2b6c107d0eddad56cca wmsmixer-0.5.tar.gz 26208
diff --git a/x11-plugins/wmsmixer/files/gcc3.diff b/x11-plugins/wmsmixer/files/gcc3.diff
new file mode 100644
index 000000000000..098dbb5ee3a9
--- /dev/null
+++ b/x11-plugins/wmsmixer/files/gcc3.diff
@@ -0,0 +1,12 @@
+diff -urN wmsmixer-0.5/wmsmixer.cc wmsmixer-0.5-modified/wmsmixer.cc
+--- wmsmixer-0.5/wmsmixer.cc 2001-03-05 16:39:43.000000000 -0600
++++ wmsmixer-0.5-modified/wmsmixer.cc 2002-10-04 10:48:24.000000000 -0500
+@@ -547,7 +547,7 @@
+ }
+ }
+
+-void checkVol(bool forced=true)
++void checkVol(bool forced)
+ {
+ mixctl->readVol(channel[curchannel], true);
+ int nl=mixctl->readLeft(channel[curchannel]);
diff --git a/x11-plugins/wmsmixer/files/makefile.diff b/x11-plugins/wmsmixer/files/makefile.diff
new file mode 100644
index 000000000000..c9be8c5f6bc8
--- /dev/null
+++ b/x11-plugins/wmsmixer/files/makefile.diff
@@ -0,0 +1,31 @@
+--- Makefile.orig 2002-10-04 10:53:52.000000000 -0500
++++ Makefile 2002-10-04 11:01:50.000000000 -0500
+@@ -150,12 +150,12 @@
+
+ BOOTSTRAPCFLAGS =
+
+- CC = gcc
++ CC = g++
+ AS = as
+
+ .SUFFIXES: .cc
+
+- CXX = c++
++ CXX = g++
+
+ CXXFILT = c++filt
+ CXXLIB =
+@@ -887,13 +887,6 @@
+ fi
+ $(INSTALL) $(INSTALLFLAGS) $(INSTPGMFLAGS) wmsmixer $(DESTDIR)$(BINDIR)/wmsmixer
+
+-all:: wmsmixer.$(MANNEWSUFFIX)
+-
+-wmsmixer.$(MANNEWSUFFIX): wmsmixer.$(MANSRCSUFFIX)
+- $(RM) $@
+- cd `dirname wmsmixer` && \
+- $(LN) `basename wmsmixer.$(MANSRCSUFFIX)` `basename $@`
+-
+ cleandir::
+ $(RM) wmsmixer.$(MANNEWSUFFIX)
+
diff --git a/x11-plugins/wmsmixer/wmsmixer-0.5.ebuild b/x11-plugins/wmsmixer/wmsmixer-0.5.ebuild
new file mode 100644
index 000000000000..74bf6701c562
--- /dev/null
+++ b/x11-plugins/wmsmixer/wmsmixer-0.5.ebuild
@@ -0,0 +1,41 @@
+# Copyright 1999-2002 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/x11-plugins/wmsmixer/wmsmixer-0.5.ebuild,v 1.1 2002/10/04 16:05:45 raker Exp $
+
+S="${WORKDIR}/${P}"
+
+DESCRIPTION="fork of wmmixer adding scrollwheel support and other features"
+HOMEPAGE="http://www.hibernaculum.net/wmsmixer.html"
+SRC_URI="http://www.hibernaculum.net/download/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="x86"
+
+DEPEND="virtual/glibc
+ virtual/x11"
+RDEPEND="${DEPEND}"
+
+src_unpack() {
+
+ unpack ${A}
+ cd ${S}
+ patch -p1 < ${FILESDIR}/gcc3.diff || die "patch failed"
+
+}
+
+src_compile() {
+
+ xmkmf || die "xmkmf failed"
+
+ patch -p0 < ${FILESDIR}/makefile.diff
+
+ make || die "parallel make failed"
+
+}
+
+src_install() {
+
+ make DESTDIR=${D} install || die "make install failed"
+
+}