summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDiego Elio Pettenò <flameeyes@gentoo.org>2007-12-30 23:15:28 +0000
committerDiego Elio Pettenò <flameeyes@gentoo.org>2007-12-30 23:15:28 +0000
commitb53c634d970b86451bf522ff0593a2c1531484aa (patch)
treec3e3b8906682a98ed10e681f8e8b41a3bf8a6c04 /x11-themes/nuvox/nuvox-07.1.ebuild
parentVersion bump #203833 by Philip Ludlam. (diff)
downloadhistorical-b53c634d970b86451bf522ff0593a2c1531484aa.tar.gz
historical-b53c634d970b86451bf522ff0593a2c1531484aa.tar.bz2
historical-b53c634d970b86451bf522ff0593a2c1531484aa.zip
Initial import of nuvox, an icon theme for KDE (and other FDO-compliant desktop environments).
Package-Manager: portage-2.1.4_rc12
Diffstat (limited to 'x11-themes/nuvox/nuvox-07.1.ebuild')
-rw-r--r--x11-themes/nuvox/nuvox-07.1.ebuild42
1 files changed, 42 insertions, 0 deletions
diff --git a/x11-themes/nuvox/nuvox-07.1.ebuild b/x11-themes/nuvox/nuvox-07.1.ebuild
new file mode 100644
index 000000000000..c1c1247617f7
--- /dev/null
+++ b/x11-themes/nuvox/nuvox-07.1.ebuild
@@ -0,0 +1,42 @@
+# Copyright 1999-2007 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/x11-themes/nuvox/nuvox-07.1.ebuild,v 1.1 2007/12/30 23:15:28 flameeyes Exp $
+
+MY_P="nuvoX_${PV}"
+
+DESCRIPTION="NuvoX SVG icon theme."
+SRC_URI="mirror://gentoo/${MY_P}.tar.gz"
+HOMEPAGE="http://www.kde-look.org/content/show.php?content=38467"
+LICENSE="GPL-2"
+
+IUSE=""
+KEYWORDS="~amd64"
+SLOT="0"
+
+RESTRICT="strip binchecks"
+
+S="${WORKDIR}/${MY_P}"
+
+DEPEND="media-gfx/imagemagick"
+RDEPEND=""
+
+src_unpack() {
+ unpack ${A}
+
+ sed -i \
+ -e '/rm -fr/d' \
+ -e '/tar cf/d' \
+ "${S}/buildset"
+}
+
+src_compile() {
+ ./buildset || die "unable to build icon sets."
+}
+
+src_install() {
+ dodoc nuvoX_0.7/readme.txt
+ rm nuvoX_0.7/{readme,license}.txt
+
+ insinto /usr/share/icons/${PN}
+ doins -r nuvoX_0.7/*
+}