summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAnant Narayanan <anant@gentoo.org>2007-03-08 19:05:36 +0000
committerAnant Narayanan <anant@gentoo.org>2007-03-08 19:05:36 +0000
commit3da8a6666a8c5ee45e01f173033bdf9a1e56af1c (patch)
tree9a681ffd2731b540a57816ae4ff656165e162310 /x11-themes/wm-icons/wm-icons-0.4.0.ebuild
parentStable on sparc wrt #169094 (diff)
downloadhistorical-3da8a6666a8c5ee45e01f173033bdf9a1e56af1c.tar.gz
historical-3da8a6666a8c5ee45e01f173033bdf9a1e56af1c.tar.bz2
historical-3da8a6666a8c5ee45e01f173033bdf9a1e56af1c.zip
vBump to 0.4.0, thanks to Richard Adenling, bug #150838
Package-Manager: portage-2.1.2.1
Diffstat (limited to 'x11-themes/wm-icons/wm-icons-0.4.0.ebuild')
-rw-r--r--x11-themes/wm-icons/wm-icons-0.4.0.ebuild39
1 files changed, 39 insertions, 0 deletions
diff --git a/x11-themes/wm-icons/wm-icons-0.4.0.ebuild b/x11-themes/wm-icons/wm-icons-0.4.0.ebuild
new file mode 100644
index 000000000000..413eb49eb7a5
--- /dev/null
+++ b/x11-themes/wm-icons/wm-icons-0.4.0.ebuild
@@ -0,0 +1,39 @@
+# Copyright 1999-2007 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/x11-themes/wm-icons/wm-icons-0.4.0.ebuild,v 1.1 2007/03/08 19:05:36 anant Exp $
+
+DESCRIPTION="A Large Assortment of Beutiful Themed Icons, Created with FVWM in mind"
+
+HOMEPAGE="http://wm-icons.sourceforge.net/"
+SRC_URI="mirror://sourceforge/wm-icons/wm-icons-${PV}.tar.bz2"
+LICENSE="GPL-2"
+
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~ia64 ~ppc ~ppc64 ~x86"
+
+IUSE=""
+RDEPEND="sys-apps/gawk dev-lang/perl"
+DEPEND="${RDEPEND} sys-devel/autoconf sys-devel/automake sys-apps/sed"
+
+src_compile() {
+ econf --enable-all-sets --enable-icondir=/usr/share/icons/wm-icons || die "econf failed"
+ emake
+}
+
+src_install() {
+ make icondir=${D}/usr/share/icons/wm-icons DESTDIR=${D} install
+
+ einfo "Setting default aliases..."
+ ${D}/usr/bin/wm-icons-config --force --user-dir="${D}/usr/share/icons/wm-icons" --defaults
+
+ dodoc AUTHORS ChangeLog COPYING INSTALL NEWS README
+}
+
+pkg_postinst() {
+ einfo "Users can use the wm-icons-config utility to create aliases in their"
+ einfo "home directory, FVWM users can then set this in their ImagePath"
+ einfo
+ einfo "Sample configurations for fvwm1, fvwm2, fvwm95 and scwm are available in"
+ einfo "/usr/share/wm-icons"
+ einfo
+}