summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorBen de Groot <yngwin@gentoo.org>2009-08-13 07:58:56 +0000
committerBen de Groot <yngwin@gentoo.org>2009-08-13 07:58:56 +0000
commit46a3cfe9bf25b17a10ebfc3b45a3ea0fc737357a (patch)
tree424ff0da36a12c04db7375aacf1a6f9d9628affb /x11-themes
parentremoved block, improved live detection (diff)
downloadhistorical-46a3cfe9bf25b17a10ebfc3b45a3ea0fc737357a.tar.gz
historical-46a3cfe9bf25b17a10ebfc3b45a3ea0fc737357a.tar.bz2
historical-46a3cfe9bf25b17a10ebfc3b45a3ea0fc737357a.zip
Version bump
Package-Manager: portage-2.2_rc38/cvs/Linux x86_64
Diffstat (limited to 'x11-themes')
-rw-r--r--x11-themes/gtk-engines-qtcurve/ChangeLog8
-rw-r--r--x11-themes/gtk-engines-qtcurve/gtk-engines-qtcurve-0.67.4.ebuild35
-rw-r--r--x11-themes/qtcurve-qt4/ChangeLog7
-rw-r--r--x11-themes/qtcurve-qt4/qtcurve-qt4-0.67.5.ebuild33
-rw-r--r--x11-themes/qtcurve/ChangeLog7
-rw-r--r--x11-themes/qtcurve/qtcurve-0.67.2.ebuild35
6 files changed, 122 insertions, 3 deletions
diff --git a/x11-themes/gtk-engines-qtcurve/ChangeLog b/x11-themes/gtk-engines-qtcurve/ChangeLog
index e0f88934b00e..e84e621b836b 100644
--- a/x11-themes/gtk-engines-qtcurve/ChangeLog
+++ b/x11-themes/gtk-engines-qtcurve/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for x11-themes/gtk-engines-qtcurve
# Copyright 1999-2009 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/x11-themes/gtk-engines-qtcurve/ChangeLog,v 1.62 2009/08/05 13:50:28 yngwin Exp $
+# $Header: /var/cvsroot/gentoo-x86/x11-themes/gtk-engines-qtcurve/ChangeLog,v 1.63 2009/08/13 07:52:45 yngwin Exp $
+
+*gtk-engines-qtcurve-0.67.4 (13 Aug 2009)
+
+ 13 Aug 2009; Ben de Groot <yngwin@gentoo.org>
+ +gtk-engines-qtcurve-0.67.4.ebuild:
+ Version bump
*gtk-engines-qtcurve-0.67.2 (05 Aug 2009)
diff --git a/x11-themes/gtk-engines-qtcurve/gtk-engines-qtcurve-0.67.4.ebuild b/x11-themes/gtk-engines-qtcurve/gtk-engines-qtcurve-0.67.4.ebuild
new file mode 100644
index 000000000000..5ece92c05168
--- /dev/null
+++ b/x11-themes/gtk-engines-qtcurve/gtk-engines-qtcurve-0.67.4.ebuild
@@ -0,0 +1,35 @@
+# Copyright 1999-2009 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/x11-themes/gtk-engines-qtcurve/gtk-engines-qtcurve-0.67.4.ebuild,v 1.1 2009/08/13 07:52:45 yngwin Exp $
+
+EAPI=1
+inherit eutils cmake-utils
+
+MY_P=${P/gtk-engines-qtcurve/QtCurve-Gtk2}
+
+DESCRIPTION="A set of widget styles for GTK2 based apps, also available for KDE3 and Qt4"
+HOMEPAGE="http://www.kde-look.org/content/show.php?content=40492"
+SRC_URI="http://home.freeuk.com/cpdrummond/${MY_P}.tar.bz2"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~hppa ~ppc ~ppc64 ~sparc ~x86"
+IUSE="mozilla firefox3"
+
+RDEPEND="x11-libs/gtk+:2
+ x11-libs/cairo
+ firefox3? ( || ( >=www-client/mozilla-firefox-3.0
+ >=www-client/mozilla-firefox-bin-3.0 ) )"
+DEPEND="x11-libs/gtk+:2
+ x11-libs/cairo
+ dev-util/pkgconfig"
+
+S=${WORKDIR}/${MY_P}
+DOCS="ChangeLog README TODO"
+
+src_compile() {
+ local mycmakeargs=""
+ use mozilla && mycmakeargs="-DQTC_MODIFY_MOZILLA=true -DQTC_OLD_MOZILLA=true"
+ use firefox3 && mycmakeargs="-DQTC_MODIFY_MOZILLA=true -DQTC_OLD_MOZILLA=false"
+ cmake-utils_src_compile
+}
diff --git a/x11-themes/qtcurve-qt4/ChangeLog b/x11-themes/qtcurve-qt4/ChangeLog
index 76a217c53792..247ed063edfd 100644
--- a/x11-themes/qtcurve-qt4/ChangeLog
+++ b/x11-themes/qtcurve-qt4/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for x11-themes/qtcurve-qt4
# Copyright 1999-2009 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/x11-themes/qtcurve-qt4/ChangeLog,v 1.72 2009/08/05 13:51:40 yngwin Exp $
+# $Header: /var/cvsroot/gentoo-x86/x11-themes/qtcurve-qt4/ChangeLog,v 1.73 2009/08/13 07:54:57 yngwin Exp $
+
+*qtcurve-qt4-0.67.5 (13 Aug 2009)
+
+ 13 Aug 2009; Ben de Groot <yngwin@gentoo.org> +qtcurve-qt4-0.67.5.ebuild:
+ Version bump
*qtcurve-qt4-0.67.2 (05 Aug 2009)
diff --git a/x11-themes/qtcurve-qt4/qtcurve-qt4-0.67.5.ebuild b/x11-themes/qtcurve-qt4/qtcurve-qt4-0.67.5.ebuild
new file mode 100644
index 000000000000..c323a329b17e
--- /dev/null
+++ b/x11-themes/qtcurve-qt4/qtcurve-qt4-0.67.5.ebuild
@@ -0,0 +1,33 @@
+# Copyright 1999-2009 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/x11-themes/qtcurve-qt4/qtcurve-qt4-0.67.5.ebuild,v 1.1 2009/08/13 07:54:57 yngwin Exp $
+
+EAPI="2"
+KDE_REQUIRED="optional"
+inherit flag-o-matic cmake-utils kde4-base
+
+MY_P="${P/qtcurve-qt4/QtCurve-KDE4}"
+DESCRIPTION="A set of widget styles for Qt4 based apps, also available for KDE3 and GTK2"
+HOMEPAGE="http://www.kde-look.org/content/show.php?content=40492"
+SRC_URI="http://home.freeuk.com/cpdrummond/${MY_P}.tar.bz2"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~hppa ~ppc ~ppc64 ~sparc ~x86"
+IUSE="kde"
+
+DEPEND="x11-libs/qt-gui:4[dbus]
+ kde? ( >=kde-base/kwin-4.1.0 )"
+RDEPEND="${DEPEND}"
+
+S="${WORKDIR}/${MY_P}"
+DOCS="ChangeLog README TODO"
+
+src_configure() {
+ if use kde ; then
+ kde4-base_src_configure
+ else
+ mycmakeargs="-DQTC_QT_ONLY=true"
+ cmake-utils_src_configure
+ fi
+}
diff --git a/x11-themes/qtcurve/ChangeLog b/x11-themes/qtcurve/ChangeLog
index a268d3df2698..e7efc7649c7e 100644
--- a/x11-themes/qtcurve/ChangeLog
+++ b/x11-themes/qtcurve/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for x11-themes/qtcurve
# Copyright 1999-2009 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/x11-themes/qtcurve/ChangeLog,v 1.62 2009/08/03 20:16:13 maekke Exp $
+# $Header: /var/cvsroot/gentoo-x86/x11-themes/qtcurve/ChangeLog,v 1.63 2009/08/13 07:58:56 yngwin Exp $
+
+*qtcurve-0.67.2 (13 Aug 2009)
+
+ 13 Aug 2009; Ben de Groot <yngwin@gentoo.org> +qtcurve-0.67.2.ebuild:
+ Version bump
03 Aug 2009; Markus Meier <maekke@gentoo.org> qtcurve-0.65.2.ebuild:
amd64/x86 stable, bug #279585
diff --git a/x11-themes/qtcurve/qtcurve-0.67.2.ebuild b/x11-themes/qtcurve/qtcurve-0.67.2.ebuild
new file mode 100644
index 000000000000..da7720c7793d
--- /dev/null
+++ b/x11-themes/qtcurve/qtcurve-0.67.2.ebuild
@@ -0,0 +1,35 @@
+# Copyright 1999-2009 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/x11-themes/qtcurve/qtcurve-0.67.2.ebuild,v 1.1 2009/08/13 07:58:56 yngwin Exp $
+
+EAPI=1
+
+# Order is important, so we get src_compile from cmake-utils.
+inherit kde-functions qt3 cmake-utils
+
+MY_P=${P/qtcurve/QtCurve-KDE3}
+
+DESCRIPTION="A set of widget styles for KDE3 based apps, also available for GTK2 and Qt4"
+HOMEPAGE="http://www.kde-look.org/content/show.php?content=40492"
+SRC_URI="http://home.freeuk.com/cpdrummond/${MY_P}.tar.bz2"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~hppa ~ppc ~ppc64 ~sparc ~x86"
+IUSE=""
+
+RDEPEND="x11-libs/qt:3"
+DEPEND="${RDEPEND}"
+
+need-kde 3.5
+
+S=${WORKDIR}/${MY_P}
+DOCS="ChangeLog README TODO"
+
+pkg_postinst() {
+ buildsycoca
+}
+
+pkg_postrm() {
+ buildsycoca
+}