summaryrefslogtreecommitdiff
path: root/x11-wm
diff options
context:
space:
mode:
authorMatt Keadle <mkeadle@gentoo.org>2002-12-07 21:37:08 +0000
committerMatt Keadle <mkeadle@gentoo.org>2002-12-07 21:37:08 +0000
commit250b86bea06461f9ffa0085370be6018a94f5b2f (patch)
tree6a09d4a5b6f1f57c3511eb014509d69275c819b7 /x11-wm
parentunstable pre-release version. (diff)
downloadhistorical-250b86bea06461f9ffa0085370be6018a94f5b2f.tar.gz
historical-250b86bea06461f9ffa0085370be6018a94f5b2f.tar.bz2
historical-250b86bea06461f9ffa0085370be6018a94f5b2f.zip
More Xft2 fixes
Diffstat (limited to 'x11-wm')
-rw-r--r--x11-wm/fluxbox/ChangeLog15
-rw-r--r--x11-wm/fluxbox/files/digest-fluxbox-0.1.13-r71
-rw-r--r--x11-wm/fluxbox/files/digest-fluxbox-0.1.13-r81
-rw-r--r--x11-wm/fluxbox/fluxbox-0.1.13-r7.ebuild65
-rw-r--r--x11-wm/fluxbox/fluxbox-0.1.13-r8.ebuild67
5 files changed, 149 insertions, 0 deletions
diff --git a/x11-wm/fluxbox/ChangeLog b/x11-wm/fluxbox/ChangeLog
index 7f8b5098c68d..a28c6187fcc0 100644
--- a/x11-wm/fluxbox/ChangeLog
+++ b/x11-wm/fluxbox/ChangeLog
@@ -2,6 +2,21 @@
# Copyright 2002 Gentoo Technologies, Inc.; Distributed under the GPL
# $Header
+*fluxbox-0.1.13-r6 (07 Dec 2002)
+
+ 07 Dec 2002; Matt Keadle <mkeadle@gentoo.org> fluxbox-0.1.13-r8.ebuild
+ files/digest-fluxbox-0.1.13-r8
+
+ Update to build against Xft2. Remember patch release.
+
+*fluxbox-0.1.13-r7 (07 Dec 2002)
+
+ 07 Dec 2002; Matt Keadle <mkeadle@gentoo.org> fluxbox-0.1.13-r7.ebuild
+ files/digest-fluxbox-0.1.13-r7
+
+ Update to build against Xft2. No remember patch release.
+
+
*fluxbox-0.1.13-r6 (06 Dec 2002)
06 Dec 2002; Matt Keadle <mkeadle@gentoo.org> fluxbox-0.1.13-r5.ebui
diff --git a/x11-wm/fluxbox/files/digest-fluxbox-0.1.13-r7 b/x11-wm/fluxbox/files/digest-fluxbox-0.1.13-r7
new file mode 100644
index 000000000000..b74d9982fc39
--- /dev/null
+++ b/x11-wm/fluxbox/files/digest-fluxbox-0.1.13-r7
@@ -0,0 +1 @@
+MD5 24844a5961b56406e2d6d52f199e54bb fluxbox-0.1.13.tar.bz2 350608
diff --git a/x11-wm/fluxbox/files/digest-fluxbox-0.1.13-r8 b/x11-wm/fluxbox/files/digest-fluxbox-0.1.13-r8
new file mode 100644
index 000000000000..b74d9982fc39
--- /dev/null
+++ b/x11-wm/fluxbox/files/digest-fluxbox-0.1.13-r8
@@ -0,0 +1 @@
+MD5 24844a5961b56406e2d6d52f199e54bb fluxbox-0.1.13.tar.bz2 350608
diff --git a/x11-wm/fluxbox/fluxbox-0.1.13-r7.ebuild b/x11-wm/fluxbox/fluxbox-0.1.13-r7.ebuild
new file mode 100644
index 000000000000..f9b7dcdd1675
--- /dev/null
+++ b/x11-wm/fluxbox/fluxbox-0.1.13-r7.ebuild
@@ -0,0 +1,65 @@
+# Copyright 1999-2002 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/x11-wm/fluxbox/fluxbox-0.1.13-r7.ebuild,v 1.1 2002/12/07 21:37:08 mkeadle Exp $
+
+IUSE="nls"
+
+inherit commonbox flag-o-matic eutils
+
+S=${WORKDIR}/${P}
+DESCRIPTION="Window manager based on Blackbox and pwm -- has tabs."
+SRC_URI="http://download.sourceforge.net/${PN}/${P}.tar.bz2"
+HOMEPAGE="http://fluxbox.sf.net"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="x86 ~ppc ~sparc ~sparc64"
+
+mydoc="ChangeLog COPYING NEWS"
+myconf="--enable-xinerama"
+# Test for Xft2
+if pkg-config xft; then CXXFLAGS="${CXXFLAGS} -I/usr/include/freetype2"; fi
+
+filter-flags -fno-exceptions
+export WANT_AUTOMAKE_1_6=1
+export WANT_AUTOCONF_2_5=1
+
+src_unpack() {
+
+ unpack ${A}
+ cd ${S}
+ # Enable keybindings for root and window menus
+ epatch ${FILESDIR}/${P}-menukey.patch
+ # Fix misshaped fonts on fluxbox first start
+ epatch ${FILESDIR}/${P}-aa2.patch
+ # Fix for Openoffice crashing X server
+ epatch ${FILESDIR}/${P}-openoffice.patch
+ # Make sure NLS catalogs get installed
+ epatch ${FILESDIR}/${P}-nls.patch
+
+ # NLS is still names after blackbox.
+ # This will be fixed in later releases.
+ ssed -i "s:blackbox.cat:fluxbox.cat:" \
+ ${S}/src/main.cc
+}
+
+src_compile() {
+
+ commonbox_src_compile
+
+ cd data
+ make \
+ pkgdatadir=/usr/share/commonbox init
+}
+
+
+src_install() {
+
+ commonbox_src_install
+ cd data
+ insinto /usr/share/commonbox
+ doins init
+ insinto /usr/share/commonbox/fluxbox
+ doins keys
+ rm -f ${D}/usr/bin/fluxbox-generate_menu
+}
diff --git a/x11-wm/fluxbox/fluxbox-0.1.13-r8.ebuild b/x11-wm/fluxbox/fluxbox-0.1.13-r8.ebuild
new file mode 100644
index 000000000000..9e188c28e54b
--- /dev/null
+++ b/x11-wm/fluxbox/fluxbox-0.1.13-r8.ebuild
@@ -0,0 +1,67 @@
+# Copyright 1999-2002 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/x11-wm/fluxbox/fluxbox-0.1.13-r8.ebuild,v 1.1 2002/12/07 21:37:08 mkeadle Exp $
+
+IUSE="nls"
+
+inherit commonbox flag-o-matic eutils
+
+S=${WORKDIR}/${P}
+DESCRIPTION="Window manager based on Blackbox and pwm -- has tabs."
+SRC_URI="http://download.sourceforge.net/${PN}/${P}.tar.bz2"
+HOMEPAGE="http://fluxbox.sf.net"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~x86 ~ppc ~sparc ~sparc64"
+
+mydoc="ChangeLog COPYING NEWS"
+myconf="--enable-xinerama"
+# Test for Xft2
+if pkg-config xft; then CXXFLAGS="${CXXFLAGS} -I/usr/include/freetype2"; fi
+
+filter-flags -fno-exceptions
+export WANT_AUTOMAKE_1_6=1
+export WANT_AUTOCONF_2_5=1
+
+src_unpack() {
+
+ unpack ${A}
+ cd ${S}
+ # Enable keybindings for root and window menus
+ epatch ${FILESDIR}/${P}-menukey.patch
+ # Fix misshaped fonts on fluxbox first start
+ epatch ${FILESDIR}/${P}-aa2.patch
+ # Enable remember/startup patch
+ epatch ${FILESDIR}/${P}-remember.patch
+ # Fix for Openoffice crashing X server
+ epatch ${FILESDIR}/${P}-openoffice.patch
+ # Make sure NLS catalogs get installed
+ epatch ${FILESDIR}/${P}-nls.patch
+
+ # NLS is still names after blackbox.
+ # This will be fixed in later releases.
+ ssed -i "s:blackbox.cat:fluxbox.cat:" \
+ ${S}/src/main.cc
+}
+
+src_compile() {
+
+ commonbox_src_compile
+
+ cd data
+ make \
+ pkgdatadir=/usr/share/commonbox init
+}
+
+
+src_install() {
+
+ commonbox_src_install
+ cd data
+ insinto /usr/share/commonbox
+ doins init
+ insinto /usr/share/commonbox/fluxbox
+ doins keys
+ rm -f ${D}/usr/bin/fluxbox-generate_menu
+}