summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJoshua Nichols <nichoj@gentoo.org>2006-12-10 19:58:32 +0000
committerJoshua Nichols <nichoj@gentoo.org>2006-12-10 19:58:32 +0000
commit8da1a446a0d72a410d89066d03cb777896cbb5b5 (patch)
tree9727e9c134ba21a2ed2bd38ce2841a32c6ee3768 /xfce-base
parentAdded ~amd64 keyword wrt bug #153523 (diff)
downloadhistorical-8da1a446a0d72a410d89066d03cb777896cbb5b5.tar.gz
historical-8da1a446a0d72a410d89066d03cb777896cbb5b5.tar.bz2
historical-8da1a446a0d72a410d89066d03cb777896cbb5b5.zip
Got xdt-autogen to work sanely. It is used to do the autogeneration, but not configuring. econf is then used for the configure. Fixes bug #157740. Pruned broken revision.
Package-Manager: portage-2.1.2_rc2-r1
Diffstat (limited to 'xfce-base')
-rw-r--r--xfce-base/xfce-mcs-plugins/ChangeLog11
-rw-r--r--xfce-base/xfce-mcs-plugins/files/digest-xfce-mcs-plugins-4.3.99.2-r33
-rw-r--r--xfce-base/xfce-mcs-plugins/xfce-mcs-plugins-4.3.99.2-r3.ebuild56
3 files changed, 69 insertions, 1 deletions
diff --git a/xfce-base/xfce-mcs-plugins/ChangeLog b/xfce-base/xfce-mcs-plugins/ChangeLog
index e18cb17c024d..50c770c336df 100644
--- a/xfce-base/xfce-mcs-plugins/ChangeLog
+++ b/xfce-base/xfce-mcs-plugins/ChangeLog
@@ -1,6 +1,15 @@
# ChangeLog for xfce-base/xfce-mcs-plugins
# Copyright 2000-2006 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/xfce-base/xfce-mcs-plugins/ChangeLog,v 1.71 2006/12/09 00:32:30 nichoj Exp $
+# $Header: /var/cvsroot/gentoo-x86/xfce-base/xfce-mcs-plugins/ChangeLog,v 1.72 2006/12/10 19:58:32 nichoj Exp $
+
+*xfce-mcs-plugins-4.3.99.2-r3 (10 Dec 2006)
+
+ 10 Dec 2006; Joshua Nichols <nichoj@gentoo.org>
+ -xfce-mcs-plugins-4.3.99.2-r2.ebuild,
+ +xfce-mcs-plugins-4.3.99.2-r3.ebuild:
+ Got xdt-autogen to work sanely. It is used to do the autogeneration, but not
+ configuring. econf is then used for the configure. Fixes bug #157740. Pruned
+ broken revision.
*xfce-mcs-plugins-4.3.99.2-r2 (09 Dec 2006)
diff --git a/xfce-base/xfce-mcs-plugins/files/digest-xfce-mcs-plugins-4.3.99.2-r3 b/xfce-base/xfce-mcs-plugins/files/digest-xfce-mcs-plugins-4.3.99.2-r3
new file mode 100644
index 000000000000..4d8505dfbe0f
--- /dev/null
+++ b/xfce-base/xfce-mcs-plugins/files/digest-xfce-mcs-plugins-4.3.99.2-r3
@@ -0,0 +1,3 @@
+MD5 6234425227e1145319bd75ef52fa97f5 xfce-mcs-plugins-4.3.99.2.tar.bz2 842712
+RMD160 572088b0429f984bedc62484a7a28b2d37aab305 xfce-mcs-plugins-4.3.99.2.tar.bz2 842712
+SHA256 f2773a4c007139f0a06c418b3535374ebeed8e10eef41d3ae69f4259f6f632a5 xfce-mcs-plugins-4.3.99.2.tar.bz2 842712
diff --git a/xfce-base/xfce-mcs-plugins/xfce-mcs-plugins-4.3.99.2-r3.ebuild b/xfce-base/xfce-mcs-plugins/xfce-mcs-plugins-4.3.99.2-r3.ebuild
new file mode 100644
index 000000000000..2504c0e47091
--- /dev/null
+++ b/xfce-base/xfce-mcs-plugins/xfce-mcs-plugins-4.3.99.2-r3.ebuild
@@ -0,0 +1,56 @@
+# Copyright 1999-2006 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/xfce-base/xfce-mcs-plugins/xfce-mcs-plugins-4.3.99.2-r3.ebuild,v 1.1 2006/12/10 19:58:32 nichoj Exp $
+
+inherit gnome2 xfce44
+
+xfce44_beta
+
+DESCRIPTION="Xfce4 mcs plugins"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~mips ~ppc ~ppc64 ~sparc ~x86"
+
+RDEPEND="|| ( ( x11-libs/libX11
+ x11-libs/libXcursor
+ x11-libs/libXrandr
+ x11-libs/libXrender
+ x11-libs/libICE
+ x11-libs/libSM
+ x11-libs/libXext
+ x11-libs/libXxf86misc
+ x11-libs/libXxf86vm )
+ virtual/x11 )
+ >=dev-libs/glib-2
+ >=x11-libs/gtk+-2.6
+ ~xfce-base/libxfce4mcs-${PV}
+ ~xfce-base/libxfce4util-${PV}
+ ~xfce-base/libxfcegui4-${PV}
+ ~xfce-base/xfce-mcs-manager-${PV}"
+# need xfce4-dev-tools, since we patch automake and need regeneration
+DEPEND="${RDEPEND}
+ || ( ( x11-proto/xf86miscproto
+ x11-proto/xf86vidmodeproto
+ x11-proto/xproto )
+ virtual/x11 )
+ xfce-extra/xfce4-dev-tools"
+
+XFCE_CONFIG="--enable-xf86misc --enable-xkb --enable-randr --enable-xf86vm"
+
+xfce44_core_package
+
+src_unpack() {
+ unpack ${A}
+ cd ${S}
+ # don't install xfce-filemanager.png, which collides with xfce4-session
+ epatch ${FILESDIR}/${P}-icon.patch
+ # regenerate stuff, but don't run configure yet
+ NOCONFIGURE="true" xdt-autogen
+}
+
+
+pkg_postinst() {
+ gnome2_icon_cache_update
+}
+
+pkg_postrm() {
+ gnome2_icon_cache_update
+}