summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--sys-apps/most/ChangeLog8
-rw-r--r--sys-apps/most/Manifest6
-rw-r--r--sys-apps/most/files/digest-most-4.9.51
-rw-r--r--sys-apps/most/most-4.9.5.ebuild57
4 files changed, 69 insertions, 3 deletions
diff --git a/sys-apps/most/ChangeLog b/sys-apps/most/ChangeLog
index 3315949d99f6..be9442f62037 100644
--- a/sys-apps/most/ChangeLog
+++ b/sys-apps/most/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for sys-apps/most
# Copyright 2002-2004 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sys-apps/most/ChangeLog,v 1.9 2004/06/24 22:18:14 agriffis Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-apps/most/ChangeLog,v 1.10 2004/06/27 23:49:01 ciaranm Exp $
+
+*most-4.9.5 (28 Jun 2004)
+
+ 28 Jun 2004; Ciaran McCreesh <ciaranm@gentoo.org> +most-4.9.5.ebuild:
+ Version bump. Changed the src_install around a bit to make things simpler for
+ arch people. Added in ~sparc ~mips to the supported arch list.
*most-4.9.4 (06 Apr 2004)
diff --git a/sys-apps/most/Manifest b/sys-apps/most/Manifest
index c52b3ec52933..407b37043681 100644
--- a/sys-apps/most/Manifest
+++ b/sys-apps/most/Manifest
@@ -1,6 +1,8 @@
+MD5 fba70acb64e08a898bc826fb6e1f1159 ChangeLog 1591
+MD5 695e0173b19466d3c1b32762dbcfb33e most-4.9.5.ebuild 1380
MD5 c07a740bca356aa092241def89d4f5f6 most-4.9.2.ebuild 948
-MD5 ef02083a8c6847d2a0d983ce6b86b3c6 ChangeLog 1346
-MD5 9a09f8d531c582e78977dbfd96edc1f2 metadata.xml 164
MD5 e5ed898f7010e4ad6719b5ededc42415 most-4.9.4.ebuild 949
+MD5 9a09f8d531c582e78977dbfd96edc1f2 metadata.xml 164
+MD5 f50722839e33523b309eda86c46e465d files/digest-most-4.9.5 62
MD5 a23dcc37cb7e0fb3d5fde35a36d9f270 files/digest-most-4.9.2 61
MD5 fca955f15889eb7ffb4639dd1484ccfa files/digest-most-4.9.4 62
diff --git a/sys-apps/most/files/digest-most-4.9.5 b/sys-apps/most/files/digest-most-4.9.5
new file mode 100644
index 000000000000..b3cd656349c5
--- /dev/null
+++ b/sys-apps/most/files/digest-most-4.9.5
@@ -0,0 +1 @@
+MD5 5c0922952485b0a5822ef994603dcc2f most-4.9.5.tar.gz 117361
diff --git a/sys-apps/most/most-4.9.5.ebuild b/sys-apps/most/most-4.9.5.ebuild
new file mode 100644
index 000000000000..3836e3c5d814
--- /dev/null
+++ b/sys-apps/most/most-4.9.5.ebuild
@@ -0,0 +1,57 @@
+# Copyright 1999-2004 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sys-apps/most/most-4.9.5.ebuild,v 1.1 2004/06/27 23:49:01 ciaranm Exp $
+
+S=${WORKDIR}/${P}
+DESCRIPTION="An extremely excellent text file reader"
+HOMEPAGE="http://freshmeat.net/projects/most/"
+SLOT="0"
+LICENSE="GPL-2"
+SRC_URI="ftp://space.mit.edu/pub/davis/${PN}/${P}.tar.gz"
+IUSE=""
+
+# Note to arch maintainers: you'll need to add to src_install() for your
+# arch, since the app's Makefile does strange things with different
+# directories for each arch. -- ciaranm, 27 June 2004
+KEYWORDS="~x86 ~amd64 -ppc ~sparc ~mips"
+
+DEPEND=">=sys-libs/slang-1.4.2
+ >=sys-libs/ncurses-5.2-r2"
+
+src_compile() {
+ ./configure \
+ --host=${CHOST} \
+ --prefix=/usr \
+ --sysconfdir=/etc || die
+
+ #*possible* (not definite) pmake problems, let's not risk it.
+ make SYS_INITFILE="/etc/most.conf" || die
+}
+
+src_install() {
+ # Changing this to use src/${ARCH}objs/most probably isn't a good
+ # idea...
+ local objsdir
+ case ${ARCH} in
+ x86)
+ objsdir=x86objs
+ ;;
+ amd64)
+ objsdir=amd64objs
+ ;;
+ sparc)
+ objsdir=sparcobjs
+ ;;
+ mips)
+ objsdir=mipsobjs
+ ;;
+ esac
+ dobin src/${objsdir:-objs}/most || die "Couldn't install binary"
+
+ doman most.1
+
+ dodoc COPYING COPYRIGHT README changes.txt
+ docinto txt
+ dodoc default.rc lesskeys.rc most-fun.txt
+}
+