summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--games-fps/quake3/ChangeLog5
-rw-r--r--games-fps/quake3/Manifest20
-rw-r--r--games-fps/quake3/quake3-1.31.ebuild19
3 files changed, 31 insertions, 13 deletions
diff --git a/games-fps/quake3/ChangeLog b/games-fps/quake3/ChangeLog
index 5d095b77d580..ba2223f681e5 100644
--- a/games-fps/quake3/ChangeLog
+++ b/games-fps/quake3/ChangeLog
@@ -1,6 +1,9 @@
# ChangeLog for games-fps/quake3
# Copyright 2002-2004 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/games-fps/quake3/ChangeLog,v 1.12 2004/09/01 20:31:51 wolf31o2 Exp $
+# $Header: /var/cvsroot/gentoo-x86/games-fps/quake3/ChangeLog,v 1.13 2004/12/28 03:30:33 vapier Exp $
+
+ 27 Dec 2004; Mike Frysinger <vapier@gentoo.org> quake3-1.31.ebuild:
+ Add install fixes by Erdroh Moshan #66437.
01 Sep 2004; Chris Gianelloni <wolf31o2@gentoo.org> files/q3ded.rc:
Changing dedicated server user to games from games-ded.
diff --git a/games-fps/quake3/Manifest b/games-fps/quake3/Manifest
index ebcf2fd38011..bfb3f9a027dd 100644
--- a/games-fps/quake3/Manifest
+++ b/games-fps/quake3/Manifest
@@ -1,9 +1,19 @@
-MD5 189d8c6f88f95cb5c7e1ee669247ba7d quake3-1.32b-r3.ebuild 2086
-MD5 188a6836937dbbd05a1916960e52bb88 ChangeLog 2322
+-----BEGIN PGP SIGNED MESSAGE-----
+Hash: SHA1
+
+MD5 6bf44cab3e604c7726a8b73b865908fc ChangeLog 2436
MD5 0a25a9c85ee385ef578cb770a957756d metadata.xml 954
-MD5 d214657b9001a4c2d77fb0da94133290 quake3-1.31.ebuild 1761
-MD5 398efeaa7e416ad1a58e334d37b5ac26 files/q3ded.rc 817
-MD5 2d4f86497a3ba63bc01677f8c306cea5 files/quake3.png 2170
+MD5 7ec4ca6d07522428a96d80dd7a7dcefe quake3-1.31.ebuild 1873
+MD5 189d8c6f88f95cb5c7e1ee669247ba7d quake3-1.32b-r3.ebuild 2086
MD5 aa25102bc1d29a9d3cef6ccb88b87833 files/digest-quake3-1.31 73
MD5 ac0eeb5bcea4995d27e0c6575b8f4dbb files/digest-quake3-1.32b-r3 76
MD5 ccfdb942c238488a3626c63a53574485 files/q3ded.conf.d 305
+MD5 398efeaa7e416ad1a58e334d37b5ac26 files/q3ded.rc 817
+MD5 2d4f86497a3ba63bc01677f8c306cea5 files/quake3.png 2170
+-----BEGIN PGP SIGNATURE-----
+Version: GnuPG v1.9.10 (GNU/Linux)
+
+iD8DBQFB0NNrroRuSHgZdywRAislAJwLFgBIgejKIr85h/iCdhJ/JoUBnQCeM7kp
+T7sJCYZEeFaucMeP67Hc0/U=
+=5Uk9
+-----END PGP SIGNATURE-----
diff --git a/games-fps/quake3/quake3-1.31.ebuild b/games-fps/quake3/quake3-1.31.ebuild
index ac17bfbf0912..4220ca3a73af 100644
--- a/games-fps/quake3/quake3-1.31.ebuild
+++ b/games-fps/quake3/quake3-1.31.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2004 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/games-fps/quake3/quake3-1.31.ebuild,v 1.11 2004/07/14 14:44:32 agriffis Exp $
+# $Header: /var/cvsroot/gentoo-x86/games-fps/quake3/quake3-1.31.ebuild,v 1.12 2004/12/28 03:30:33 vapier Exp $
inherit games
@@ -10,16 +10,23 @@ SRC_URI="ftp://ftp.idsoftware.com/idstuff/quake3/linux/linuxq3apoint-${PV}.x86.r
LICENSE="Q3AEULA"
SLOT="0"
-KEYWORDS="-* x86"
+KEYWORDS="-* amd64 x86"
IUSE="X dedicated opengl"
RESTRICT="nostrip"
RDEPEND="virtual/libc
opengl? ( virtual/opengl )
X? ( virtual/x11 )
- dedicated? ( app-misc/screen )"
+ dedicated? ( app-misc/screen )
+ amd64? (
+ app-emulation/emul-linux-x86-baselibs
+ app-emulation/emul-linux-x86-xlibs
+ app-emulation/emul-linux-x86-nvidia
+ )"
S=${WORKDIR}
+dir=${GAMES_PREFIX_OPT}/${PN}
+Ddir=${D}/${dir}
pkg_setup() {
check_license
@@ -31,19 +38,17 @@ src_unpack() {
}
src_install() {
- local dir=${GAMES_PREFIX_OPT}/${PN}
dodir ${dir}
insinto ${dir}/baseq3
doins baseq3/*.pk3
- mv Docs ${D}/${dir}/
+ mv Help ${Ddir}/
insinto ${dir}/missionpack
doins missionpack/*.pk3
- mv pb ${D}/${dir}/
exeinto ${dir}
insinto ${dir}
- doexe bin/Linux/x86/{quake3.x86,q3ded}
+ doexe bin/x86/{quake3.x86,q3ded}
doins quake3.xpm README* Q3A_EULA.txt
games_make_wrapper quake3 ./quake3.x86 ${dir}
games_make_wrapper q3ded ./q3ded ${dir}