summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'app-admin/realpath/files/realpath-1.9.16-Makefile.patch')
-rw-r--r--app-admin/realpath/files/realpath-1.9.16-Makefile.patch43
1 files changed, 43 insertions, 0 deletions
diff --git a/app-admin/realpath/files/realpath-1.9.16-Makefile.patch b/app-admin/realpath/files/realpath-1.9.16-Makefile.patch
new file mode 100644
index 000000000000..436f1705b4e3
--- /dev/null
+++ b/app-admin/realpath/files/realpath-1.9.16-Makefile.patch
@@ -0,0 +1,43 @@
+diff -Naur dwww-1.9.16-orig/Makefile dwww-1.9.16/Makefile
+--- dwww-1.9.16-orig/Makefile 2003-09-02 14:02:00.000000000 -0600
++++ dwww-1.9.16/Makefile 2007-02-03 19:26:06.000000000 -0600
+@@ -6,24 +6,24 @@
+ VERSION = $(shell dpkg-parsechangelog | sed -ne 's/^Version: *//p')
+
+ CC = gcc
+-CFLAGS = -Wall -Wstrict-prototypes -Wmissing-prototypes -DVERSION='"$(VERSION)"'
+-LDFLAGS =
++CFLAGS += -Wall -Wstrict-prototypes -Wmissing-prototypes -DVERSION='"$(VERSION)"'
++LDFLAGS +=
+ LIBS = -lpub
+
+
+-ifeq (,$(findstring nodebug,$(DEB_BUILD_OPTIONS)))
+- CFLAGS += -g
+-endif
+-
+-ifneq (,$(findstring noopt,$(DEB_BUILD_OPTIONS)))
+- CFLAGS += -O0
+-else
+- CFLAGS += -O2
+-endif
+-
+-ifeq (,$(findstring nostrip,$(DEB_BUILD_OPTIONS)))
+- LDFLAGS += -s
+-endif
++#ifeq (,$(findstring nodebug,$(DEB_BUILD_OPTIONS)))
++# CFLAGS += -g
++#endif
++#
++#ifneq (,$(findstring noopt,$(DEB_BUILD_OPTIONS)))
++# CFLAGS += -O0
++#else
++# CFLAGS += -O2
++#endif
++#
++#ifeq (,$(findstring nostrip,$(DEB_BUILD_OPTIONS)))
++# LDFLAGS += -s
++#endif
+
+
+ prefix = debian/dwww