summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'app-admin/realpath/files/realpath-1.9.28-Makefile.patch')
-rw-r--r--app-admin/realpath/files/realpath-1.9.28-Makefile.patch44
1 files changed, 44 insertions, 0 deletions
diff --git a/app-admin/realpath/files/realpath-1.9.28-Makefile.patch b/app-admin/realpath/files/realpath-1.9.28-Makefile.patch
new file mode 100644
index 000000000000..eeb7e89a26b1
--- /dev/null
+++ b/app-admin/realpath/files/realpath-1.9.28-Makefile.patch
@@ -0,0 +1,44 @@
+diff -Naur dwww-1.9.28-orig/Makefile dwww-1.9.28/Makefile
+--- dwww-1.9.28-orig/Makefile 2006-01-14 05:06:21.000000000 -0600
++++ dwww-1.9.28/Makefile 2007-02-03 19:45:32.000000000 -0600
+@@ -6,25 +6,25 @@
+ VERSION = $(shell dpkg-parsechangelog | sed -ne 's/^Version: *//p')
+
+ CC = gcc
+-CFLAGS = -Wall -Wstrict-prototypes -Wmissing-prototypes -DVERSION='"$(VERSION)"'
+-LDFLAGS =
++CFLAGS += -Wall -Wstrict-prototypes -Wmissing-prototypes -DVERSION='"$(VERSION)"'
++LDFLAGS +=
+ LIBS = -lpub
+ PERL = /usr/bin/perl
+
+
+-ifeq (,$(findstring nodebug,$(DEB_BUILD_OPTIONS)))
+- CFLAGS += -g
+-endif
+-
+-ifneq (,$(findstring noopt,$(DEB_BUILD_OPTIONS)))
+- CFLAGS += -O0
+-else
+- CFLAGS += -O2
+-endif
+-
+-ifeq (,$(findstring nostrip,$(DEB_BUILD_OPTIONS)))
+- LDFLAGS += -s
+-endif
++#ifeq (,$(findstring nodebug,$(DEB_BUILD_OPTIONS)))
++# CFLAGS += -g
++#endif
++#
++#ifneq (,$(findstring noopt,$(DEB_BUILD_OPTIONS)))
++# CFLAGS += -O0
++#else
++# CFLAGS += -O2
++#endif
++#
++#ifeq (,$(findstring nostrip,$(DEB_BUILD_OPTIONS)))
++# LDFLAGS += -s
++#endif
+
+
+ prefix = debian/dwww