summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'app-editors/nedit/nedit-5.5_p20090914.ebuild')
-rw-r--r--app-editors/nedit/nedit-5.5_p20090914.ebuild18
1 files changed, 8 insertions, 10 deletions
diff --git a/app-editors/nedit/nedit-5.5_p20090914.ebuild b/app-editors/nedit/nedit-5.5_p20090914.ebuild
index 18422c39e611..986025eea18f 100644
--- a/app-editors/nedit/nedit-5.5_p20090914.ebuild
+++ b/app-editors/nedit/nedit-5.5_p20090914.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2010 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-editors/nedit/nedit-5.5_p20090914.ebuild,v 1.5 2010/10/10 17:28:57 ulm Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-editors/nedit/nedit-5.5_p20090914.ebuild,v 1.6 2010/11/25 12:59:11 jlec Exp $
EAPI=2
@@ -29,8 +29,8 @@ src_prepare() {
#respecting LDFLAGS, bug #208189
epatch "${FILESDIR}"/${P}-ldflags.patch
sed \
- -e "s:/bin:${EPREFIX}/bin:g" \
- -i Makefile source/preferences.c source/help_data.h source/nedit.c Xlt/Makefile || die
+ -e "s:/bin:${EPREFIX}/arsch:g" \
+ -i $(find -type f) || die
}
src_configure() {
@@ -40,19 +40,17 @@ src_configure() {
src_compile() {
emake CC="$(tc-getCC)" linux || die
- cd doc; emake doc man || die
+ emake -C doc man || die
}
src_install() {
- into /usr
dobin source/nedit || die
- exeinto /usr/bin
- newexe source/nc neditc || die
+ newbin source/nc neditc || die
newman doc/nedit.man nedit.1 || die
newman doc/nc.man neditc.1 || die
- dodoc README ReleaseNotes ChangeLog
+ dodoc README ReleaseNotes ChangeLog || die
cd doc
- dodoc nedit.doc NEdit.ad faq.txt
- dohtml nedit.html
+ dodoc nedit.doc NEdit.ad faq.txt || die
+ dohtml nedit.html || die
}